Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029863
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-05-13 13:092015-06-10 15:50
ReportergorkaionView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision672ff4b32ead
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSLinux 32 bitDatabaseOracleJava version1.5.0_15
OS VersionGentooDatabase version11gAnt version1.7.0
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029863: Multiple Selection Process Definition buttons with reference list shows wrong text

DescriptionHaving a button related to a Process Definition that allows multiple selection. This button has also a list to change the Text based on its value.

When more than one record is selected the text shown is based on the last record loaded in the client. This has the following issues:

1. Open a window in grid mode and click the select all records button. The text shown is the Default name of the process. Unselect some records until all the selected have the same value, the text keeps being the default. Continue unselecting until only one is selected. The text keeps being the default.

2. Open a window and select one record. Check that the text of the button is updated. Now select more records of different statuses. The text does not change. Now unselect until one record of a different status is selected. The text does not change.

Steps To ReproduceCase 1:
0 Log in with Openbravo Admin role in an instance with the F&B client.
1 Open the "Fiscal Calendar" window and select "Calendario EspaƱa".
2 Create a new "Fiscal Year" for year 2016.
3 Click on "Create Periods" and create all the periods.
4 Go to "Open/Close Period Control window."
5 Click on select all records
6 Check that the button has "Open close"
7 Unselect all the periods in "All never opened" status.
8 The button keeps "Open close" but it should be "Close Period"

-----

Case 2:
1 Go to "Open/Close Period Control window."
2 Select two periods in "All Opened" status.
3 Check that the button has "Close Period". OK
4 Select two more records in "All never opened".
5 Check that the button keeps in "Close Period" but it should be "Open Close"


Proposed SolutionWhen records are selected it should be checked their value.

If there are records with different values the text should be the "Name" of the button field.
If all the selected records have the same value the text should be the one related to the value.

This check should be done every time the selection of the grid is changed.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 00298653.0PR15Q3 closedNaroaIriarte Multiple Selection Process Definition buttons with children tabs with reference list shows wrong text 
related to defect 00298673.0PR15Q3 closeddbaz Grid multiple selection is lost on refresh 

-  Notes
(0078086)
hgbot (developer)
2015-06-04 16:55

Repository: erp/devel/pi
Changeset: 672ff4b32ead2412881ddc6ed4d5dfdddcf37d14
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Jun 04 16:53:27 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/672ff4b32ead2412881ddc6ed4d5dfdddcf37d14 [^]

Fixed issue 29863: Title of process buttons are not showing the correct text.

When a process button allows multiple selection, the text shown in the button was not correct.

The problem was that the code for handling the change of the text inside a process button, that allows multiple selection,
didn't exist before.
To fix this the code needed to deal with the change of the name of the button for multiple selection has been created.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0078124)
hudsonbot (developer)
2015-06-06 16:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7419f65cdeb3 [^]
Maturity status: Test
(0078183)
alostale (developer)
2015-06-10 15:50

code reviewed

tested as defined in steps to reproduce + refreshing with single/multiple selection

- Issue History
Date Modified Username Field Change
2015-05-13 13:09 gorkaion New Issue
2015-05-13 13:09 gorkaion Assigned To => platform
2015-05-13 13:09 gorkaion Modules => Core
2015-05-13 13:09 gorkaion Triggers an Emergency Pack => No
2015-05-13 13:28 gorkaion Issue cloned 0029865
2015-05-13 13:28 gorkaion Relationship added related to 0029865
2015-05-13 13:52 gorkaion Relationship added related to 0029867
2015-05-13 16:42 jonalegriaesarte Target Version => 3.0PR15Q3
2015-05-13 18:25 gorkaion Priority normal => immediate
2015-05-15 12:30 alostale Status new => acknowledged
2015-05-27 15:48 alostale Status acknowledged => scheduled
2015-05-27 15:48 alostale Assigned To platform => inigosanchez
2015-06-02 14:51 NaroaIriarte Assigned To inigosanchez => NaroaIriarte
2015-06-03 16:27 NaroaIriarte Steps to Reproduce Updated View Revisions
2015-06-04 10:21 NaroaIriarte Issue Monitored: alostale
2015-06-04 10:21 NaroaIriarte Review Assigned To => alostale
2015-06-04 16:55 hgbot Checkin
2015-06-04 16:55 hgbot Note Added: 0078086
2015-06-04 16:55 hgbot Status scheduled => resolved
2015-06-04 16:55 hgbot Resolution open => fixed
2015-06-04 16:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/672ff4b32ead2412881ddc6ed4d5dfdddcf37d14 [^]
2015-06-05 09:54 NaroaIriarte Relationship replaced has duplicate 0029865
2015-06-06 16:53 hudsonbot Checkin
2015-06-06 16:53 hudsonbot Note Added: 0078124
2015-06-10 15:50 alostale Note Added: 0078183
2015-06-10 15:50 alostale Status resolved => closed
2015-06-10 15:50 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker