Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029767
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-05-04 18:112015-06-09 17:01
ReportermaiteView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision72e2b8bfe6fc
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029767: "Display logic for grid column" not working for Organization, Business Partner and Product dimensions

Description"Display logic for grid column" not working for Organization, Business Partner and Product dimensions
Steps To Reproduce1. Access "Client" window an verify that Business Partner and Project dimensions are configured to be shown in Header and Line
2. Access "Dimensions" tab, search by "AP Invoice" and "Business Partner" and delete record (to ensure that is configured similar to Project dimension)
3. Logout / login
4. Access Purchase Invoice window. Search by any invoice "Not Paid" and run "Add payment" process
5. Access "GL Item" section and realize that Business Partner dimension does not directly appear in grid. However Project dimension appears

Debugging "evaluateDisplayLogicForGridColumns" javascript function, when evaluating "contextInfo" variable there is element for project ("Element_PJ_API_H") but not for BP, ORG, PRODUCT
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0039444 newTriage Finance Openbravo ERP Display logic for grid column not working for Organization and Product dimensions 
related to defect 0029840 acknowledgedplatform Openbravo ERP DimensionDisplayUtility is not called when opening AddPayment process definition with the + button 
related to defect 00301083.0PR15Q3 closedaferraz Openbravo ERP Business Partner field not shown in Payment In/Out Header in F&B client 
related to defect 0030677 closedaferraz Modules "Display logic for grid column" not working for accounting dimensions 
causes defect 0031015 closedvmromanos Openbravo ERP ON the sales order window when selecting a organization that has not got document types some fields are hidden 
causes defect 0033040 closedSanjota Openbravo ERP Unhomogeneous behavior depending on Org Access when role is defined at "Organization" user level 

-  Notes
(0077300)
hgbot (developer)
2015-05-11 17:50

Repository: erp/devel/pi
Changeset: 72e2b8bfe6fcf24641d900e00cdb6c38a0731483
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu May 07 11:03:35 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/72e2b8bfe6fcf24641d900e00cdb6c38a0731483 [^]

Fixes issue 29767: "Display logic for grid column" not working

GL Items grid in Add Payment process is not showing accounting dimensions correctly.
The problem was that "Organization" and "Business Partner" fields didn't have display logic defined as "Cost Center", "Project", "1st Dimension" and "2nd Dimension" had, for "Purchase Order", "Sales Order", "Purchase Invoice", "Sales Invoice", "Payment In" and "Payment Out windows", because they were mandatory.
@ACCT_DIMENSION_DISPLAY@ display logic has been added to those fields for those windows.
Now, when executing computeAccountingDimensionDisplayLogic in DimensionDisplayUtility, "Organization" and "Business Partner" fields will be included. Then, contextInfo variable in evaluateDisplayLogicForGridColumns function in ob-pick-and-execute-grid.js will have the proper values for Business Partner and Organization.

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0077303)
Sandrahuguet (developer)
2015-05-11 18:00

Code review + testing OK
(0077304)
Sandrahuguet (developer)
2015-05-11 18:06
edited on: 2015-05-11 18:06

Dimension display logic is not working when add payment is open from '+' button (add payment reference).
Issue: https://issues.openbravo.com/view.php?id=29840 [^]

(0077347)
hudsonbot (developer)
2015-05-12 17:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6d9fee60cdbd [^]
Maturity status: Test
(0078160)
ngarcia (developer)
2015-06-09 16:59

Solved for Organization and Business Partner, not for Product as the Dimension is not available in document's header

- Issue History
Date Modified Username Field Change
2015-05-04 18:11 maite New Issue
2015-05-04 18:11 maite Assigned To => Triage Finance
2015-05-04 18:11 maite Modules => Core
2015-05-04 18:11 maite Triggers an Emergency Pack => No
2015-05-04 18:14 maite Steps to Reproduce Updated View Revisions
2015-05-04 18:14 maite Issue Monitored: networkb
2015-05-06 17:54 aferraz Status new => scheduled
2015-05-06 17:54 aferraz Assigned To Triage Finance => aferraz
2015-05-07 17:53 Sandrahuguet Review Assigned To => Sandrahuguet
2015-05-11 11:12 aferraz Relationship added related to 0029840
2015-05-11 17:50 hgbot Checkin
2015-05-11 17:50 hgbot Note Added: 0077300
2015-05-11 17:50 hgbot Status scheduled => resolved
2015-05-11 17:50 hgbot Resolution open => fixed
2015-05-11 17:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/72e2b8bfe6fcf24641d900e00cdb6c38a0731483 [^]
2015-05-11 18:00 Sandrahuguet Note Added: 0077303
2015-05-11 18:00 Sandrahuguet Status resolved => closed
2015-05-11 18:00 Sandrahuguet Fixed in Version => 3.0PR15Q3
2015-05-11 18:06 Sandrahuguet Note Added: 0077304
2015-05-11 18:06 Sandrahuguet Note Edited: 0077304 View Revisions
2015-05-12 17:40 hudsonbot Checkin
2015-05-12 17:40 hudsonbot Note Added: 0077347
2015-06-05 10:09 aferraz Relationship added causes 0030108
2015-06-05 12:06 aferraz Relationship deleted causes 0030108
2015-06-05 12:07 aferraz Relationship added related to 0030108
2015-06-09 16:59 ngarcia Note Added: 0078160
2015-06-09 17:01 ngarcia Issue Monitored: ngarcia
2015-08-26 12:47 maite Relationship added related to 0030677
2015-10-02 10:00 vmromanos Relationship added causes 0031015
2016-05-30 11:53 aferraz Relationship added related to 0033040
2016-05-31 13:23 aferraz Relationship deleted related to 0033040
2016-05-31 13:23 aferraz Relationship added causes 0033040
2018-10-15 09:42 anderaranguren Relationship added related to 0039444
2018-10-16 08:53 anderaranguren Relationship replaced blocks 0039444
2018-10-16 08:53 anderaranguren Relationship deleted blocks 0039444
2018-10-16 08:54 anderaranguren Relationship added has duplicate 0039444


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker