Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029739
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-29 18:202015-06-12 16:59
ReporterioritzCiaView Statuspublic 
Assigned ToTriage Finance 
PriorityhighResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revision2a66cd73cfe8
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version6
OS VersionUbuntu 14.04Database version9.3Ant version
Product Version3.0PR15Q1SCM revision 
Review Assigned ToioritzCia
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029739: Costing Background process takes most of the time of execution on a system

DescriptionDepending on the system the Costing Background process can take up to a 25% of the execution time of the whole server.

We will provide more details when possible.

We have a clone of the environment.
Steps To ReproduceYou need to enter the system and analyze execution times.

Ask for already executed analysis.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029708 closedumartirena The costing background process is very slow 

-  Notes
(0076885)
ioritzCia (developer)
2015-04-29 18:43

This particular instance has 7 background processes configured each one for one of their 7 orgs. This is like this, so that if the background process stops calculating one cost for a particular org the rest of the costs of the rest of the orgs keep being calculated. If we fixed this, so that one single process would not stop calculating costs of other organizations, they could schedule one single process.
(0076914)
ioritzCia (developer)
2015-04-30 13:32

Issue 29708 complains about large execution of the process, which does not happen here as the process is executed frequently. Even if it is executed frequently, takes an average of 4'5 seconds to execute and it gets executed a huge amount of times, there should be a way to improve this.
(0078221)
hgbot (developer)
2015-06-11 18:29

Repository: erp/devel/pi
Changeset: 2a66cd73cfe8a9b37ecd30545b8e6fcc77cd0e5b
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Jun 11 18:28:02 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2a66cd73cfe8a9b37ecd30545b8e6fcc77cd0e5b [^]

Fixes Issue 29739. Adds Indexes for isProcess and IsCostCalculated columns
to improve performance in Costing Background Process Queries.

---
M src-db/database/model/tables/M_TRANSACTION.xml
---
(0078227)
ioritzCia (developer)
2015-06-12 09:29

Tested and verified in the cloned environment.
(0078258)
hudsonbot (developer)
2015-06-12 16:59

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ebf462f93acf [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-29 18:20 ioritzCia New Issue
2015-04-29 18:20 ioritzCia Assigned To => Triage Finance
2015-04-29 18:20 ioritzCia Web browser => Google Chrome
2015-04-29 18:20 ioritzCia Modules => Core
2015-04-29 18:20 ioritzCia Triggers an Emergency Pack => No
2015-04-29 18:21 ioritzCia Tag Attached: Performance
2015-04-29 18:23 shuehner Issue Monitored: shuehner
2015-04-29 18:43 ioritzCia Web browser Google Chrome => Google Chrome
2015-04-29 18:43 ioritzCia Note Added: 0076885
2015-04-30 13:25 ioritzCia Review Assigned To => ioritzCia
2015-04-30 13:25 ioritzCia Relationship added duplicate of 0029708
2015-04-30 13:25 ioritzCia Status new => closed
2015-04-30 13:25 ioritzCia Resolution open => duplicate
2015-04-30 13:30 ioritzCia Status closed => new
2015-04-30 13:30 ioritzCia Resolution duplicate => open
2015-04-30 13:30 ioritzCia Relationship deleted 0029708
2015-04-30 13:30 ioritzCia Relationship added related to 0029708
2015-04-30 13:32 ioritzCia Note Added: 0076914
2015-04-30 13:39 egoitz Web browser Google Chrome => Google Chrome
2015-04-30 13:44 egoitz Issue Monitored: egoitz
2015-06-11 18:29 hgbot Checkin
2015-06-11 18:29 hgbot Note Added: 0078221
2015-06-11 18:29 hgbot Status new => resolved
2015-06-11 18:29 hgbot Resolution open => fixed
2015-06-11 18:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2a66cd73cfe8a9b37ecd30545b8e6fcc77cd0e5b [^]
2015-06-12 09:29 ioritzCia Note Added: 0078227
2015-06-12 09:29 ioritzCia Status resolved => closed
2015-06-12 09:29 ioritzCia Fixed in Version => 3.0PR15Q4
2015-06-12 16:59 hudsonbot Checkin
2015-06-12 16:59 hudsonbot Note Added: 0078258


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker