Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029675
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. PlatformtrivialN/A2015-04-23 07:562015-06-30 20:44
ReporteralostaleView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionfcc755f5f885
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029675: check DB and Tomcat have the same time at Tomcat start

DescriptionTomcat and DB should be configured to use the same timezone in order to guarantee system consistency.

A check should be implemented to warn in case they are differently configured.
Steps To Reproduce-
Proposed SolutionWhen starting Tomcat DB is queried to check its time and compared with time obtained in java, if there is a difference bigger than a few seconds, log a warning.

This can be implemented as a ApplicationInitializer [1].

[1] http://wiki.openbravo.com/wiki/Openbravo_3_Architecture#Implement_Application_Initialization_Logic [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate feature request 0019671 closedalostale Create new check with verifies that postgres timezone == system (tomcat-server) timezone 
related to feature request 00301873.0PR15Q3 closedcaristu prevent build in unsupported PG verrsions 

-  Notes
(0078394)
hgbot (developer)
2015-06-19 12:55

Repository: erp/devel/pi
Changeset: fcc755f5f885f4af5dbfca37607530e07640c23c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jun 19 12:54:35 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fcc755f5f885f4af5dbfca37607530e07640c23c [^]

Fixes issue 29675: check DB and Tomcat have the same time at Tomcat start

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelApplicationInitializer.java
M src/org/openbravo/erpCommon/utility/DateTime_data.xsql
---
(0078400)
hudsonbot (developer)
2015-06-19 23:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/53058d80de1d [^]
Maturity status: Test
(0078467)
hgbot (developer)
2015-06-24 09:20

Repository: erp/devel/pi
Changeset: 11fe473f73e6399957d2c17cade08ae1cf37752d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jun 24 09:19:24 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/11fe473f73e6399957d2c17cade08ae1cf37752d [^]

Related to issue 29675: Added log messages in case of error

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelApplicationInitializer.java
---
(0078474)
hgbot (developer)
2015-06-24 10:22

Repository: erp/devel/pi
Changeset: 3a6f672bc73fd79f34a225157a6ad12603b2f527
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jun 24 10:21:18 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3a6f672bc73fd79f34a225157a6ad12603b2f527 [^]

Related to issue 29675: Added the exception to log in error messages

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelApplicationInitializer.java
---
(0078490)
hudsonbot (developer)
2015-06-24 16:03

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cf8c31083813 [^]
Maturity status: Test
(0078515)
hgbot (developer)
2015-06-25 16:43

Repository: erp/devel/pi
Changeset: 431da3d3ec953b35f3d435b1b04fe2ddcf2799f9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jun 25 16:42:32 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/431da3d3ec953b35f3d435b1b04fe2ddcf2799f9 [^]

Related to issue 29675: change to show message in debug mode

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelApplicationInitializer.java
---
(0078517)
hudsonbot (developer)
2015-06-25 18:00

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/65f6b2e875a7 [^]
Maturity status: Test
(0078519)
AugustoMauch (developer)
2015-06-25 18:19

Code reviewed and verified in pi@431da3d3ec95

Tested with postgresql and oracle
(0078545)
hudsonbot (developer)
2015-06-26 15:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/60ba8db95a9d [^]
Maturity status: Test
(0078580)
hgbot (developer)
2015-06-30 09:05

Repository: erp/devel/pi
Changeset: 59a8db5a95cb3d4c2e8ab0ff788c22123ee994a5
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jun 30 09:04:31 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/59a8db5a95cb3d4c2e8ab0ff788c22123ee994a5 [^]

Related to issue 29675: improvements in log messages

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelApplicationInitializer.java
---
(0078581)
hgbot (developer)
2015-06-30 09:08

Repository: erp/devel/pi
Changeset: 9d2b4c014bca6394b2a0225d0a8a5885bc4f2f21
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jun 30 09:08:18 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9d2b4c014bca6394b2a0225d0a8a5885bc4f2f21 [^]

Related to issue 29675: fix in comment

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelApplicationInitializer.java
---
(0078598)
hudsonbot (developer)
2015-06-30 20:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a0fd6a76a3d5 [^]
Maturity status: Test
(0078599)
hudsonbot (developer)
2015-06-30 20:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a0fd6a76a3d5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-23 07:56 alostale New Issue
2015-04-23 07:56 alostale Assigned To => platform
2015-04-23 07:56 alostale Modules => Core
2015-04-23 07:56 alostale Triggers an Emergency Pack => No
2015-04-23 10:50 shuehner Issue Monitored: shuehner
2015-06-16 11:24 alostale Relationship added related to 0030187
2015-06-16 11:25 alostale Status new => scheduled
2015-06-16 11:25 alostale Assigned To platform => caristu
2015-06-16 11:29 alostale Proposed Solution updated
2015-06-19 12:43 caristu Review Assigned To => alostale
2015-06-19 12:43 caristu Issue Monitored: alostale
2015-06-19 12:55 hgbot Checkin
2015-06-19 12:55 hgbot Note Added: 0078394
2015-06-19 12:55 hgbot Status scheduled => resolved
2015-06-19 12:55 hgbot Resolution open => fixed
2015-06-19 12:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fcc755f5f885f4af5dbfca37607530e07640c23c [^]
2015-06-19 23:57 hudsonbot Checkin
2015-06-19 23:57 hudsonbot Note Added: 0078400
2015-06-22 19:41 caristu Issue Monitored: AugustoMauch
2015-06-22 19:41 caristu Review Assigned To alostale => AugustoMauch
2015-06-24 09:20 hgbot Checkin
2015-06-24 09:20 hgbot Note Added: 0078467
2015-06-24 10:22 hgbot Checkin
2015-06-24 10:22 hgbot Note Added: 0078474
2015-06-24 16:03 hudsonbot Checkin
2015-06-24 16:03 hudsonbot Note Added: 0078490
2015-06-25 16:43 hgbot Checkin
2015-06-25 16:43 hgbot Note Added: 0078515
2015-06-25 18:00 hudsonbot Checkin
2015-06-25 18:00 hudsonbot Note Added: 0078517
2015-06-25 18:19 AugustoMauch Note Added: 0078519
2015-06-25 18:19 AugustoMauch Status resolved => closed
2015-06-25 18:19 AugustoMauch Fixed in Version => 3.0PR15Q3
2015-06-26 15:57 hudsonbot Checkin
2015-06-26 15:57 hudsonbot Note Added: 0078545
2015-06-30 09:05 hgbot Checkin
2015-06-30 09:05 hgbot Note Added: 0078580
2015-06-30 09:08 hgbot Checkin
2015-06-30 09:08 hgbot Note Added: 0078581
2015-06-30 20:44 hudsonbot Checkin
2015-06-30 20:44 hudsonbot Note Added: 0078598
2015-06-30 20:44 hudsonbot Checkin
2015-06-30 20:44 hudsonbot Note Added: 0078599
2016-03-24 07:58 alostale Relationship added duplicate of 0019671
2016-03-24 07:59 alostale Relationship replaced has duplicate 0019671


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker