Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029605
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-04-15 18:492016-02-02 09:34
ReportermalsasuaView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision7f6f8501e762
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-09-23
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
Triggers an Emergency PackNo
Summary

0029605: foreign currency and foreign amount are not assigned in transaction

Descriptionwhen a transaction is created manually (with "new" button and "process" button), the foreign currency and foreign amount is not assigned, and error is returned when transaction is posted
Steps To Reproduce. in F&B
. price list window:
 Otros Servicios
 . change currency from EUR to USD

. financial account window:
 Cuenta de Banco -> Payment Method -> transferencia
  . Make Payments in Multiple Currency -> select
  . automatic drawals -> unselect

. purchase invoice window:
 new record:
  . org: F&B España SA
  . bp: Generación Eléctrica
 . new line:
  product: electricidad
  qty: 100
process it
(invoice currency: USD)
Add Details
 .paid it and not reconcile:
    "Action Regarding Document" -> Pocess Made Payments

go to fincial account "Cuenta de Banco"
 . new transaction: select the above payment
 . process it
 . post it: error is returned:
Process failed during execution

TagsNo tags attached.
Attached Files? file icon 29605.sql [^] (493 bytes) 2015-05-18 12:50

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00296333.0PR15Q2 closedaferraz foreign currency and foreign amount are not assigned in transaction 
depends on backport 00296343.0PR15Q1.4 closedaferraz foreign currency and foreign amount are not assigned in transaction 
caused by feature request 0029387 closedSandrahuguet Transaction refactor project 

-  Notes
(0076622)
aferraz (developer)
2015-04-20 10:27

Test plan:

In F&B:
. price list window:
 Otros Servicios
 . change currency from EUR to USD

. financial account window:
 Cuenta de Banco -> Payment Method -> transferencia
  . Make Payments in Multiple Currency -> select
  . automatic drawals -> unselect

. purchase invoice window:
 new record:
  . org: F&B España SA
  . bp: Generación Eléctrica
 . new line:
  product: electricidad
  qty: 100
process it
(invoice currency: USD)
Add Details
 .paid it and not reconcile:
    "Action Regarding Document" -> Pocess Made Payments

go to fincial account "Cuenta de Banco"
 . new transaction: select the above payment
 . process it
 . post it

Realize transaction is posted correctly
(0076658)
hgbot (developer)
2015-04-21 13:52

Repository: erp/devel/pi
Changeset: 7f6f8501e7628ca753738013cfc0641093e2a5d2
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Apr 21 11:04:04 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7f6f8501e7628ca753738013cfc0641093e2a5d2 [^]

Fixes issue 29605: Foreign currency not setted in transaction

When creating a transaction manually from a payment, foreign currency, foreign conversion rate and foreign amount fields were not setted to transaction. Now, they will be setted as in TransactionDao.java, when the transaction is automatically created from the payment.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_TransactionProcess.java
---
(0076659)
vmromanos (developer)
2015-04-21 13:52

Code review + testing OK
(0077139)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077527)
aferraz (developer)
2015-05-18 12:51

Attached a query to fix wrong data created by the issue
(0083802)
hgbot (developer)
2016-02-02 09:34

Repository: tools/automation/int
Changeset: 50555365e65c4d4edc7cd50cb4488c154d6c14b5
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Sep 18 18:56:43 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/50555365e65c4d4edc7cd50cb4488c154d6c14b5 [^]

Related to issue 29605: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/data/financial/receivablespayables/transactions/financialaccount/TransactionsData.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression012.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression013.java
---

- Issue History
Date Modified Username Field Change
2015-04-15 18:49 malsasua New Issue
2015-04-15 18:49 malsasua Assigned To => Triage Finance
2015-04-15 18:49 malsasua Modules => Core
2015-04-15 18:49 malsasua Triggers an Emergency Pack => No
2015-04-17 10:12 maite Issue Monitored: networkb
2015-04-17 14:07 aferraz Relationship added caused by 0029387
2015-04-17 14:08 aferraz Regression level => Production - QA Approved
2015-04-17 14:08 aferraz Regression date => 2014-09-23
2015-04-17 14:08 aferraz Regression introduced in release => 3.0PR14Q4
2015-04-17 14:08 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2015-04-17 14:51 aferraz Priority high => immediate
2015-04-20 10:27 aferraz Note Added: 0076622
2015-04-20 10:31 aferraz Status new => scheduled
2015-04-20 10:31 aferraz Assigned To Triage Finance => aferraz
2015-04-21 13:10 aferraz Regression level Production - QA Approved => Production - Confirmed Stable
2015-04-21 13:52 hgbot Checkin
2015-04-21 13:52 hgbot Note Added: 0076658
2015-04-21 13:52 hgbot Status scheduled => resolved
2015-04-21 13:52 hgbot Resolution open => fixed
2015-04-21 13:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7f6f8501e7628ca753738013cfc0641093e2a5d2 [^]
2015-04-21 13:52 vmromanos Review Assigned To => vmromanos
2015-04-21 13:52 vmromanos Note Added: 0076659
2015-04-21 13:52 vmromanos Status resolved => closed
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077139
2015-05-18 12:50 aferraz File Added: 29605.sql
2015-05-18 12:51 aferraz Note Added: 0077527
2016-02-02 09:34 hgbot Checkin
2016-02-02 09:34 hgbot Note Added: 0083802


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker