Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029602
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-04-15 17:082015-06-04 11:18
ReporterVictorVillarView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision8721a7b97a6b
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029602: A Window should be read only when is assigned with a table defined as view

DescriptionA Window should be read only when is assigned with a table defined as view
Steps To ReproduceAs System Administrator,
  Go to Tables and Columns window,
     select the m_product_category and define it as a View.
Compile.

As Group Admin role,
  Go to Product Category window:
     Try to create and save a new register.
You receive the following error message: Unknown entity org.openbravo.model.common.plm ProductCategory
TagsNo tags attached.
Attached Files? file icon FixIssue29602.export [^] (1,869 bytes) 2015-05-27 16:30

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0077824)
inigosanchez (developer)
2015-05-27 16:30

Attached file is the solution of the issue. Waiting for some feedback...
(0077907)
hgbot (developer)
2015-05-31 19:48

Repository: erp/devel/pi
Changeset: a6e31121bf797dc96d6f4248e12a065e950f444e
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri May 29 13:58:50 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a6e31121bf797dc96d6f4248e12a065e950f444e [^]

Related issue 29602: Changed UI pattern to read only mode in some tabs

The problem was that some tabs have their UI patterns wrong.They are
not set properly.

Now it have been solved by updating the UI Pattern to read only mode.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_TAB.xml
M src-db/database/sourcedata/AD_TAB.xml
---
(0077911)
hgbot (developer)
2015-06-01 09:25

Repository: erp/devel/pi
Changeset: 099550fa4baade9724bd4477e09e5f4d6c80092f
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed May 27 16:27:00 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/099550fa4baade9724bd4477e09e5f4d6c80092f [^]

Fixed issue 29602: window with table defined as view should be RO

The problem was that if you had a window that was assigned with a
table defined as view you could edited.

Now, it is taking into account this condition by checking windows
(Type window "M" and "T").

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/WindowSettingsActionHandler.java
---
(0077939)
alostale (developer)
2015-06-01 13:10

reopening due to code review: tab to check shouldn't be obtained from table's window but directly from the current window.
(0077945)
hgbot (developer)
2015-06-01 13:48

Repository: erp/devel/pi
Changeset: 8721a7b97a6b759e23e7b1947fb75ab96c6f0584
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Jun 01 13:16:02 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8721a7b97a6b759e23e7b1947fb75ab96c6f0584 [^]

Fixed issue 29602: tab to check shouldn't be obtained from table's window

The problem was that tab to check shouldn't be obtained from table's window
but directly from the current window. Now it is taking into account.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/WindowSettingsActionHandler.java
---
(0077950)
hgbot (developer)
2015-06-01 17:32

Repository: erp/devel/pi
Changeset: d4644c111852bd65acc7ed2ae7eaaa5b32f8e582
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Jun 01 17:30:38 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d4644c111852bd65acc7ed2ae7eaaa5b32f8e582 [^]

Related issue 29602:wrong position of parenthesis in a condition

The problem was the wrong position of parenthesis in a condicion. Now it has been solved
by updating position of parenthesis properly,

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/WindowSettingsActionHandler.java
---
(0077960)
hudsonbot (developer)
2015-06-02 03:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/14de467bd788 [^]
Maturity status: Test
(0077961)
hudsonbot (developer)
2015-06-02 03:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/14de467bd788 [^]
Maturity status: Test
(0077967)
hudsonbot (developer)
2015-06-02 03:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/14de467bd788 [^]
Maturity status: Test
(0077968)
hudsonbot (developer)
2015-06-02 03:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/14de467bd788 [^]
Maturity status: Test
(0078054)
alostale (developer)
2015-06-04 11:18

code reviewed

tested read only is correctly forcefully applied to views and preserved in other cases

- Issue History
Date Modified Username Field Change
2015-04-15 17:08 VictorVillar New Issue
2015-04-15 17:08 VictorVillar Assigned To => platform
2015-04-15 17:08 VictorVillar Modules => Core
2015-04-15 17:08 VictorVillar Triggers an Emergency Pack => No
2015-04-15 17:08 VictorVillar Issue Monitored: networkb
2015-04-16 08:31 alostale Status new => acknowledged
2015-05-26 09:43 alostale Status acknowledged => scheduled
2015-05-26 09:43 alostale Assigned To platform => NaroaIriarte
2015-05-26 13:16 inigosanchez Assigned To NaroaIriarte => inigosanchez
2015-05-27 16:30 inigosanchez File Added: FixIssue29602.export
2015-05-27 16:30 inigosanchez Note Added: 0077824
2015-05-31 19:48 hgbot Checkin
2015-05-31 19:48 hgbot Note Added: 0077907
2015-06-01 09:23 inigosanchez Issue Monitored: alostale
2015-06-01 09:24 inigosanchez Review Assigned To => alostale
2015-06-01 09:25 hgbot Checkin
2015-06-01 09:25 hgbot Note Added: 0077911
2015-06-01 09:25 hgbot Status scheduled => resolved
2015-06-01 09:25 hgbot Resolution open => fixed
2015-06-01 09:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/099550fa4baade9724bd4477e09e5f4d6c80092f [^]
2015-06-01 13:10 alostale Note Added: 0077939
2015-06-01 13:10 alostale Status resolved => new
2015-06-01 13:10 alostale Resolution fixed => open
2015-06-01 13:48 hgbot Checkin
2015-06-01 13:48 hgbot Note Added: 0077945
2015-06-01 13:48 hgbot Status new => resolved
2015-06-01 13:48 hgbot Resolution open => fixed
2015-06-01 13:48 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/099550fa4baade9724bd4477e09e5f4d6c80092f [^] => http://code.openbravo.com/erp/devel/pi/rev/8721a7b97a6b759e23e7b1947fb75ab96c6f0584 [^]
2015-06-01 17:32 hgbot Checkin
2015-06-01 17:32 hgbot Note Added: 0077950
2015-06-02 03:42 hudsonbot Checkin
2015-06-02 03:42 hudsonbot Note Added: 0077960
2015-06-02 03:42 hudsonbot Checkin
2015-06-02 03:42 hudsonbot Note Added: 0077961
2015-06-02 03:42 hudsonbot Checkin
2015-06-02 03:42 hudsonbot Note Added: 0077967
2015-06-02 03:42 hudsonbot Checkin
2015-06-02 03:42 hudsonbot Note Added: 0077968
2015-06-04 11:18 alostale Note Added: 0078054
2015-06-04 11:18 alostale Status resolved => closed
2015-06-04 11:18 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker