Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029574
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-13 16:542015-05-07 22:16
ReporterVictorVillarView Statuspublic 
Assigned Tojorge-garcia 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision8ca445154dbb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029574: It is not possible to reactivate a Landed Cost under some circumstancies

DescriptionIt is not possible to reactivate a Landed Cost under some circumstancies. Necessary to have more than 100 registers in M_LC_ReceiptLine_Amt table. For instance, 1 Goods receipt with 200 lines and one landed cost affecting to this Landed Cost.
Steps To ReproduceNecessary to have more than 100 registers in M_LC_ReceiptLine_Amt table. For instance, 1 Goods receipt with 200 lines and one landed cost affecting to this Landed Cost.
Once you have completed it and you try to reactivate it, you receive the following error:

'a different object with the same identifier value was already associated with the session: [LandedCostReceiptLineAmt#38B8F2EA56834B20A02AB4C111E5903D]'

It seems that the problem is in LandedCostDistributionAlgorithm.java -- method: cancelDistributeAmount.

OBDal.getInstance().save(lcCost);

Proposed SolutionWe have checked in the client's environment that the following change is fixing the problem.

List<String> idList = OBDao.getIDListFromOBObject(lcCost.getLandedCostReceiptLineAmtList());
++++ OBDal.getInstance().save(lcCost);

      for (String id : idList) {
        i++;
        LCReceiptLineAmt lcrla = OBDal.getInstance().get(LCReceiptLineAmt.class, id);
        lcCost.getLandedCostReceiptLineAmtList().remove(lcrla);
        OBDal.getInstance().remove(lcrla);
               if (i % 100 == 0) {
----- OBDal.getInstance().save(lcCost);
          OBDal.getInstance().flush();
          OBDal.getInstance().getSession().clear();
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00295843.0PR15Q2 closedjorge-garcia It is not possible to reactivate a Landed Cost under some circumstancies 
depends on backport 00295853.0PR15Q1.3 closedjorge-garcia It is not possible to reactivate a Landed Cost under some circumstancies 

-  Notes
(0076537)
hgbot (developer)
2015-04-14 18:04

Repository: erp/devel/pi
Changeset: 8ca445154dbb2682bc9f2b085ffb09a5febdaccb
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Apr 14 09:56:20 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8ca445154dbb2682bc9f2b085ffb09a5febdaccb [^]

Fixed issue 29574: It is not possible to reactivate a Landed Cost

It is not possible to reactivate a Landed Cost under some circunstances.
The problem was fixed from the LandedCostDistributionAlgorithm.java

When you try to reactivate a Landed Cost, an error message appears and
the process was cancelled

Now the process is done succesfully and the Landed Cost can be reactivated.

---
M src/org/openbravo/costing/LandedCostDistributionAlgorithm.java
---
(0076543)
umartirena (developer)
2015-04-14 19:19

Code Review + Testing OK
(0077126)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-13 16:54 VictorVillar New Issue
2015-04-13 16:54 VictorVillar Assigned To => umartirena
2015-04-13 16:54 VictorVillar Modules => Core
2015-04-13 16:54 VictorVillar Triggers an Emergency Pack => No
2015-04-13 16:54 VictorVillar Issue Monitored: networkb
2015-04-14 12:48 Triage Finance Assigned To umartirena => Triage Finance
2015-04-14 17:17 umartirena Status new => scheduled
2015-04-14 17:24 eduardo_Argal Assigned To Triage Finance => jorge-garcia
2015-04-14 18:04 hgbot Checkin
2015-04-14 18:04 hgbot Note Added: 0076537
2015-04-14 18:04 hgbot Status scheduled => resolved
2015-04-14 18:04 hgbot Resolution open => fixed
2015-04-14 18:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8ca445154dbb2682bc9f2b085ffb09a5febdaccb [^]
2015-04-14 19:19 umartirena Review Assigned To => umartirena
2015-04-14 19:19 umartirena Note Added: 0076543
2015-04-14 19:19 umartirena Status resolved => closed
2015-04-14 19:19 umartirena Fixed in Version => pi
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077126


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker