Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029571
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-13 12:582015-07-02 11:51
ReporterngarciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisionaa5e62559ffb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029571: In Physical Inventory Lines, Book Quantity is not updated to 0 by Update Quantity process if product has a mandatory attribute

DescriptionIn Physical Inventory Lines, Book Quantity is not updated to 0 by Update Quantity process if product has a mandatory attribute
Steps To ReproduceAs group admin role:
   Create a Product and set an attribute set to it, that is defined as Require At Least One Value
   Create a Goods Receipt for that product, assign an attribute set value and complete it
   Create a physical inventory and add that product with Quantity Count = Book Quantity. Do not complete it
   Create a Goods Shipment in order to leave the stock of the product to 0. Complete it
   Launch the Update Quantity process in the Physical Inventory and check the Book Quantity is not updated to 0
   Increase the Quantity Count and process the inventory
   Check the stock of the product is not the value introduced in the Quantity Count field but the difference between Quantity Count and Book Quantity
Proposed SolutionIt should be analyzed if that records should not be deleted from the M_STORAGE_DETAIL table or if the Update Quantity should update the Book Quantity to 0 when there is not an associated record in the M_STORAGE_DETAIL table
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00201593.0MP11 closedjecharri Product with mandatory attribute should not generate lines without attribute in m_storage_detail 
related to defect 0028459 closededuardo_Argal It is necessary a modulescript to solve stock inconsistencies 
related to defect 0030033 closedaferraz Create Inventory Count List process does not insert products without stock if product has a mandatory attribute 

-  Notes
(0076643)
jorge-garcia (developer)
2015-04-21 09:14

Test Plan

As group admin role:
   Create a Product and set an attribute set to it, that is defined as Require At Least One Value
   Create a Goods Receipt for that product, assign an attribute set value and complete it
   Create a physical inventory and add that product with Quantity Count = Book Quantity. Do not complete it
   Create a Goods Shipment in order to leave the stock of the product to 0. Complete it
   Launch the Update Quantity process in the Physical Inventory and check the line of that product is deleted because there is no stock at the moment
(0076959)
hgbot (developer)
2015-05-04 17:37

Repository: erp/devel/pi
Changeset: aa5e62559ffb22c55a560cbfcc07e17d0eccbae3
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Apr 20 18:14:19 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/aa5e62559ffb22c55a560cbfcc07e17d0eccbae3 [^]

Fixed issue 29571: Book Quantity is not updated to 0 by Update Quantity process

In Physical Inventory Lines, Book Quantity is not updated to 0 by Update
Quantity process if product has a mandatory attribute.

The decided solution is to delete the lines from the physical inventory in two
cases: if the product of the line doesn't had an associated record in the
m_storage_detail table, or if the quantity on hand is equal to 0 or the order
quantity is equal to 0 or null.

---
M src-db/database/model/functions/M_INVENTORY_LISTUPDATE.xml
---
(0076960)
hgbot (developer)
2015-05-04 17:37

Repository: erp/devel/pi
Changeset: f83615a66bb3c90e9dd3890408bfc6cbe69363a9
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Mon May 04 17:24:03 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f83615a66bb3c90e9dd3890408bfc6cbe69363a9 [^]

Related to bug 29571: Code Review

[1]: Fix copyright
[2]: Return number of deleted lines

---
M src-db/database/model/functions/M_INVENTORY_LISTUPDATE.xml
---
(0076961)
umartirena (developer)
2015-05-04 17:40

Code Review + Testing OK
(0077200)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077201)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-13 12:58 ngarcia New Issue
2015-04-13 12:58 ngarcia Assigned To => Sandrahuguet
2015-04-13 12:58 ngarcia Modules => Core
2015-04-13 12:58 ngarcia Triggers an Emergency Pack => No
2015-04-13 12:59 ngarcia Issue Monitored: networkb
2015-04-13 12:59 ngarcia Relationship added related to 0020159
2015-04-13 13:06 ngarcia Proposed Solution updated
2015-04-14 12:48 Triage Finance Assigned To Sandrahuguet => Triage Finance
2015-04-17 14:32 jorge-garcia Status new => scheduled
2015-04-17 14:32 jorge-garcia Assigned To Triage Finance => jorge-garcia
2015-04-21 09:14 jorge-garcia Note Added: 0076643
2015-05-04 17:37 hgbot Checkin
2015-05-04 17:37 hgbot Note Added: 0076959
2015-05-04 17:37 hgbot Status scheduled => resolved
2015-05-04 17:37 hgbot Resolution open => fixed
2015-05-04 17:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/aa5e62559ffb22c55a560cbfcc07e17d0eccbae3 [^]
2015-05-04 17:37 hgbot Checkin
2015-05-04 17:37 hgbot Note Added: 0076960
2015-05-04 17:40 umartirena Review Assigned To => umartirena
2015-05-04 17:40 umartirena Note Added: 0076961
2015-05-04 17:40 umartirena Status resolved => closed
2015-05-04 17:40 umartirena Fixed in Version => pi
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077200
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077201
2015-05-27 16:33 ngarcia Relationship added related to 0030033
2015-07-02 11:51 ngarcia Relationship added related to 0028459


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker