Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029532
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2015-04-08 19:082016-02-02 09:36
ReportercaristuView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision5422fb661d82
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-09-23
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
Triggers an Emergency PackNo
Summary

0029532: The done button appears disabled when it should not under some circumstances in Add Payment window

DescriptionThe done button appears disabled when it should not under some circumstances in Add Payment window.

The done button is disabled when not all the mandatory fields are populated, taking this into account, it is possible to follow some steps that makes this mechanism to detect that the overpayment action is not populated when it is hidden.

This causes the disabling of the Done button when it should not.
Steps To Reproduce1) Create a new Sales Order for the "Restaurantes Luna Llena, S.A." business partner
2) Create a line with one unit of product "Agua Sin Gas 1L"
3) Book it
4) Go to the [Payment In] window and create one record in the header, with Received From: Restaurantes Luna Llena, S.A. and amount: 1
5) Click in "Add Details" button. If there are not invoices to pay, the overpayment action field will appear. Leave it empty.
6) Switch the Transaction Type to "Orders". The order created previously is selected by default, with the amount set, so the Done button should be enabled. But it is disabled.
In order to disable we just need to write in the actual payment field

This behavior can be reproduced following other flows.
Proposed SolutionThe mandatory hidden fields should not be considered by the Done button disabling logic when they are not populated.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00297803.0PR15Q2.1 closedSandrahuguet The done button appears disabled when it should not under some circumstances in Add Payment window 
depends on backport 00297813.0PR15Q1.4 closedSandrahuguet The done button appears disabled when it should not under some circumstances in Add Payment window 
caused by feature request 00293903.0PR14Q4 closedSandrahuguet Reconciliation refactor project 

-  Notes
(0077049)
Sandrahuguet (developer)
2015-05-06 13:03

Test Plan:

Create a new Sales Order for the "Restaurantes Luna Llena, S.A." business partner
Create a line with one unit of product "Agua Sin Gas 1L"
Book it
Go to Payment In window and create one record in the header, with Received From: Restaurantes Luna Llena, S.A. and amount: 1
Click in "Add Details" button. If there are not invoices to pay, the overpayment action field will appear. Leave it empty.
Switch the Transaction Type to "Orders". The order created previously is selected by default, with the amount set
Done button should be enabled
(0077054)
Sandrahuguet (developer)
2015-05-06 13:42

Test case added in testlink
https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8216 [^]
(0077076)
hgbot (developer)
2015-05-07 10:47

Repository: erp/devel/pi
Changeset: 5422fb661d828ad8f0550778fa19ee43c79087ac
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed May 06 11:09:24 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5422fb661d828ad8f0550778fa19ee43c79087ac [^]

Fixed bug 29532 The done button appears disabled when it should not

null parameter when it should be the view in recalcDisplayLogicOrReadOnlyLogic
call in updateDifference function

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0077233)
umartirena (developer)
2015-05-08 12:55

Code Review + Testing OK
(0077245)
hudsonbot (developer)
2015-05-08 15:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d5cb256a6a8a [^]
Maturity status: Test
(0083815)
hgbot (developer)
2016-02-02 09:36

Repository: tools/automation/int
Changeset: 5118d8dbb5e5bc064043142c7a9af001f9661b11
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Sep 30 00:25:24 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/5118d8dbb5e5bc064043142c7a9af001f9661b11 [^]

Related to issue 29532: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/gui/financial/receivablespayables/transactions/AddPaymentProcess.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression29532In.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression29532Out.java
---

- Issue History
Date Modified Username Field Change
2015-04-08 19:08 caristu New Issue
2015-04-08 19:08 caristu Assigned To => Sandrahuguet
2015-04-08 19:08 caristu Modules => Core
2015-04-08 19:08 caristu Triggers an Emergency Pack => No
2015-04-08 19:08 caristu Issue Monitored: networkb
2015-04-08 19:09 caristu version => pi
2015-04-08 19:11 caristu Summary The done button appears disabled when it should not under some circumstances => The done button appears disabled when it should not under some circumstances in Add Payment window
2015-04-08 19:11 caristu Description Updated View Revisions
2015-04-08 19:15 caristu Proposed Solution updated
2015-04-14 12:48 Triage Finance Assigned To Sandrahuguet => Triage Finance
2015-05-05 15:50 Sandrahuguet Assigned To Triage Finance => Sandrahuguet
2015-05-05 16:08 Sandrahuguet Status new => scheduled
2015-05-05 16:35 Sandrahuguet Regression level => Production - Confirmed Stable
2015-05-05 16:35 Sandrahuguet Regression date => 2014-06-19
2015-05-05 16:35 Sandrahuguet Regression introduced in release => 3.0PR14Q3
2015-05-05 16:35 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
2015-05-05 16:35 Sandrahuguet Severity major => minor
2015-05-05 16:35 Sandrahuguet Relationship added caused by 0029391
2015-05-05 16:45 Sandrahuguet Status scheduled => acknowledged
2015-05-05 16:46 Sandrahuguet Status acknowledged => scheduled
2015-05-05 17:07 Sandrahuguet Relationship deleted caused by 0029391
2015-05-05 17:20 Sandrahuguet Regression date 2014-06-19 => 2014-09-23
2015-05-05 17:20 Sandrahuguet Regression introduced in release 3.0PR14Q3 => 3.0PR14Q4
2015-05-05 17:20 Sandrahuguet Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^] => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2015-05-05 17:20 Sandrahuguet Relationship added caused by 0029390
2015-05-06 13:03 Sandrahuguet Note Added: 0077049
2015-05-06 13:42 Sandrahuguet Note Added: 0077054
2015-05-06 13:42 Sandrahuguet Priority normal => immediate
2015-05-06 13:43 Sandrahuguet Review Assigned To => umartirena
2015-05-07 10:47 hgbot Checkin
2015-05-07 10:47 hgbot Note Added: 0077076
2015-05-07 10:47 hgbot Status scheduled => resolved
2015-05-07 10:47 hgbot Resolution open => fixed
2015-05-07 10:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5422fb661d828ad8f0550778fa19ee43c79087ac [^]
2015-05-08 12:55 umartirena Note Added: 0077233
2015-05-08 12:55 umartirena Status resolved => closed
2015-05-08 12:55 umartirena Fixed in Version => pi
2015-05-08 15:39 hudsonbot Checkin
2015-05-08 15:39 hudsonbot Note Added: 0077245
2016-02-02 09:36 hgbot Checkin
2016-02-02 09:36 hgbot Note Added: 0083815


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker