Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029521
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-04-08 10:062015-05-07 22:17
ReporterngarciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision3c8bdfba416c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029521: Storage Bin and UOM fields are not filled when posting Work Efforts and Bill of Material Productions

DescriptionStorage Bin and UOM fields (Accounting Transaction Details window) are not filled when posting Work Efforts and Bill of Material Productions
Steps To ReproduceAs group admin role:
   Post a Work Effort
   Go to the associated record in the Accounting Transaction Details window and check the UOM and Storage Bin fields are empty
   The same happens when posting a Bill Of Material Production
   The fields are filled in records related with Goods Shipments/Receipts, Goods Movements, Physical Inventories and Internal Consumptions
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0076596)
jorge-garcia (developer)
2015-04-16 17:59

Test Plan:

As group admin role:
   Post a Work Effort or a Bill Of Material Production
   Go to the associated record in the Accounting Transaction Details window and check the UOM and Storage Bin fields are filled well
(0076989)
hgbot (developer)
2015-05-05 11:05

Repository: erp/devel/pi
Changeset: 3c8bdfba416cdebce1e8eca2c7cd20853d54c2f0
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Apr 16 17:48:02 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3c8bdfba416cdebce1e8eca2c7cd20853d54c2f0 [^]

Fixed issue 29521: Storage Bin and UOM fields are not filled well

Storage Bin and UOM fields are not filled when posting Work Efforts and
Bill of Material Productions.

The problem was in the Production side of the ERP for both posts.

The solution is to retrieve the UOM from the M_PRODUCTIONLINE table, and
set the storage bin and the UOM in the fact lines.

---
M src/org/openbravo/erpCommon/ad_forms/DocLineProduction_data.xsql
M src/org/openbravo/erpCommon/ad_forms/DocProduction.java
---
(0076990)
hgbot (developer)
2015-05-05 11:05

Repository: erp/devel/pi
Changeset: cec0d8150e63350f9bd97688a15159e1de2d7a84
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Apr 17 09:11:04 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cec0d8150e63350f9bd97688a15159e1de2d7a84 [^]

Related to issue 29521: Costing Test has change due to the new changes

TestCosting must be changed to adapt to the new changes made in the
BOM production and the Work Effort introduced by the issue 29521.

---
M src-test/src/org/openbravo/test/costing/TestCosting.java
---
(0076991)
hgbot (developer)
2015-05-05 11:05

Repository: erp/devel/pi
Changeset: 046dc0d08ef0bcfb6837f5f64b3b54d88498b7c4
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Tue May 05 10:57:48 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/046dc0d08ef0bcfb6837f5f64b3b54d88498b7c4 [^]

related to issue 29521 update Copyright

---
M src/org/openbravo/erpCommon/ad_forms/DocLineProduction_data.xsql
---
(0076992)
Sandrahuguet (developer)
2015-05-05 11:06

Code review + testing OK
(0077208)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077209)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077210)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077211)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-08 10:06 ngarcia New Issue
2015-04-08 10:06 ngarcia Assigned To => Sandrahuguet
2015-04-08 10:06 ngarcia Modules => Core
2015-04-08 10:06 ngarcia Triggers an Emergency Pack => No
2015-04-08 10:06 ngarcia Issue Monitored: ngarcia
2015-04-14 12:48 Triage Finance Assigned To Sandrahuguet => Triage Finance
2015-04-16 10:37 jorge-garcia Status new => scheduled
2015-04-16 10:37 jorge-garcia Assigned To Triage Finance => jorge-garcia
2015-04-16 17:59 jorge-garcia Note Added: 0076596
2015-05-05 11:05 hgbot Checkin
2015-05-05 11:05 hgbot Note Added: 0076989
2015-05-05 11:05 hgbot Status scheduled => resolved
2015-05-05 11:05 hgbot Resolution open => fixed
2015-05-05 11:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3c8bdfba416cdebce1e8eca2c7cd20853d54c2f0 [^]
2015-05-05 11:05 hgbot Checkin
2015-05-05 11:05 hgbot Note Added: 0076990
2015-05-05 11:05 hgbot Checkin
2015-05-05 11:05 hgbot Note Added: 0076991
2015-05-05 11:06 Sandrahuguet Review Assigned To => Sandrahuguet
2015-05-05 11:06 Sandrahuguet Note Added: 0076992
2015-05-05 11:06 Sandrahuguet Status resolved => closed
2015-05-05 11:06 Sandrahuguet Fixed in Version => 3.0PR15Q3
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077208
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077209
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077210
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077211


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker