Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029513
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-07 13:552015-05-14 17:48
ReporterVictorVillarView Statuspublic 
Assigned Toumartirena 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionbf8ba2e9ab7a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029513: Wrong Total Movement quantity in the costing tab with backdated transactions

DescriptionWrong Total Movement quantity in the costing tab with backdated transactions
Steps To ReproduceAS group admin role,
   Go to product window,
     create a new product: name: test
    Price tab: Tarifa Bebidas Alegres
      Unit: 2
      List: 2

Go to Purchase order,
   create a new one for bebidas alegres
 Lines tab:
    Add test product
    qty: 200
Go to Goods Receipt window,
   movement date: two weeks ago
 select the order line cretated before.
Process it

Go to Purchase order,
   create a new one for bebidas alegres
 Lines tab:
    Add test product
    qty: 380
Go to Goods Receipt window,
   movement date: today
 select the order line cretated before.
Process it

Go to Purchase order,
   create a new one for bebidas alegres
 Lines tab:
    Add test product
    qty: 100
Go to Goods Receipt window,
   movement date: three weekes ago
 select the order line cretated before.
Process it

Go to Costing rule window.
   Process Fix Backdated Transactions: date: 1 month ago

Go to Process request :
   Launch the costing background process
Go to the Costing tab of the product: test
   order by ending date
    realise that the first line is: qty:100 and the total movement is: 300 which is wrong, should be 100
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00298913.0PR15Q2.1 closedumartirena Wrong Total Movement quantity in the costing tab with backdated transactions 
depends on backport 00298923.0PR15Q1.4 closedumartirena Wrong Total Movement quantity in the costing tab with backdated transactions 

-  Notes
(0077417)
hgbot (developer)
2015-05-13 18:32

Repository: erp/devel/pi
Changeset: bf8ba2e9ab7a62595aae60ff4ed52fe62b25bc6d
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Tue May 12 18:18:07 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bf8ba2e9ab7a62595aae60ff4ed52fe62b25bc6d [^]

Fixes bug 29513: Total Movement qty fixed in costing tab with backdated trx

While working with cost adjustments, on certain cases the existing Costing records changes. This can happen because the cost has been recalculated due to backdated transactions, price adjustments, manual cost corrections, etc. In all this cases the 'Total Movement Quantity' field was not being correctly updated.
This field has to store the current stock of the product on that moment. So, each time the costing record is updated it is being checked if this value changes, and if it has changed the current stock is set.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0077418)
hgbot (developer)
2015-05-13 18:32

Repository: erp/devel/pi
Changeset: a680efdb1909a0e112a51691181b95c8622fd3bb
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Tue May 12 18:20:20 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a680efdb1909a0e112a51691181b95c8622fd3bb [^]

Related to bug 29513: Adjust costing tests to the new behavior

---
M src-test/src/org/openbravo/test/costing/TestCosting.java
---
(0077419)
hgbot (developer)
2015-05-13 18:32

Repository: erp/devel/pi
Changeset: 5651ef7e37fc3b6fdad813a2904c4d9239c7cc29
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed May 13 17:25:26 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5651ef7e37fc3b6fdad813a2904c4d9239c7cc29 [^]

Related to issue 29513: Remove unused line

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0077420)
aferraz (developer)
2015-05-13 18:34

Code review + Testing OK
(0077463)
hudsonbot (developer)
2015-05-14 17:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3375171dd310 [^]
Maturity status: Test
(0077464)
hudsonbot (developer)
2015-05-14 17:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3375171dd310 [^]
Maturity status: Test
(0077465)
hudsonbot (developer)
2015-05-14 17:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3375171dd310 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-07 13:55 VictorVillar New Issue
2015-04-07 13:55 VictorVillar Assigned To => Sandrahuguet
2015-04-07 13:55 VictorVillar Modules => Core
2015-04-07 13:55 VictorVillar Triggers an Emergency Pack => No
2015-04-13 07:48 AtulOpenbravo Assigned To Sandrahuguet => AtulOpenbravo
2015-04-13 07:48 AtulOpenbravo Status new => scheduled
2015-05-12 20:04 umartirena Assigned To AtulOpenbravo => umartirena
2015-05-13 18:32 hgbot Checkin
2015-05-13 18:32 hgbot Note Added: 0077417
2015-05-13 18:32 hgbot Status scheduled => resolved
2015-05-13 18:32 hgbot Resolution open => fixed
2015-05-13 18:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bf8ba2e9ab7a62595aae60ff4ed52fe62b25bc6d [^]
2015-05-13 18:32 hgbot Checkin
2015-05-13 18:32 hgbot Note Added: 0077418
2015-05-13 18:32 hgbot Checkin
2015-05-13 18:32 hgbot Note Added: 0077419
2015-05-13 18:34 aferraz Review Assigned To => aferraz
2015-05-13 18:34 aferraz Note Added: 0077420
2015-05-13 18:34 aferraz Status resolved => closed
2015-05-13 18:34 aferraz Fixed in Version => 3.0PR15Q3
2015-05-14 16:56 aferraz Status closed => new
2015-05-14 16:56 aferraz Resolution fixed => open
2015-05-14 16:56 aferraz Fixed in Version 3.0PR15Q3 =>
2015-05-14 16:56 aferraz Status new => scheduled
2015-05-14 16:57 aferraz Status scheduled => resolved
2015-05-14 16:57 aferraz Fixed in Version => 3.0PR15Q3
2015-05-14 16:57 aferraz Resolution open => fixed
2015-05-14 16:57 aferraz Status resolved => closed
2015-05-14 17:48 hudsonbot Checkin
2015-05-14 17:48 hudsonbot Note Added: 0077463
2015-05-14 17:48 hudsonbot Checkin
2015-05-14 17:48 hudsonbot Note Added: 0077464
2015-05-14 17:48 hudsonbot Checkin
2015-05-14 17:48 hudsonbot Note Added: 0077465


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker