Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029242
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-03-11 12:052015-08-20 23:16
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisioncdb0c4e4d5d0
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Topsanjuan
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029242: Initial Balance incorrectly calculated in PDF General Ledger Report when grouping by BP

DescriptionInitial Balance incorrectly calculated in PDF General Ledger Report when grouping by BP
Steps To Reproduce1. Access End Year Close window, and open year 2013 for España organization
2. Access General Ledger Report and filter by:
  - Date from 01/01/2014 to 31/12/2014
  - Organization España
  - General Ledger España
  - From account 43000 to account 43000
  - Group by = business partner
3. Run report in PDF format and realize that Initial Balance calculated for "Alimentos y Supermercados" is 1,275,028.79 (file attached "sinBP")
4. Run report in PDF with similar filtering criteria but adding "Alimentos y supermercados" in Business Partner field and realize that Initial Balance calculated is 409,599.04 (file attached "conBP")
TagsNo tags attached.
Attached Filespdf file icon sinBP.pdf [^] (11,071 bytes) 2015-03-11 12:06
pdf file icon conBP.pdf [^] (4,153 bytes) 2015-03-11 12:06

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0075604)
jorge-garcia (developer)
2015-03-16 09:15

Test Plan

Access End Year Close window, and open year 2013 for España organization
Access General Ledger Report and filter by:
  - Date from 01/01/2014 to 31/12/2014
  - Organization España
  - General Ledger España
  - From account 43000 to account 43000
  - Group by = business partner
Run report in PDF format and realize that Initial Balance calculated for "Alimentos y Supermercados" is 409,599.04
Run report in PDF with similar filtering criteria but adding "Alimentos y supermercados" in Business Partner field and realize that Initial Balance calculated is 409,599.04
Run report in PDF with similar filtering criteria but changing the Business Partner in Business Partner field and check it with the initial report.
(0076448)
hgbot (developer)
2015-04-10 14:36

Repository: erp/devel/pi
Changeset: 801202997fd19b303e26f0851143f7233adc8f83
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Mar 13 14:51:22 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/801202997fd19b303e26f0851143f7233adc8f83 [^]

Fixed issue 29242: Initial Balance incorrectly calculated in PDF GL Report

Initial Balance are incorrectly calculated in PDF General Ledger Report when
grouping by BP. Totals values are also incorrectly calculated in PDF Report.

Added the implementation to calculate correctly the following data:
Initial Balance
Totals
Subtotals
Balance fields from the lines

All added changes are inside the printPageDataPDF function in the
ReportGeneralLedger.java

Changed the ReportGeneralLedger.jrxml to show correctly the data results from
the previously commented implementation in the report.

---
M src/org/openbravo/erpCommon/ad_reports/ReportGeneralLedger.java
M src/org/openbravo/erpCommon/ad_reports/ReportGeneralLedger.jrxml
---
(0076449)
umartirena (developer)
2015-04-10 14:37

Code Review + Testing OK
(0076486)
umartirena (developer)
2015-04-13 16:55

Issue reopened as it s going to be backed out the previous changeset
(0076487)
hgbot (developer)
2015-04-13 16:55

Repository: erp/devel/pi
Changeset: b1932bc8c9310242c8bac08ca22bd3e829b82615
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Mon Apr 13 16:53:57 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b1932bc8c9310242c8bac08ca22bd3e829b82615 [^]

Related to bug 29242: Backed out changeset 801202997fd1

---
M src/org/openbravo/erpCommon/ad_reports/ReportGeneralLedger.java
M src/org/openbravo/erpCommon/ad_reports/ReportGeneralLedger.jrxml
---
(0077118)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077121)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0078745)
vmromanos (developer)
2015-07-09 15:54

Test Plan:
Go to the General Ledger Report:
- Date from 01/01/2014 to 31/12/2014
- Organization España
- General Ledger España
- From account 43000 to account 43000
- Group by = business partner

Press the Search button and write down the Initial Balance figures
Now search the Print button to generate a PDF file.
Verify the Initial Balance figures are the same in both formats.
(0078746)
hgbot (developer)
2015-07-09 17:58
edited on: 2015-07-16 11:58

Repository: erp/devel/pi
Changeset: cdb0c4e4d5d0
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jul 09 15:44:22 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cdb0c4e4d5d0 [^]

Fixed bug 29242: Initial Balance incorrectly calculated in PDF
General Ledger Report when grouping by BP

The PDF format only was not grouping by the grouping criteria due to a typo when calling the AddTotals() constructor.
After the fix, both HTML and PDF formats show the same figures in the Initial Balance fields

---
M src/org/openbravo/erpCommon/ad_reports/ReportGeneralLedger.java
---

(0078752)
psanjuan (manager)
2015-07-10 14:24

Verified test plan above for several business partners.

The "Initial Balance" shown for each of them is now the same, regardless printed option (pdf - html) or filtering options entered.
(0079486)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-11 12:05 maite New Issue
2015-03-11 12:05 maite Assigned To => Sandrahuguet
2015-03-11 12:05 maite Modules => Core
2015-03-11 12:05 maite Triggers an Emergency Pack => No
2015-03-11 12:06 maite File Added: sinBP.pdf
2015-03-11 12:06 maite File Added: conBP.pdf
2015-03-11 12:06 maite Issue Monitored: networkb
2015-03-13 10:36 jonalegriaesarte Target Version 3.0PR15Q2 => 3.0PR15Q3
2015-03-16 09:12 jorge-garcia Status new => scheduled
2015-03-16 09:12 jorge-garcia Assigned To Sandrahuguet => jorge-garcia
2015-03-16 09:15 jorge-garcia Note Added: 0075604
2015-04-10 14:36 hgbot Checkin
2015-04-10 14:36 hgbot Note Added: 0076448
2015-04-10 14:36 hgbot Status scheduled => resolved
2015-04-10 14:36 hgbot Resolution open => fixed
2015-04-10 14:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/801202997fd19b303e26f0851143f7233adc8f83 [^]
2015-04-10 14:37 umartirena Review Assigned To => umartirena
2015-04-10 14:37 umartirena Note Added: 0076449
2015-04-10 14:37 umartirena Status resolved => closed
2015-04-10 14:37 umartirena Fixed in Version => pi
2015-04-13 16:55 umartirena Note Added: 0076486
2015-04-13 16:55 umartirena Status closed => new
2015-04-13 16:55 umartirena Resolution fixed => open
2015-04-13 16:55 umartirena Fixed in Version pi =>
2015-04-13 16:55 hgbot Checkin
2015-04-13 16:55 hgbot Note Added: 0076487
2015-04-27 17:24 jorge-garcia Status new => scheduled
2015-04-28 11:02 jorge-garcia Status scheduled => acknowledged
2015-04-28 11:02 jorge-garcia Status acknowledged => scheduled
2015-04-28 11:04 jorge-garcia Status scheduled => feedback
2015-04-28 11:04 jorge-garcia Status feedback => new
2015-04-28 11:04 jorge-garcia Assigned To jorge-garcia => Triage Finance
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077118
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077121
2015-06-29 12:43 vmromanos Target Version 3.0PR15Q3 => 3.0PR15Q4
2015-07-09 13:08 vmromanos Status new => scheduled
2015-07-09 13:08 vmromanos Assigned To Triage Finance => vmromanos
2015-07-09 15:54 vmromanos Note Added: 0078745
2015-07-09 17:58 hgbot Checkin
2015-07-09 17:58 hgbot Note Added: 0078746
2015-07-09 17:58 hgbot Status scheduled => resolved
2015-07-09 17:58 hgbot Resolution open => fixed
2015-07-09 17:58 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/801202997fd19b303e26f0851143f7233adc8f83 [^] => http://code.openbravo.com/erp/devel/pi/rev/a12d452803f7694a962c7d96064db6dae091d4a2 [^]
2015-07-09 17:58 vmromanos Review Assigned To umartirena => psanjuan
2015-07-10 14:24 psanjuan Note Added: 0078752
2015-07-10 14:24 psanjuan Status resolved => closed
2015-07-16 11:57 gorka_gil Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/a12d452803f7694a962c7d96064db6dae091d4a2 [^] => http://code.openbravo.com/erp/devel/pi/rev/cdb0c4e4d5d0 [^]
2015-07-16 11:58 gorka_gil Note Edited: 0078746 View Revisions
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079486


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker