Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029178
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2015-03-06 18:392016-04-25 14:08
ReporterOrekariaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision6761ca5a9922
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029178: Wrong counted amount after voiding a layaway

DescriptionWrong counted amount after voiding a layaway
Steps To ReproduceLog into the WebPOS

create a layaway with an initial partial payment
cashup

add a deposit
retrieve the layaway and pay the remaining quantity
cashup
in the cash counted step, add some amount and remember it

verify that in the final report, the counted cash is wrong
do not finish the cashup and step back to counted cash
verify that the counted cash has been wrongly updated

note: a test with this issue number is available

TagsNo tags attached.
Attached Filespatch file icon issue 29178 Test 5218.patch [^] (2,859 bytes) 2016-03-28 09:19 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0028130RR15Q2 closedOrekaria Support creating tickets through multiple terminals with payment in other (central) devices 
blocks feature request 0029465RR16Q1 closedRetail QA: RR15Q3: Add tests for Mobile applications 

-  Notes
(0075283)
hgbot (developer)
2015-03-09 00:20

Repository: tools/automation/pi-mobile
Changeset: 03027eead0fcf59e2417849394d3381ecee6dabd
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Sat Mar 07 23:11:24 2015 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/03027eead0fcf59e2417849394d3381ecee6dabd [^]

Related to issue 28933. Verifies issue 29178: Added 'I29178_CountedWrongWhenLayawayVoided' test

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I29178_CountedWrongWhenLayawayVoided.java
---
(0085325)
hgbot (developer)
2016-03-30 09:20

Repository: tools/automation/pi-mobile
Changeset: 6d3c2cb6bba42e9870fbdf448c9180f46540af93
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Mar 30 12:49:47 2016 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/6d3c2cb6bba42e9870fbdf448c9180f46540af93 [^]

Verifies issue 29178 : Modifies automated test 'I29178_CountedWrongWhenLayawayVoided'

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I29178_CountedWrongWhenLayawayVoided.java
---
(0085341)
ranjith_qualiantech_com (developer)
2016-03-30 15:51

No changes required in source.
Minor changes added in Test
(0085364)
marvintm (developer)
2016-03-31 14:56

There is a case in which the current cash is not being updated correctly, and it can lead to a problematic situation. It can be reproduced by following these steps:

- Do a cashup, and ensure that there is no cash in the drawer.
- Create a layaway, add a partial payment of 5€, and press on layaway. At this point, you have 5€ in the drawer.
- Load the layaway, and void it. Return the 5€ in cash At this point, there is again 0€ in the drawer, and you shouldn't be able to do a return in cash.
- Add a product to the empty ticket, change its price to 5, and return the line.
- Go to payment, and verify that you can return this ticket with cash.

This is wrong, as you don't have cash in the drawer, and the system should have realized this.

If you then go to the cashup window, the window will correctly show that there is zero cash. If you then go back to the POS, and try to do a return, it will no longer be possible, as now the system has correctly updated the current cash information, and it can now correctly detect that there is no cash in the drawer. However, the situation just before voiding the layaway is dangerous, as it can lead to an incorrect situation because the check of available cash is not working at that point.
(0085365)
marvintm (developer)
2016-03-31 14:57

As a proposed solution, it seems it's required to call the OB.UTIL.calculateCurrentCash function when voiding the layaway. This will ensure that the current cash amount is updated, and that the problem doesn't happen.
(0085425)
hgbot (developer)
2016-04-05 07:40

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 6761ca5a99224d19c6e2c7aeabf5f09313185331
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Apr 05 11:09:26 2016 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6761ca5a99224d19c6e2c7aeabf5f09313185331 [^]

Fixes issue 29178 : Calaculate Payment Current cash after voiding layaway

---
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0085426)
hgbot (developer)
2016-04-05 07:40

Repository: tools/automation/pi-mobile
Changeset: d5f83252825ae754bc2e8f58da9e6b6eb710aaed
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Apr 05 11:09:29 2016 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/d5f83252825ae754bc2e8f58da9e6b6eb710aaed [^]

Verifies issue 29178 : Added automated test 'I29178_CountedWrongWhenLayawayVoided_II'

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I29178_CountedWrongWhenLayawayVoided_II.java
---
(0085744)
migueldejuana (developer)
2016-04-19 11:49

Tested and reviewed in 0b1ae75525ac
(0085958)
hgbot (developer)
2016-04-25 13:45

Repository: tools/automation/pi-mobile
Changeset: a6a3ac2e5e52cc2f13ae9d2ff9f6d633635a6c06
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Apr 25 13:41:51 2016 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/a6a3ac2e5e52cc2f13ae9d2ff9f6d633635a6c06 [^]

Verifies issue 29178 : Modifies automated test 'I29178_CountedWrongWhenLayawayVoided'

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I29178_CountedWrongWhenLayawayVoided.java
---
(0085961)
hgbot (developer)
2016-04-25 14:08

Repository: tools/automation/pi-mobile
Changeset: 3bab134721e71d57cbdca72e38714932e8430295
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Apr 25 13:58:50 2016 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/3bab134721e71d57cbdca72e38714932e8430295 [^]

Verifies issue 29178 : Modifies automated test 'I29178_CountedWrongWhenLayawayVoided'

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I29178_CountedWrongWhenLayawayVoided.java
---

- Issue History
Date Modified Username Field Change
2015-03-06 18:39 Orekaria New Issue
2015-03-06 18:39 Orekaria Assigned To => marvintm
2015-03-06 18:39 Orekaria Triggers an Emergency Pack => No
2015-03-09 00:20 hgbot Checkin
2015-03-09 00:20 hgbot Note Added: 0075283
2015-03-09 01:00 Orekaria Relationship added blocks 0028933
2015-03-09 01:01 Orekaria Relationship added related to 0028130
2015-03-12 15:17 Osmany Assigned To marvintm => Osmany
2015-03-30 18:59 Orekaria Relationship added blocks 0029465
2015-03-30 18:59 Orekaria Relationship deleted blocks 0028933
2015-04-01 13:35 malsasua Assigned To Osmany => Retail
2016-03-15 18:35 mario_castello Status new => acknowledged
2016-03-28 09:17 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2016-03-28 09:17 ranjith_qualiantech_com Status acknowledged => scheduled
2016-03-28 09:19 ranjith_qualiantech_com File Added: issue 29178 Test 5218.patch
2016-03-30 09:20 hgbot Checkin
2016-03-30 09:20 hgbot Note Added: 0085325
2016-03-30 15:51 ranjith_qualiantech_com Note Added: 0085341
2016-03-30 15:51 ranjith_qualiantech_com Status scheduled => resolved
2016-03-30 15:51 ranjith_qualiantech_com Resolution open => fixed
2016-03-31 14:56 marvintm Note Added: 0085364
2016-03-31 14:56 marvintm Status resolved => new
2016-03-31 14:56 marvintm Resolution fixed => open
2016-03-31 14:57 marvintm Note Added: 0085365
2016-04-05 07:40 hgbot Checkin
2016-04-05 07:40 hgbot Note Added: 0085425
2016-04-05 07:40 hgbot Status new => resolved
2016-04-05 07:40 hgbot Resolution open => fixed
2016-04-05 07:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6761ca5a99224d19c6e2c7aeabf5f09313185331 [^]
2016-04-05 07:40 hgbot Checkin
2016-04-05 07:40 hgbot Note Added: 0085426
2016-04-19 11:49 migueldejuana Review Assigned To => migueldejuana
2016-04-19 11:49 migueldejuana Note Added: 0085744
2016-04-19 11:49 migueldejuana Status resolved => closed
2016-04-25 13:45 hgbot Checkin
2016-04-25 13:45 hgbot Note Added: 0085958
2016-04-25 14:08 hgbot Checkin
2016-04-25 14:08 hgbot Note Added: 0085961


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker