Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029171
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2015-03-06 13:332016-02-02 09:38
ReporterVictorVillarView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision33329a8720b2
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toeduardo_Argal
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-04-15
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e367e4ce1f9852519224ff1ec15553f5759a3011 [^]
Triggers an Emergency PackNo
Summary

0029171: The sales order is not taking into account the unit price of the product when is 0

DescriptionThe sales order is not taking into account the unit price of the product when is 0
Steps To ReproduceAs group admin role,
 Go to Product window,
   select Agua Sin gas
     change the Unit Price to 0 for Tarifa de ventas

Go to Sales Order
  Create a new register for Alimentos y Supermercados
  Price List: Tarifa de ventas
 Go to Lines tab:
   select Agua Sin gas
Realise that the Unit Price of the line is 1.53, which is the List Price of the product, and this priority only happens when the Unit Price of the Product is 0.
Proposed SolutionThe product team should analyse why only in this case is not taking into account the unit price as first value to fill.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00292913.0PR15Q1.2 closedAtulOpenbravo The sales order is not taking into account the unit price of the product when is 0 
depends on backport 00292923.0PR14Q3.8 closedAtulOpenbravo The sales order is not taking into account the unit price of the product when is 0 
caused by defect 00245693.0PR14Q3 closedAtulOpenbravo Inconsistent "Discount" calculated when using "Discounts and Promotions" 

-  Notes
(0075601)
AtulOpenbravo (developer)
2015-03-16 04:58

Test Plan
- Login as group admin role
- Nagivate to Product window,
   select Agua Sin gas product
     change the Unit Price to 0 for Tarifa de ventas Price List
- Nagivate to Sales Order
- Create a new register for Alimentos y Supermercados
  Price List: Tarifa de ventas
- Navigate to Lines tab:
  select Agua Sin gas
- Check that the Unit Price of the line is set 0 which is unit price in the price list.
(0075634)
hgbot (developer)
2015-03-16 16:36

Repository: erp/devel/pi
Changeset: 33329a8720b25c84660e83f7e8d033eab3684de1
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon Mar 16 00:07:30 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/33329a8720b25c84660e83f7e8d033eab3684de1 [^]

Fixes Issue 29171:The sales order is not taking into account the unit price of
the product when is 0

Corner case regression, when ever unit price is set to zero in the price list

---
M src/org/openbravo/erpCommon/ad_callouts/SL_Order_Amt.java
M src/org/openbravo/erpCommon/businessUtility/PriceAdjustment.java
---
(0075635)
hgbot (developer)
2015-03-16 16:36

Repository: erp/devel/pi
Changeset: e4c7b3d0a0ffd239d1758eeb600516dc192d2f71
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Mar 16 16:35:31 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e4c7b3d0a0ffd239d1758eeb600516dc192d2f71 [^]

Related to issue 29171: Update copyright

---
M src/org/openbravo/erpCommon/ad_callouts/SL_Order_Amt.java
M src/org/openbravo/erpCommon/businessUtility/PriceAdjustment.java
---
(0075636)
aferraz (developer)
2015-03-16 16:43

Code review + Testing OK
(0075668)
hudsonbot (developer)
2015-03-16 23:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/28f92fd2fba0 [^]
Maturity status: Test
(0075669)
hudsonbot (developer)
2015-03-16 23:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/28f92fd2fba0 [^]
Maturity status: Test
(0075685)
dmitry_mezentsev (developer)
2015-03-17 11:19

As we are touching sensitive component in the emergency update I would like to ask for:
1. Some extra testing. I hope regular price scenario (not 0) was verified. But apart from it the scenario of the issue that caused this regression. Please confirm or execute it.
2. Additional issue review.
(0075702)
eduardo_Argal (developer)
2015-03-17 19:27

Code Reviewed and tested.
Tested both issues, regression and original which introduces the regression, and both are working as expected.
(0083820)
hgbot (developer)
2016-02-02 09:38

Repository: tools/automation/int
Changeset: 9fe1c166aebc2fcc52e342552626179c039e586d
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Oct 07 10:23:06 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/9fe1c166aebc2fcc52e342552626179c039e586d [^]

Related to issue 29171: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/testscripts/masterdata/product/Product.java
M src-test/com/openbravo/test/integration/erp/testscripts/masterdata/product/ProductClassicScript.java
M src-test/com/openbravo/test/integration/erp/testscripts/masterdata/product/ProductScript.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRORegression29171.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRO_RegressionSuite.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/SALRegression29171.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/SAL_RegressionSuite.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/build.xml
---

- Issue History
Date Modified Username Field Change
2015-03-06 13:33 VictorVillar New Issue
2015-03-06 13:33 VictorVillar Assigned To => Sandrahuguet
2015-03-06 13:33 VictorVillar Modules => Core
2015-03-06 13:33 VictorVillar Triggers an Emergency Pack => No
2015-03-06 13:33 VictorVillar Issue Monitored: networkb
2015-03-09 13:32 VictorVillar Priority high => immediate
2015-03-09 13:32 VictorVillar Severity minor => major
2015-03-09 13:44 AtulOpenbravo Assigned To Sandrahuguet => AtulOpenbravo
2015-03-09 13:44 AtulOpenbravo Status new => scheduled
2015-03-13 13:22 Orekaria Relationship added depends on 0027048
2015-03-13 13:22 Orekaria Relationship deleted depends on 0027048
2015-03-16 04:58 AtulOpenbravo Note Added: 0075601
2015-03-16 13:08 aferraz Regression level => Production - Confirmed Stable
2015-03-16 13:08 aferraz Regression date => 2014-04-15
2015-03-16 13:08 aferraz Regression introduced in release => 3.0PR14Q3
2015-03-16 13:08 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/e367e4ce1f9852519224ff1ec15553f5759a3011 [^]
2015-03-16 16:36 hgbot Checkin
2015-03-16 16:36 hgbot Note Added: 0075634
2015-03-16 16:36 hgbot Status scheduled => resolved
2015-03-16 16:36 hgbot Resolution open => fixed
2015-03-16 16:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/33329a8720b25c84660e83f7e8d033eab3684de1 [^]
2015-03-16 16:36 hgbot Checkin
2015-03-16 16:36 hgbot Note Added: 0075635
2015-03-16 16:39 aferraz Status resolved => new
2015-03-16 16:39 aferraz Resolution fixed => open
2015-03-16 16:39 aferraz Status new => scheduled
2015-03-16 16:41 aferraz Status scheduled => resolved
2015-03-16 16:41 aferraz Resolution open => fixed
2015-03-16 16:43 aferraz Review Assigned To => aferraz
2015-03-16 16:43 aferraz Note Added: 0075636
2015-03-16 16:43 aferraz Status resolved => closed
2015-03-16 17:30 aferraz Relationship added caused by 0024569
2015-03-16 23:53 hudsonbot Checkin
2015-03-16 23:53 hudsonbot Note Added: 0075668
2015-03-16 23:53 hudsonbot Checkin
2015-03-16 23:53 hudsonbot Note Added: 0075669
2015-03-17 11:14 dmitry_mezentsev Target Version 3.0PR15Q3 => 3.0PR15Q2
2015-03-17 11:19 dmitry_mezentsev Note Added: 0075685
2015-03-17 11:19 dmitry_mezentsev Status closed => new
2015-03-17 11:19 dmitry_mezentsev Resolution fixed => open
2015-03-17 11:19 dmitry_mezentsev Status new => scheduled
2015-03-17 11:20 dmitry_mezentsev Status scheduled => resolved
2015-03-17 11:20 dmitry_mezentsev Fixed in Version => 3.0PR15Q2
2015-03-17 11:20 dmitry_mezentsev Resolution open => fixed
2015-03-17 11:20 dmitry_mezentsev Review Assigned To aferraz => eduardo_Argal
2015-03-17 19:27 eduardo_Argal Note Added: 0075702
2015-03-17 19:27 eduardo_Argal Status resolved => closed
2016-02-02 09:38 hgbot Checkin
2016-02-02 09:38 hgbot Note Added: 0083820


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker