Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029147
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajorhave not tried2015-03-05 16:062015-03-20 19:23
ReporterSandrahuguetView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q3.8
StatusclosedFix in branchFixed in SCM revision236f8d92d55c
ProjectionnoneETAnoneTarget Version3.0PR14Q3.8
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-19
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
Triggers an Emergency PackYes
Summary

0029147: Used credit is not correct under certain circumstances

DescriptionUsed credit is not correct under certain circumstances
Steps To ReproduceGo to Payment In and create a new payment with this data:
  Paying to: Restaurantes Luna Llena, S.A.
  Amount: 3000.00

Click Add Details button and complete the pop-up:
  Actual Payment: 3000
  Action Regarding Document: Process Made Payment(s)
  Overpayment Action: Leave the credit to be used later
  Click Done button

Go to Sales Invoice and create new:
 Organization: F&B España - Región Norte
 Business Partner: Restaurantes Luna Llena, S.A.
 Lines: Cerveza Ale 0,5L ; Qty:100

Go to Payment In and create a new payment with this data:
  Paying to: Restaurantes Luna Llena, S.A.
  Amount 0

Click Add Details button and complete the pop-up:
 Actual Payment: 0.00
 On Credit To Use, check off the credit created in previous step and set payment amount to 3000,00
 In order/invoices grid select the invoice created in previous step (2468.40 amount)
 Action Regarding Document: Process Made Payment(s)
 Overpayment Action: Leave the credit to be used later
 Click Done button

Returns to first payment and in the header, notice that used credit is 3000.00 and should be 2468.40
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0029145 closedSandrahuguet Used credit is not correct under certain circumstances 

-  Notes
(0075697)
hgbot (developer)
2015-03-17 18:49

Repository: erp/backports/3.0PR14Q3.8
Changeset: 236f8d92d55c1796964167745505b06ab93ddc4b
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Tue Mar 17 18:48:37 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/236f8d92d55c1796964167745505b06ab93ddc4b [^]

Fixed bug 29147: Used credit is not correct under certain circumstances

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0075704)
umartirena (developer)
2015-03-17 19:30

Code Review + Testing OK
(0075749)
hgbot (developer)
2015-03-18 17:38

Repository: erp/backports/3.0PR14Q3.8
Changeset: d528beb78f200e598517a50089e0b34997a95ecd
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Mar 18 17:37:56 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/d528beb78f200e598517a50089e0b34997a95ecd [^]

related to issue 29147

the validation only has to be considered when overpayment combo is visible

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0075757)
umartirena (developer)
2015-03-18 19:05

Code Review + Testing OK
(0075758)
umartirena (developer)
2015-03-18 20:21

Reopened due to a last issue found.
On Friday will be fixed and closed
(0075812)
hgbot (developer)
2015-03-20 14:33

Repository: erp/backports/3.0PR14Q3.8
Changeset: 3ef684d430732ad9c8e5ffe9eee660d763cef15d
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Mar 20 09:32:09 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/3ef684d430732ad9c8e5ffe9eee660d763cef15d [^]

related to issue 29147

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0075814)
umartirena (developer)
2015-03-20 14:55

Code Review + Testing of last changeset is OK
(0075831)
hudsonbot (developer)
2015-03-20 19:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a670497786d1 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-05 16:08 AugustoMauch Type defect => backport
2015-03-05 16:08 AugustoMauch Target Version => 3.0PR14Q3.8
2015-03-05 16:25 ngarcia Issue Monitored: ngarcia
2015-03-05 17:49 ngarcia Triggers an Emergency Pack No => Yes
2015-03-06 08:13 Sandrahuguet Assigned To AugustoMauch => Sandrahuguet
2015-03-06 08:13 Sandrahuguet Category A. Platform => 09. Financial management
2015-03-06 10:22 dmitry_mezentsev Tag Attached: Approved
2015-03-17 18:49 hgbot Checkin
2015-03-17 18:49 hgbot Note Added: 0075697
2015-03-17 18:49 hgbot Status scheduled => resolved
2015-03-17 18:49 hgbot Resolution open => fixed
2015-03-17 18:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/236f8d92d55c1796964167745505b06ab93ddc4b [^]
2015-03-17 19:30 umartirena Review Assigned To => umartirena
2015-03-17 19:30 umartirena Note Added: 0075704
2015-03-17 19:30 umartirena Status resolved => closed
2015-03-17 19:30 umartirena Fixed in Version => 3.0PR14Q3.8
2015-03-18 13:47 Sandrahuguet Status closed => new
2015-03-18 13:47 Sandrahuguet Resolution fixed => open
2015-03-18 13:47 Sandrahuguet Fixed in Version 3.0PR14Q3.8 =>
2015-03-18 17:18 hgbot Checkin
2015-03-18 17:18 hgbot Note Added: 0075747
2015-03-18 17:20 Sandrahuguet Note Deleted: 0075747
2015-03-18 17:38 hgbot Checkin
2015-03-18 17:38 hgbot Note Added: 0075749
2015-03-18 17:38 Sandrahuguet Status new => scheduled
2015-03-18 17:38 Sandrahuguet Status scheduled => resolved
2015-03-18 17:38 Sandrahuguet Resolution open => fixed
2015-03-18 19:05 umartirena Note Added: 0075757
2015-03-18 19:05 umartirena Status resolved => closed
2015-03-18 19:05 umartirena Fixed in Version => 3.0PR14Q3.8
2015-03-18 20:21 umartirena Note Added: 0075758
2015-03-18 20:21 umartirena Status closed => new
2015-03-18 20:21 umartirena Resolution fixed => open
2015-03-18 20:21 umartirena Fixed in Version 3.0PR14Q3.8 =>
2015-03-20 14:33 hgbot Checkin
2015-03-20 14:33 hgbot Note Added: 0075812
2015-03-20 14:55 umartirena Status new => scheduled
2015-03-20 14:55 umartirena Status scheduled => resolved
2015-03-20 14:55 umartirena Fixed in Version => 3.0PR14Q3.8
2015-03-20 14:55 umartirena Resolution open => fixed
2015-03-20 14:55 umartirena Note Added: 0075814
2015-03-20 14:55 umartirena Status resolved => closed
2015-03-20 19:23 hudsonbot Checkin
2015-03-20 19:23 hudsonbot Note Added: 0075831


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker