Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029091
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2015-02-27 10:232015-05-07 22:17
ReporterngarciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityhighResolutionfixedFixed in Versionpi
StatusclosedFix in branchpiFixed in SCM revision2e2ef063c7dd
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029091: Fully depreciated field is not updated when unprocessing an asset amortization

DescriptionFully depreciated field is not updated when unprocessing an asset amortization
Steps To ReproduceAs group admin role:
   Create a record in the Asset window:
      Depreciated: Y
      Calculate Type: Time
      Amortize: Monthly
      Usable Life - Months: 2
      Depreciation Start Date: 01-02-2015
      Asset Value: 1000
   Create the Amortization
   Navigate to each of the amortizations and process them
   Return to the Asset window and check the Depreciated Value = Depreciated Plan and Fully Depreciated = 'Y'
   Return to Amortization window and unprocess one of them
   Check the Depreciated Value = 500, Depreciated Plan = 1000. Fully Depreciated remains as 'Y', which is wrong
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00251063.0MP31 closedAtulOpenbravo Asset set as not fully depreciated when there is a previously depreciated amount 
related to defect 0032280 closedAtulOpenbravo Amortization Process / Unprocess should only update Fully Depreciated field of the assets included on it and need the update 

-  Notes
(0075066)
jorge-garcia (developer)
2015-03-02 11:08

Test Plan

As group admin role:
 Create a record in the Asset window:
   Depreciated: Y
   Calculate Type: Time
   Amortize: Monthly
   Usable Life - Months: 2
   Depreciation Start Date: 01-02-2015
   Asset Value: 1000
 Create the Amortization
 Navigate to each of the amortizations and process them
 Return to the Asset window and check the Depreciated Value = Depreciated Plan and Fully Depreciated = 'Y'
 Return to Amortization window and unprocess one of them
 Check the Depreciated Value = 500, Depreciated Plan = 1000 and Fully Depreciated = 'N'
(0076854)
hgbot (developer)
2015-04-29 10:46

Repository: erp/devel/pi
Changeset: 2e2ef063c7dd6f9ca0c31d469176286ea2c8f8a1
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Mar 02 11:02:02 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2e2ef063c7dd6f9ca0c31d469176286ea2c8f8a1 [^]

Fixed issue 29091: Fully depreciated field is not updated

The process didn't update the Fully Depreciated field when one or more
asset amortization lines were unprocessed.

The problem was in the amortization process.

Now the process changes the isFullyDepreciated field if the Depreciated
Value and the Depreciated Plan fields are differents.

---
M src-db/database/model/functions/A_AMORTIZATION_PROCESS.xml
---
(0076855)
hgbot (developer)
2015-04-29 10:47

Repository: erp/devel/pi
Changeset: 4d152114fbe9bcc3035cacbf337a801806d23a69
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Apr 29 10:22:24 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4d152114fbe9bcc3035cacbf337a801806d23a69 [^]

Related to bug 29091: Code Review

[1]: Fix copyright
[2]: Change != for <>

---
M src-db/database/model/functions/A_AMORTIZATION_PROCESS.xml
---
(0076856)
umartirena (developer)
2015-04-29 10:52

Code Review + Testing OK
(0077179)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077180)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-27 10:23 ngarcia New Issue
2015-02-27 10:23 ngarcia Assigned To => Sandrahuguet
2015-02-27 10:23 ngarcia Modules => Core
2015-02-27 10:23 ngarcia Triggers an Emergency Pack => No
2015-02-27 10:24 ngarcia Relationship added related to 0025106
2015-02-27 10:24 ngarcia Issue Monitored: networkb
2015-02-27 12:33 Sandrahuguet Assigned To Sandrahuguet => jorge-garcia
2015-02-27 12:37 jorge-garcia Status new => scheduled
2015-02-27 12:37 jorge-garcia fix_in_branch => pi
2015-03-02 11:08 jorge-garcia Note Added: 0075066
2015-04-29 10:46 hgbot Checkin
2015-04-29 10:46 hgbot Note Added: 0076854
2015-04-29 10:46 hgbot Status scheduled => resolved
2015-04-29 10:46 hgbot Resolution open => fixed
2015-04-29 10:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2e2ef063c7dd6f9ca0c31d469176286ea2c8f8a1 [^]
2015-04-29 10:47 hgbot Checkin
2015-04-29 10:47 hgbot Note Added: 0076855
2015-04-29 10:52 umartirena Review Assigned To => umartirena
2015-04-29 10:53 umartirena Note Added: 0076856
2015-04-29 10:53 umartirena Status resolved => closed
2015-04-29 10:53 umartirena Fixed in Version => pi
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077179
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077180
2016-02-18 17:44 ngarcia Relationship added related to 0032280


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker