Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029035
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-02-23 18:262015-05-20 12:37
ReportermaiteView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision2aca706e9b8c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-11-13
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c0aa8da15e9c [^]
Triggers an Emergency PackNo
Summary

0029035: Process definition containing parameters defined as "window", should automatically inherit permissions

DescriptionProcess definition containing parameters defined as "window", should automatically inherit permissions
Steps To Reproduce1. Access application and change to use a manual role, as "EspaƱa Finance"
2. Access Sales Invoice "1000133" and run "Add payment" process
3. Realize that no data is shown in "Order/Invoice" grid. Problem is that this role has not access to windows contained in that process definition.

Following error can be found in openbravo.log:

2015-02-23 18:16:27,072 [ajp-localhost%2F127.0.0.1-8809-10] ERROR org.openbravo.client.kernel.KernelUtils - AccessTableNoView
org.openbravo.client.kernel.OBUserException: AccessTableNoView
    at org.openbravo.service.datasource.DataSourceServlet.doPost(DataSourceServlet.java:742)
    
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00297593.0PR15Q2 closedinigosanchez Process definition containing parameters defined as "window", should automatically inherit permissions 
depends on backport 00297603.0PR15Q1.4 closedinigosanchez Process definition containing parameters defined as "window", should automatically inherit permissions 
related to defect 00289993.0PR15Q3 closedinigosanchez Grant access to buttons is not working fine depending on the process you want to configure 
related to defect 00290663.0PR15Q2 closedinigosanchez Is not possible to add new payment from transaction window when working with a role defined as "Manual" 
related to defect 00306193.0PR16Q1 closedTriage Finance Error "java.text.ParseException: Unparseable date: "null" received when running Add Payment process from a copied window 
related to defect 00313863.0PR16Q1 closedaferraz Error shown in Add Payment when role has no access to Financial Account window 

-  Notes
(0076932)
alostale (developer)
2015-05-04 12:14

Workaround: grant explicit access to P&E windows
(0076945)
hgbot (developer)
2015-05-04 14:42

Repository: erp/devel/pi
Changeset: 2aca706e9b8c4ca7093805dd2614418ce030f5b0
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon May 04 13:54:07 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2aca706e9b8c4ca7093805dd2614418ce030f5b0 [^]

Fixed bug 29035:Problems with inherited permissions in process definition

The problem was that when a process containing parameters defined as "window" is
launched , this manual role has not access to windows contained in that process
definition.

The cause of this issue is that before 14Q3, no security check was done on P&E
grids, so data always was retrieved.From 15Q1, security is checked requiring
explicit access to P&E grid.

The issue is fixed by inheriting access from the process, this is if the process
is accessible the grid within the P&E doesn't require to have explicit access
but inherits from the process itself.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/process/BaseProcessActionHandler.java
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/DataSourceServlet.java
---
(0076978)
alostale (developer)
2015-05-05 08:06

code reviewed

tested in:
* Process defined as a button in a standard window
* Process accessed from menu
(0077199)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-23 18:26 maite New Issue
2015-02-23 18:26 maite Assigned To => AugustoMauch
2015-02-23 18:26 maite Modules => Core
2015-02-23 18:26 maite Triggers an Emergency Pack => No
2015-02-23 18:26 maite Issue Monitored: networkb
2015-02-23 18:27 maite Steps to Reproduce Updated View Revisions
2015-02-23 18:32 alostale Relationship added related to 0028999
2015-02-23 18:33 alostale Status new => acknowledged
2015-02-23 18:54 ngarcia Issue Monitored: ngarcia
2015-02-25 17:39 maite Relationship added related to 0029066
2015-02-26 08:24 alostale Relationship added related to 0029049
2015-02-26 08:24 alostale Relationship deleted related to 0029049
2015-03-11 08:09 alostale Priority high => urgent
2015-03-11 08:09 alostale Target Version 3.0PR15Q2 =>
2015-03-17 14:37 alostale Assigned To AugustoMauch => platform
2015-03-23 21:57 inigosanchez Assigned To platform => inigosanchez
2015-03-24 09:21 inigosanchez Status acknowledged => scheduled
2015-05-04 12:14 alostale Regression level => Production - Confirmed Stable
2015-05-04 12:14 alostale Regression date => 2014-11-13
2015-05-04 12:14 alostale Regression introduced in release => 3.0PR15Q1
2015-05-04 12:14 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/c0aa8da15e9c [^]
2015-05-04 12:14 alostale Priority urgent => immediate
2015-05-04 12:14 alostale Note Added: 0076932
2015-05-04 12:14 alostale Status scheduled => feedback
2015-05-04 12:14 alostale Status feedback => new
2015-05-04 12:15 alostale Status new => scheduled
2015-05-04 14:41 inigosanchez Review Assigned To => alostale
2015-05-04 14:42 hgbot Checkin
2015-05-04 14:42 hgbot Note Added: 0076945
2015-05-04 14:42 hgbot Status scheduled => resolved
2015-05-04 14:42 hgbot Resolution open => fixed
2015-05-04 14:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2aca706e9b8c4ca7093805dd2614418ce030f5b0 [^]
2015-05-04 14:50 inigosanchez Issue Monitored: alostale
2015-05-05 08:06 alostale Note Added: 0076978
2015-05-05 08:06 alostale Status resolved => closed
2015-05-05 08:06 alostale Fixed in Version => 3.0PR15Q3
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077199
2015-05-20 12:37 eugeni Issue Monitored: eugeni
2015-08-21 10:08 maite Relationship added related to 0030619
2015-11-06 10:33 aferraz Relationship added related to 0031386


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker