Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028943
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-02-13 13:322015-02-23 05:11
ReporterngarciaView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisiona19973cac41e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-11-17
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/ca006bb312dd1243f340d64c73f426304d88263c [^]
Triggers an Emergency PackNo
Summary

0028943: It should be possible to enter different accounting and document date in GL Journal and Header

DescriptionIt should be possible to enter different accounting and document date in GL Journal and Header. But the Accounting Date should always belong to the Period
Steps To ReproduceAs group admin role:
   Create a Record in the GL Journal window
   Define the Document date
   Change the Accounting date
   Check the Document date is updated with the accounting date and it should not
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0023679 closedreinaldoguerra G\L Journal: not possible to enter different Document and Accounting dates (loop in callout) 
related to defect 0029016 closedaferraz G/L Journal Header document and accounting dates are not copied from G/L Journal 
related to defect 00289523.0PR15Q3 closedfsoto82 Period Not Updated in G/L Journal if the Accounting Date belongs to a closed period. It is not possible to unpost it 

-  Notes
(0074501)
aferraz (developer)
2015-02-16 11:17

As group admin role:
- Create a record in the GL Journal window
- Define the Document date
- Change the Accounting date
- Check the Document date is not updated with the accounting date
- Create a record in the Header tab
- Define the Document date
- Change the Accounting date
- Check the Document date is not updated with the accounting date
(0074527)
hgbot (developer)
2015-02-16 18:07

Repository: erp/devel/pi
Changeset: a19973cac41e73f65840beb07bb4c9c30dd4d45e
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Feb 16 11:11:14 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a19973cac41e73f65840beb07bb4c9c30dd4d45e [^]

Fixes issue 28943: DocDate & AccDate in GLJournal could be different

Document Date and Accounting Date in G/L Journal window and Header tab can now be different

---
M src/org/openbravo/erpCommon/ad_callouts/SL_Journal_Period.java
---
(0074528)
Sandrahuguet (developer)
2015-02-16 18:11

Code review + testing OK
(0074736)
aferraz (developer)
2015-02-20 15:14

Test case added in Testlink:
http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8046 [^]
(0074766)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-13 13:32 ngarcia New Issue
2015-02-13 13:32 ngarcia Assigned To => Sandrahuguet
2015-02-13 13:32 ngarcia Modules => Core
2015-02-13 13:32 ngarcia Triggers an Emergency Pack => No
2015-02-13 13:33 ngarcia Regression level => Production - QA Approved
2015-02-13 13:33 ngarcia Regression date => 2014-11-17
2015-02-13 13:33 ngarcia Regression introduced in release => 3.0PR15Q1
2015-02-13 13:33 ngarcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/ca006bb312dd1243f340d64c73f426304d88263c [^]
2015-02-13 13:34 ngarcia Issue Monitored: networkb
2015-02-13 14:04 Sandrahuguet Assigned To Sandrahuguet => aferraz
2015-02-16 11:17 aferraz Note Added: 0074501
2015-02-16 13:26 ngarcia Relationship added caused by 0023679
2015-02-16 13:39 ngarcia Relationship added blocks 0028952
2015-02-16 18:07 hgbot Checkin
2015-02-16 18:07 hgbot Note Added: 0074527
2015-02-16 18:07 hgbot Status new => resolved
2015-02-16 18:07 hgbot Resolution open => fixed
2015-02-16 18:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a19973cac41e73f65840beb07bb4c9c30dd4d45e [^]
2015-02-16 18:11 Sandrahuguet Review Assigned To => Sandrahuguet
2015-02-16 18:11 Sandrahuguet Note Added: 0074528
2015-02-16 18:11 Sandrahuguet Status resolved => closed
2015-02-16 18:11 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-20 15:14 aferraz Note Added: 0074736
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074766
2015-02-23 10:50 aferraz Relationship added related to 0029016
2015-05-04 17:55 aferraz Relationship deleted blocks 0028952
2015-05-04 17:55 aferraz Relationship added related to 0028952


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker