Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028862
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2015-02-04 13:222015-02-10 18:28
ReportermaiteView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision64fd34510c40
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d45ee3d2e877 [^]
Triggers an Emergency PackNo
Summary

0028862: Error received when processing invoice including line referencing "discount product" line if it has not been delivered

DescriptionError received when processing invoice including line referencing "discount product" line if it has not been delivered
Steps To Reproduce1. Register Sales Order for any Org and Alimentos y Supermercados BP.
2. Add any line. Verify that discount register has been included in "Discounts" tab and process order
3. Register Goods Shipment header and run "Create lines from" process. Include only product line and not include discount line. Process Shipment
4. Register Sales Invoice header and run "Create Lines from" process. Select previous Order and include both lines. Process and realize that following error is received "It is not possible to complete the invoice 1000133 line 20. Order No. 1000126: Invoiced Quantity cannot be higher than Delivered Quantity when Invoice Terms are: After Delivery."

NOTE: in Q4 version you are able to follow same steps and properly complete sales invoice
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00274853.0PR15Q1 closedreinaldoguerra Should not be possible to invoice more quantity than delivered quantity, when Invoice Terms are "After delivery" 

-  Notes
(0074247)
hgbot (developer)
2015-02-06 11:41

Repository: erp/devel/pi
Changeset: 64fd34510c402d2c08d036a8f5303e244021e345
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Feb 06 08:17:31 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/64fd34510c402d2c08d036a8f5303e244021e345 [^]

fixed issue 28862 backout changeset d45ee3d2e877

---
M src-db/database/model/functions/C_INVOICE_POST.xml
---
(0074248)
hgbot (developer)
2015-02-06 11:42

Repository: erp/devel/pi
Changeset: 52c6748ca22a72960f45cd5212292142e4788ccb
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Feb 06 08:29:42 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/52c6748ca22a72960f45cd5212292142e4788ccb [^]

Related to issue 28862

add warning message when invoiced quantity is higher than delivered
quantity when invoice terms are After Delivery

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/erpCommon/ad_callouts/SL_Invoice_Amt.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Invoice_Amt_data.xsql
---
(0074254)
aferraz (developer)
2015-02-06 14:22

Code review + Testing OK
(0074299)
hudsonbot (developer)
2015-02-09 21:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d68c131a3f59 [^]
Maturity status: Test
(0074300)
hudsonbot (developer)
2015-02-09 21:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d68c131a3f59 [^]
Maturity status: Test
(0074336)
Sandrahuguet (developer)
2015-02-10 18:28

Test added in testlink:

http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8035 [^]

- Issue History
Date Modified Username Field Change
2015-02-04 13:22 maite New Issue
2015-02-04 13:22 maite Assigned To => dmiguelez
2015-02-04 13:22 maite Modules => Core
2015-02-04 13:22 maite Regression level => Production - QA Approved
2015-02-04 13:22 maite Regression introduced in release => 3.0PR15Q1
2015-02-04 13:22 maite Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d45ee3d2e877 [^]
2015-02-04 13:22 maite Triggers an Emergency Pack => No
2015-02-04 13:22 maite Issue Monitored: networkb
2015-02-04 13:34 Sandrahuguet Assigned To dmiguelez => umartirena
2015-02-05 17:38 Sandrahuguet Assigned To umartirena => Sandrahuguet
2015-02-06 11:41 hgbot Checkin
2015-02-06 11:41 hgbot Note Added: 0074247
2015-02-06 11:41 hgbot Status new => resolved
2015-02-06 11:41 hgbot Resolution open => fixed
2015-02-06 11:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/64fd34510c402d2c08d036a8f5303e244021e345 [^]
2015-02-06 11:42 hgbot Checkin
2015-02-06 11:42 hgbot Note Added: 0074248
2015-02-06 14:22 aferraz Review Assigned To => aferraz
2015-02-06 14:22 aferraz Note Added: 0074254
2015-02-06 14:22 aferraz Status resolved => closed
2015-02-06 16:37 dmitry_mezentsev Relationship added caused by 0027485
2015-02-09 21:48 hudsonbot Checkin
2015-02-09 21:48 hudsonbot Note Added: 0074299
2015-02-09 21:48 hudsonbot Checkin
2015-02-09 21:48 hudsonbot Note Added: 0074300
2015-02-10 18:28 Sandrahuguet Note Added: 0074336


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker