Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028779
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-01-27 11:552015-02-04 20:35
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisionb71f486b4915
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028779: Value of combo is not displayed after setting it with a trigger

DescriptionValue of combo is not displayed after setting it with a trigger. It seems that the value map of the OBFKComboItem is not filled with the new assigned value until you refresh the record.
Steps To Reproduce1) Create the attached trigger, which sets the value of a column (c_tax_id) with table reference
2) Go to the [Purchase Invoice] window. Create a new record in the header.
3) Create a new record in the lines tab. Save it.
4) Notice that the value of the tax field is empty.
5) Refresh the record
6) Now the value appears. From now the problem won't happen until you open the window again
TagsNo tags attached.
Attached Files? file icon trigger.sql [^] (590 bytes) 2015-01-27 11:55

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 00262673.0PR14Q3 closedshankarb Re-implement combos (table and tableDir) to use datasources 
causes defect 0030940 closedNaroaIriarte When add a second new line in goods movements, the product field is already filled 

-  Notes
(0073876)
hgbot (developer)
2015-01-29 08:19

Repository: erp/devel/pi
Changeset: b71f486b491559c86ce99065c783fd85cc8fe798
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Jan 28 17:29:42 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b71f486b491559c86ce99065c783fd85cc8fe798 [^]

fixed bug 28779: value of combo not displayed after setting it with a trigger

  When creating/refreshing a record, if the value of a FK drop down (table, tableDir
  and selector references) is changed in the backed (ie. through a trigger) and that
  drop down was not previously opened the value was seen as empty. The problem was
  the actual value was set but not is identifier in the valueMap.

  The fix handles this case on the dataSource reponse. It adds the new values to the
  valueMap if it is not present.

  setEntries method has been moved from OBFKComboItem to OBSelectorItem to handle it
  both for selectors and table/tableDir references.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view-datasource.js
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-formitem-fk-combo.js
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0074047)
hgbot (developer)
2015-02-03 17:57

Repository: erp/devel/pi
Changeset: 377df53b49e507a9f594dc6f8d359fde51e7da86
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Feb 03 17:48:24 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/377df53b49e507a9f594dc6f8d359fde51e7da86 [^]

Related with issue 28779: Moves instruction out of the loop

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view-datasource.js
---
(0074048)
AugustoMauch (developer)
2015-02-03 17:57

Code reviewed and verified in pi@377df53b49e5
(0074194)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074214)
hudsonbot (developer)
2015-02-04 20:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-27 11:55 caristu New Issue
2015-01-27 11:55 caristu Assigned To => AugustoMauch
2015-01-27 11:55 caristu File Added: trigger.sql
2015-01-27 11:55 caristu Modules => Core
2015-01-27 11:55 caristu Triggers an Emergency Pack => No
2015-01-27 12:05 caristu Issue Monitored: networkb
2015-01-29 08:19 hgbot Checkin
2015-01-29 08:19 hgbot Note Added: 0073876
2015-01-29 08:19 hgbot Status new => resolved
2015-01-29 08:19 hgbot Resolution open => fixed
2015-01-29 08:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b71f486b491559c86ce99065c783fd85cc8fe798 [^]
2015-01-29 09:05 alostale Review Assigned To => AugustoMauch
2015-01-29 09:05 alostale Assigned To AugustoMauch => alostale
2015-01-29 09:06 alostale Relationship added related to 0026267
2015-02-03 17:57 hgbot Checkin
2015-02-03 17:57 hgbot Note Added: 0074047
2015-02-03 17:57 AugustoMauch Note Added: 0074048
2015-02-03 17:57 AugustoMauch Status resolved => closed
2015-02-03 17:57 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074194
2015-02-04 20:35 hudsonbot Checkin
2015-02-04 20:35 hudsonbot Note Added: 0074214
2015-10-14 09:54 alostale Relationship added causes 0030940


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker