Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028736
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-01-22 16:582015-02-09 09:22
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision54caa7a8270a
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028736: Link to parent tree tables displayed in child tabs should be filtered by the selected parent record automatically

DescriptionLink to parent tree tables displayed in child tabs should be filtered by the selected parent record automatically. Currently it is necessary to configure an HQL where clause using the "HQL Where Clause for root nodes" field.

Notice that AD Tree Node tree structure behaves in this way. For example:

  - In the [Account Tree], the "Element Value" tab is based on an AD Tree Node tree structure table. It does not use the "HQL Where Clause for root nodes" field and the records in the tab are filtered properly when selecting a parent record in the header

  - In the [Cost Adjustment] window, the "Line" tab is based on a Link to parent tree structure. It is making use of the "HQL Where Clause for root nodes" to filter the records by the parent record in the header.
Steps To ReproduceInstall the attached patch. It adds a column and a field to the Unit of Measure Transation table and makes it a Link to Parent based tree.

As System Admin:
- Open unit of measure
- Select any record
- Open the tree view of the Translation subtab. Check that all the translations are shown, not only those that belong to the record selected in the header tab.
TagsNo tags attached.
Attached Filespatch file icon test28736.patch [^] (14,128 bytes) 2015-02-02 16:47 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
causes defect 0028847 closedAugustoMauch Change in method modifier has broken the API 

-  Notes
(0073993)
hgbot (developer)
2015-02-02 16:49

Repository: erp/devel/pi
Changeset: 54caa7a8270a2d5bab573f880d41e6852d37f791
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Feb 02 16:24:33 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/54caa7a8270a2d5bab573f880d41e6852d37f791 [^]

Fixes issue 28736: Selected record in parent tab criteria is applied to trees

In order to show the proper records in the subtabs, a criteria is applied based on the record selected in the parent tab. This criteria was automatically being added in the trees based
on the ADTree structure, but not in those based on the LinkToParent structure.

Now this criteria is also added in the LinkToParent trees if the following conditions are met:
- The tab is not a header tab
- The tree does not define a HQL clause for root nodes
- The parameters contains the info needed to build the new criteria

The getParentRecordIdFromCriteria method, which was used in the ADTreeDatasourceService for this purpose, has been moved up to TreeDatasourceService so that it can be reused by LinkToPa
rentTreeDatasourceService.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ADTreeDatasourceService.java
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/LinkToParentTreeDatasourceService.java
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/TreeDatasourceService.java
---
(0073994)
hgbot (developer)
2015-02-02 16:52

Repository: erp/devel/pi
Changeset: e80c827222a3328818f6e746a15566156a95cae3
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Feb 02 16:50:49 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e80c827222a3328818f6e746a15566156a95cae3 [^]

Related with issue 28736: Updates copyright year

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ADTreeDatasourceService.java
---
(0074012)
alostale (developer)
2015-02-03 09:01

Code review:
-missing javadoc in new protected method: TreeDatasourceService.getParentRecordIdFromCriteria
(0074016)
hgbot (developer)
2015-02-03 10:33

Repository: erp/devel/pi
Changeset: 128a5d39aba2a3e2e979a54f143c31d8fbf83b65
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Feb 03 10:32:54 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/128a5d39aba2a3e2e979a54f143c31d8fbf83b65 [^]

Related with issue 28736: Adds javadoc and final modifier to method

The getParentRecordIdFromCriteria of the TreeDatasourceService is not meant to be overwritten, so the final modifier has been added. The method cannot be made private because it is used by two of the TreeDatasourceService subclasses.

Also, javadoc for this method has been added.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/TreeDatasourceService.java
---
(0074206)
hudsonbot (developer)
2015-02-04 20:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074207)
hudsonbot (developer)
2015-02-04 20:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074211)
hudsonbot (developer)
2015-02-04 20:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074267)
alostale (developer)
2015-02-09 09:22

code reviewed + tested with attached patch and existent trees in distribution

- Issue History
Date Modified Username Field Change
2015-01-22 16:58 caristu New Issue
2015-01-22 16:58 caristu Assigned To => AugustoMauch
2015-01-22 16:58 caristu Modules => Core
2015-01-22 16:58 caristu Triggers an Emergency Pack => No
2015-01-22 16:58 caristu Issue Monitored: networkb
2015-01-29 10:34 alostale Status new => scheduled
2015-01-29 10:34 alostale fix_in_branch => pi
2015-02-02 16:25 AugustoMauch Issue Monitored: alostale
2015-02-02 16:25 AugustoMauch Review Assigned To => alostale
2015-02-02 16:25 AugustoMauch fix_in_branch pi =>
2015-02-02 16:47 AugustoMauch File Added: test28736.patch
2015-02-02 16:48 AugustoMauch Steps to Reproduce Updated View Revisions
2015-02-02 16:49 hgbot Checkin
2015-02-02 16:49 hgbot Note Added: 0073993
2015-02-02 16:49 hgbot Status scheduled => resolved
2015-02-02 16:49 hgbot Resolution open => fixed
2015-02-02 16:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/54caa7a8270a2d5bab573f880d41e6852d37f791 [^]
2015-02-02 16:52 hgbot Checkin
2015-02-02 16:52 hgbot Note Added: 0073994
2015-02-03 09:01 alostale Note Added: 0074012
2015-02-03 10:33 hgbot Checkin
2015-02-03 10:33 hgbot Note Added: 0074016
2015-02-03 14:03 AugustoMauch Relationship added causes 0028847
2015-02-04 20:35 hudsonbot Checkin
2015-02-04 20:35 hudsonbot Note Added: 0074206
2015-02-04 20:35 hudsonbot Checkin
2015-02-04 20:35 hudsonbot Note Added: 0074207
2015-02-04 20:35 hudsonbot Checkin
2015-02-04 20:35 hudsonbot Note Added: 0074211
2015-02-09 09:22 alostale Note Added: 0074267
2015-02-09 09:22 alostale Status resolved => closed
2015-02-09 09:22 alostale Fixed in Version => 3.0PR15Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker