Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028662
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2015-01-18 21:122015-05-07 22:16
ReporterrjapoovaView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision8bf39bc67924
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR14Q4SCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-09-23
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
Triggers an Emergency PackNo
Summary

0028662: The business partner selector in Add New Transaction does not include all business partners

DescriptionIn the Match Statement flow, if you need to add a new transaction coming from an imported statement (Add New Transaction window), the business partner selector does not include all business partners.

It appears that when you are in the Add New Transaction window itself and you try to type a business partner in the field, only business partners with a valid location are available for selection. However, if you open the selector itself (press on magnifying glass icon), all business partners are available.

In general in the Financial Account window, you can associate a transaction with any business partner, even if they are not customers or vendors and even if they do not have a location.

This is important because business partners transacted through credit card do not necessarily have a known location and that is not needed.
Steps To ReproduceSee this video from 2':50" to 3':30":
https://drive.google.com/file/d/0B2uCUQlrOPvIUXZ5cDdmd3IydDg/view?usp=sharing [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00296443.0PR15Q2 closedaferraz The business partner selector in Add New Transaction does not include all business partners 
depends on backport 00296453.0PR15Q1.4 closedaferraz The business partner selector in Add New Transaction does not include all business partners 
caused by feature request 00293903.0PR14Q4 closedSandrahuguet Reconciliation refactor project 
has duplicate defect 00296813.0PR15Q3 closedTriage Finance Business Partner selector in "Match Statement | Add transaction" pop-up is always showing "customers" in drop down list 

-  Notes
(0076728)
hgbot (developer)
2015-04-23 15:50

Repository: erp/devel/pi
Changeset: 8bf39bc67924e2bd0071a7e388a7cd956eb4bb91
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Apr 23 12:44:09 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8bf39bc67924e2bd0071a7e388a7cd956eb4bb91 [^]

Fixes issue 28662: BP selector in AddTransaction shows all bp

"Business Partner selector" selector of "Business Partner" paramenter in "AddTransaction" process definition, has been changed into "Business Partner selector without default expressions" selector; in order to show all business partners in the dropdown of the selector.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_REFERENCE.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUIAPP_PARAMETER.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0076729)
hgbot (developer)
2015-04-23 15:50

Repository: erp/devel/pi
Changeset: 9713bfd119303031252d181d0f6b0e922f0f2312
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Apr 23 15:43:27 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9713bfd119303031252d181d0f6b0e922f0f2312 [^]

Related to issue 28662: changed column in selector field
 to get the right name, description and help for the selector's column

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0076730)
vmromanos (developer)
2015-04-23 15:51

Code review + testing OK
(0077148)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077149)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-18 21:12 rjapoova New Issue
2015-01-18 21:12 rjapoova Assigned To => dmiguelez
2015-01-18 21:12 rjapoova Modules => Core
2015-01-18 21:12 rjapoova Triggers an Emergency Pack => No
2015-04-17 20:25 dmitry_mezentsev Assigned To dmiguelez => Triage Finance
2015-04-17 20:25 dmitry_mezentsev Status new => acknowledged
2015-04-17 20:28 dmitry_mezentsev Priority normal => immediate
2015-04-17 20:28 dmitry_mezentsev Severity major => minor
2015-04-17 20:29 dmitry_mezentsev Relationship added caused by 0029390
2015-04-17 20:40 dmitry_mezentsev Regression level => Production - QA Approved
2015-04-20 11:42 aferraz Regression date => 2014-09-23
2015-04-20 11:42 aferraz Regression introduced in release => 3.0PR14Q4
2015-04-20 11:42 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2015-04-21 09:55 aferraz Status acknowledged => scheduled
2015-04-21 09:55 aferraz Assigned To Triage Finance => aferraz
2015-04-21 13:09 aferraz Regression level Production - QA Approved => Production - Confirmed Stable
2015-04-23 12:41 umartirena Relationship added has duplicate 0029681
2015-04-23 15:50 hgbot Checkin
2015-04-23 15:50 hgbot Note Added: 0076728
2015-04-23 15:50 hgbot Status scheduled => resolved
2015-04-23 15:50 hgbot Resolution open => fixed
2015-04-23 15:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8bf39bc67924e2bd0071a7e388a7cd956eb4bb91 [^]
2015-04-23 15:50 hgbot Checkin
2015-04-23 15:50 hgbot Note Added: 0076729
2015-04-23 15:51 vmromanos Review Assigned To => vmromanos
2015-04-23 15:51 vmromanos Note Added: 0076730
2015-04-23 15:51 vmromanos Status resolved => closed
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077148
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077149


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker