Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028618
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminoralways2015-01-14 18:152016-04-08 11:00
ReporterVictorVillarView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision056348867989
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-02-18
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/0b033ca5bd1b08e81a30cfdbab2b459549d8c17c [^]
Triggers an Emergency PackYes
Summary

0028618: It is possible to reserve more qty than the qty of the order

DescriptionIt is possible to reserve more qty than the qty of the order
Steps To ReproduceAs group admin role,
Reservations are disabled by default. To be able to use them please insert a new Preference using property Enable Stock Reservations with value Y.
  Go to Sales Order,
    Org: EspaƱa
    business Partner: Alimentos
  Lines tab:
     Product: Agua
     qty: 100
     stock reservation: automatic
Complete it.

Go to Stock reservation window,
  open the manage stock popup
     update the qty to 2000000
click on OK.
You can do it without any restriction.

After that you can register a goods shipment (qty: 100) which is related to the sales order.
Then, you will not be able to create a new goods shipment of this product and try to take out all units of the warehous, because you have 2000000 units reserved.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028459 closededuardo_Argal Openbravo ERP It is necessary a modulescript to solve stock inconsistencies 
caused by design defect 0023412 closedSandrahuguet Openbravo ERP Manage Stock Pick and Execute Window does not work with large amount of data 
related to defect 0028645 closedvmromanos Openbravo ERP It would be nice to be able to reserve more qty than the qty of the order if you have defined the 'is qty variable' 
related to defect 0038093 closedAtulOpenbravo QA After the fix of 28645 should not be possible to enter a reservation greater than the sales order. However it is possible  

-  Notes
(0073503)
hgbot (developer)
2015-01-14 18:51

Repository: erp/devel/pi
Changeset: 056348867989bb66514de37bf21c26091247bb4e
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Jan 14 18:44:36 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/056348867989bb66514de37bf21c26091247bb4e [^]

Fixed bug 28618 Added OB.Reservation.QuantityValidate to quantity field

OB.Reservation.QuantityValidate is missing after after stock
reservation refactor

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0073504)
Sandrahuguet (developer)
2015-01-14 18:53

modulescript is pending to fix erroneous data
(0073520)
Sandrahuguet (developer)
2015-01-15 13:15

after discussing with Dmitry the modulescript is not necessary
(0073522)
umartirena (developer)
2015-01-15 13:51

Code review + Testing OK
(0073523)
dmitry_mezentsev (developer)
2015-01-15 13:59

As per Severity definition - it has to be Minor,
http://wiki.openbravo.com/wiki/Bug_Reporting_Guidelines#How_to_Choose_the_Right_Severity [^]
(0074146)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074346)
Sandrahuguet (developer)
2015-02-11 09:08

Test case added in testlink:

http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8020 [^]
(0085522)
hgbot (developer)
2016-04-08 11:00

Repository: tools/automation/int
Changeset: 709ff12f8bd327baa07965fb9725e6a9598abe86
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Feb 24 10:22:16 2016 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/709ff12f8bd327baa07965fb9725e6a9598abe86 [^]

Related to issue 28618: Add an automated test

---
M src-test/com/openbravo/test/integration/erp/gui/sales/transactions/salesorder/HeaderTab.java
M src-test/com/openbravo/test/integration/erp/gui/sales/transactions/salesorder/LinesTab.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RES_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/sales/transactions/SalesOrder.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RESRegression28618.java
---

- Issue History
Date Modified Username Field Change
2015-01-14 18:15 VictorVillar New Issue
2015-01-14 18:15 VictorVillar Assigned To => Sandrahuguet
2015-01-14 18:15 VictorVillar Modules => Core
2015-01-14 18:15 VictorVillar Regression level => Production - Confirmed Stable
2015-01-14 18:15 VictorVillar Regression date => 2015-02-18
2015-01-14 18:15 VictorVillar Regression introduced in release => 3.0PR14Q2.6
2015-01-14 18:15 VictorVillar Triggers an Emergency Pack => No
2015-01-14 18:16 VictorVillar Issue Monitored: networkb
2015-01-14 18:48 Sandrahuguet Status new => scheduled
2015-01-14 18:48 Sandrahuguet fix_in_branch => pi
2015-01-14 18:48 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/0b033ca5bd1b08e81a30cfdbab2b459549d8c17c [^]
2015-01-14 18:48 Sandrahuguet fix_in_branch pi =>
2015-01-14 18:49 Sandrahuguet Regression introduced in release 3.0PR14Q2.6 => 3.0PR14Q2
2015-01-14 18:51 hgbot Checkin
2015-01-14 18:51 hgbot Note Added: 0073503
2015-01-14 18:51 hgbot Status scheduled => resolved
2015-01-14 18:51 hgbot Resolution open => fixed
2015-01-14 18:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/056348867989bb66514de37bf21c26091247bb4e [^]
2015-01-14 18:53 Sandrahuguet Note Added: 0073504
2015-01-15 10:36 dmitry_mezentsev Relationship added caused by 0023412
2015-01-15 12:46 VictorVillar Triggers an Emergency Pack No => Yes
2015-01-15 12:46 VictorVillar Relationship added related to 0028459
2015-01-15 13:15 Sandrahuguet Note Added: 0073520
2015-01-15 13:51 umartirena Review Assigned To => umartirena
2015-01-15 13:51 umartirena Note Added: 0073522
2015-01-15 13:51 umartirena Status resolved => closed
2015-01-15 13:51 umartirena Fixed in Version => pi
2015-01-15 13:59 dmitry_mezentsev Note Added: 0073523
2015-01-15 13:59 dmitry_mezentsev Severity major => minor
2015-01-16 11:23 VictorVillar Relationship added related to 0028645
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074146
2015-02-11 09:08 Sandrahuguet Note Added: 0074346
2016-04-08 11:00 hgbot Checkin
2016-04-08 11:00 hgbot Note Added: 0085522
2018-03-09 13:29 plujan Relationship added related to 0038093


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker