Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028601
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-01-13 18:422015-02-23 05:11
ReporterVictorVillarView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision04daf492cab4
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028601: Wrong verification for periods closed

DescriptionWrong verification for periods closed
Steps To ReproduceYour environment should be before Q4.
Your organization should have a calendar with 13 period (adjustment period) 2014
Update the environment to Q4.
This organization should have warehouse transactions in 31-12-2014
Create a Landed Cost Document - Reference date: 12/11/2014
Try to complete it. An error message appears: 13 Period is closed.
That is wrong.

periodClosed method in CostingUtilsData.java should not take into account periods types = A (adjustment period), because these Periods Adjustment include only GL journal documents, not more.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0074321)
hgbot (developer)
2015-02-10 13:00

Repository: erp/devel/pi
Changeset: 04daf492cab4c586f35249880bdb8016bd91b7de
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Feb 10 10:59:40 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/04daf492cab4c586f35249880bdb8016bd91b7de [^]

Fixes Issue 28601:Wrong verification for periods closed

In CostingUtils closedPeriod method, Adjustment Period Types are skipped
in case of document base type CAD

---
M src/org/openbravo/costing/CostingUtils_data.xsql
---
(0074322)
aferraz (developer)
2015-02-10 13:01

Code review + Testing OK
(0074744)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-13 18:42 VictorVillar New Issue
2015-01-13 18:42 VictorVillar Assigned To => dmiguelez
2015-01-13 18:42 VictorVillar Modules => Core
2015-01-13 18:42 VictorVillar Triggers an Emergency Pack => No
2015-01-13 18:42 VictorVillar Assigned To dmiguelez => Sandrahuguet
2015-01-13 18:45 VictorVillar Issue Monitored: networkb
2015-01-15 09:59 VictorVillar Steps to Reproduce Updated View Revisions
2015-02-05 12:36 AtulOpenbravo Assigned To Sandrahuguet => AtulOpenbravo
2015-02-05 12:37 AtulOpenbravo Status new => scheduled
2015-02-05 12:37 AtulOpenbravo fix_in_branch => pi
2015-02-10 13:00 hgbot Checkin
2015-02-10 13:00 hgbot Note Added: 0074321
2015-02-10 13:00 hgbot Status scheduled => resolved
2015-02-10 13:00 hgbot Resolution open => fixed
2015-02-10 13:00 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/04daf492cab4c586f35249880bdb8016bd91b7de [^]
2015-02-10 13:01 aferraz Review Assigned To => aferraz
2015-02-10 13:01 aferraz Note Added: 0074322
2015-02-10 13:01 aferraz Status resolved => closed
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074744


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker