Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028537
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-01-07 15:542015-02-04 20:33
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision6dd2893296e2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date2014-11-11
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c51dce7e9fd3 [^]
Triggers an Emergency PackNo
Summary

0028537: Wrong behaviour when sorting a grid after scrolling

DescriptionIn a grid that has more records than fit in a page, if the user first scrolls it down and then click on a column header to use it to sort the grid, then:
- The first page will be loaded (this is OK)
- It will not be possible to load the next pages
Steps To ReproduceAs F&B Admin:
- Open the Country and Region window
- See that there are more than 100 records to load (>100 text in the upper left corner of the grid)
- Scroll down the header tab (just a little is enough, no need to load the second
page)
- Click on any column title to sort the grid
- Check that the grid thinks that there are only 100 records to load. Scroll down and you will see that the second page is not loaded
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0025811 closedAugustoMauch unnecessary request on grid refresh 

-  Notes
(0073335)
hgbot (developer)
2015-01-07 16:03

Repository: erp/devel/pi
Changeset: 6dd2893296e235e43838518dc7e97767946dcb5b
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Jan 07 16:02:36 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6dd2893296e235e43838518dc7e97767946dcb5b [^]

Fixes issue 28537: Grid is loaded properly after scrolling it and sorting it

In this changeset [1] a change was done to prevent modifying improperly the totalRows property of the grid after scrolling. This code was meant to be executed after scrolling the grid, and to check it the lastScrollTop property and the getScrollTop() function of the grid body were compared. This check works properly when event that triggered the datasource request was the grid being filtered or a new page being fetched due to scrolling the grid.

The problem was that the check did not work properly when the datasource request was triggered due to having sorted the grid. In this case, the totalRows property should be left as is. To fix this, a new flag is used to control when the datasource request has been triggered by a sorting event.

[1] https://code.openbravo.com/erp/devel/pi/rev/c51dce7e9fd3 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0073336)
AugustoMauch (developer)
2015-01-07 16:23

Testlink: http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8016 [^]
(0073346)
alostale (developer)
2015-01-08 11:25

code reviewed

tested for steps to reproduce + test cases defined for 0028231 http://wiki.openbravo.com/wiki/Projects:Prevent_Unneeded_Grid_Requests%26action/QA-Test_Plan [^]
(0074118)
hudsonbot (developer)
2015-02-04 20:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-07 15:54 AugustoMauch New Issue
2015-01-07 15:54 AugustoMauch Assigned To => AugustoMauch
2015-01-07 15:54 AugustoMauch Modules => Core
2015-01-07 15:54 AugustoMauch Regression level => Coding ( Testing )
2015-01-07 15:54 AugustoMauch Regression date => 2014-11-11
2015-01-07 15:54 AugustoMauch Regression introduced in release => main
2015-01-07 15:54 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi-prevent-multiple-requests/rev/c51dce7e9fd3 [^]
2015-01-07 15:54 AugustoMauch Triggers an Emergency Pack => No
2015-01-07 15:58 AugustoMauch Regression introduced by commit https://code.openbravo.com/erp/devel/pi-prevent-multiple-requests/rev/c51dce7e9fd3 [^] => https://code.openbravo.com/erp/devel/pi/rev/c51dce7e9fd3 [^]
2015-01-07 16:02 AugustoMauch Issue Monitored: alostale
2015-01-07 16:02 AugustoMauch Review Assigned To => alostale
2015-01-07 16:03 hgbot Checkin
2015-01-07 16:03 hgbot Note Added: 0073335
2015-01-07 16:03 hgbot Status new => resolved
2015-01-07 16:03 hgbot Resolution open => fixed
2015-01-07 16:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6dd2893296e235e43838518dc7e97767946dcb5b [^]
2015-01-07 16:23 AugustoMauch Note Added: 0073336
2015-01-08 08:13 alostale Relationship added caused by 0025811
2015-01-08 11:25 alostale Note Added: 0073346
2015-01-08 11:25 alostale Status resolved => closed
2015-01-08 11:25 alostale Fixed in Version => 3.0PR15Q2
2015-02-04 20:33 hudsonbot Checkin
2015-02-04 20:33 hudsonbot Note Added: 0074118


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker