Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028533
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Remittancemajoralways2015-01-07 14:092015-01-30 12:48
ReporterngarciaView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision2a2209d3f6c2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date2014-11-24
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/81e131e2af2c [^]
Regression level
Review Assigned To
Regression introduced in release
Summary

0028533: Remittance module does not properly manage temporary Cash VAT posting into fnal VAT posting

DescriptionRemittance module does not properly manage temporary Cash VAT posting into "final" VAT posting, in the case of including either a sales or purchase Invoice in a remittance.
Steps To ReproduceGo to purchase invoice and create a new invoice for a vendor who has a remittance type payment method, such as "Cuaderno 34".
This vendor has also to be a CASH VAT vendor.

Complete and post the invoice. Posting will look like: (Spanish/ EUR General Ledger)

Debit: (60000) Compras 3750
Debit: (47200T) IVA soportado Temporal 650
Credit: (40000) Proveedores 4400

Let's say that invoice due date is 31-10-2014

Go to Remittance window and create a new remittance. Enter below data:

Remittance Type: Cuaderno 34
Expected date: 31-10-2014
Name: Payment remittance
Press "Select Orders or Invoices".

In this new window select the INVOICE previously created Press Process.
Realize that the tab Lines includes now the invoice to be paid through the remittance.

Press Process and then post.

Posting will look like:
Debit: (40000) Proveedores 4400
Credit: (40100) Proveedores efectos comerciales a pagar 4400

Go to Settle/Protest Remittances window and select the remittance previously created in the field Remittance.

Press search. Remittance is shown.

Enter 15-11-2014 as "Accounting Date" and press Settle.

Go to Remittance window, "Settled" tab and post the settled remittance.

Posting would look like:

Debit: (40100) Proveedores efectos comeciales a pagar 4400
Credit: (57200) Bancos 4400
Proposed SolutionAbove posting shouls also include temporary VAT post to final VAT.

Debit: (47200) IVA soportado 650
Credit: (47200T) IVA soportado Temporal 650
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0027078 closedSandrahuguet Modules Remittance module does not properly manage temporary Cash VAT posting into fnal VAT posting. 
caused by defect 00278203.0PR15Q1 closedAtulOpenbravo Openbravo ERP Error when posting Payment/Transaction/Reconciliation referencing a cash vat invoice linked to several orders 

-  Notes
(0073338)
hgbot (developer)
2015-01-07 17:35

Repository: erp/mods/org.openbravo.module.remittance
Changeset: 2a2209d3f6c2a8169a9deaf1f9ce2207045523b1
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Jan 07 15:50:20 2015 +0100
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/2a2209d3f6c2a8169a9deaf1f9ce2207045523b1 [^]

Fixed bug 28533 Remittances does not properly manage temporary Cash VAT

---
M src/org/openbravo/module/remittance/ad_forms/DocREMRemittanceCancel.java
---
(0073944)
psanjuan (manager)
2015-01-30 12:48

Verified.

- Issue History
Date Modified Username Field Change
2015-01-07 14:09 ngarcia New Issue
2015-01-07 14:09 ngarcia Assigned To => AtulOpenbravo
2015-01-07 14:09 ngarcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/81e131e2af2c [^]
2015-01-07 14:10 ngarcia Relationship added caused by 0027820
2015-01-07 14:10 ngarcia Relationship added related to 0027746
2015-01-07 14:10 ngarcia Issue Monitored: networkb
2015-01-07 14:10 ngarcia Relationship deleted related to 0027746
2015-01-07 14:10 ngarcia Relationship added related to 0027078
2015-01-07 15:15 Sandrahuguet Assigned To AtulOpenbravo => Sandrahuguet
2015-01-07 15:19 Sandrahuguet Regression date => 2014-11-24
2015-01-07 15:22 Sandrahuguet Status new => scheduled
2015-01-07 15:22 Sandrahuguet fix_in_branch => pi
2015-01-07 17:35 hgbot Checkin
2015-01-07 17:35 hgbot Note Added: 0073338
2015-01-07 17:35 hgbot Status scheduled => resolved
2015-01-07 17:35 hgbot Resolution open => fixed
2015-01-07 17:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/2a2209d3f6c2a8169a9deaf1f9ce2207045523b1 [^]
2015-01-13 09:25 psanjuan fix_in_branch pi =>
2015-01-13 09:25 psanjuan Proposed Solution updated
2015-01-30 12:48 psanjuan Note Added: 0073944
2015-01-30 12:48 psanjuan Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker