Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028482
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2014-12-24 10:212015-03-24 17:41
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision926cf5c76aae
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2014-06-11
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/990a2a2410e9 [^]
Triggers an Emergency PackYes
Summary

0028482: Payment's amount is still converted when changing fromdefault multicurrency financial account to same currency financial account

DescriptionPayment's amount is still converted when changing fromdefault multicurrency financial account to same currency financial account
Steps To Reproduce1. Create new Financial Account in MXN currency for España Norte organization. Add "Transferencia" payment method with "receive payments in multiple currencies" option checked
2. Define Conversion Rate between EUR and MXN
3. Set new MXN financial account as default financial account for Business Partner "Alimentos y Supermercados" in its Client tab
4. Register Sales Invoice for España Norte and Alimentos y Supermercados. Add any line and process
5. Run "Add payment" process. Realize that MXN financial account is set as default (which is correct) and that Conversion Rate and Converted Amount has been properly calculated
6. Modify default's financial account and set Cuenta de Banco. Process and deposit payment
7. Access to Cuenta de Banco financial account and verify that transaction has been created with converted amount when it should not
Proposed SolutionWhen financial account is changed in "add payment" pop-up, conversion rate and converted amount values needs to be recalculated
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0029391 closedSandrahuguet Add Payment refactor project 

-  Notes
(0072817)
hgbot (developer)
2014-12-24 13:31

Repository: erp/devel/pi
Changeset: 926cf5c76aaeef332d988368b2cabcafa5aabb9b
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Dec 24 13:29:10 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/926cf5c76aaeef332d988368b2cabcafa5aabb9b [^]

Fixed bug 28482: Exchange rate and Converted Amt in Add Payment

The Exchange rate and Converted amount fields were not properly updated when 2 financial accounts (the first one of them with different currency than the invoice and the second one with the same currency) are selected sequentially into the Add Payment process.

Casue: the conversion rate was wrongly sent back to the JS as a String ("1") instead of using a number. The OB.APRM.AddPayment.paymentMethodMulticurrency function checks the received conversion rate is a number before updating the converted amount. Since the converted amount wasn't a number but a string, the amounts were not updated.
After the fix, the conversion rate is sent back using a integer 1

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/PaymentMethodMulticurrencyActionHandler.java
---
(0072818)
vmromanos (developer)
2014-12-24 13:32

Test Plan: follow the steps to reproduce reported with the issue
(0072819)
umartirena (developer)
2014-12-24 14:00

Code Review + Testing OK
(0073268)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-12-24 10:21 maite New Issue
2014-12-24 10:21 maite Assigned To => dmiguelez
2014-12-24 10:21 maite Modules => Advanced Payables and Receivables Mngmt
2014-12-24 10:21 maite Triggers an Emergency Pack => No
2014-12-24 10:22 maite Assigned To dmiguelez => Sandrahuguet
2014-12-24 10:22 maite Issue Monitored: networkb
2014-12-24 10:38 maite Priority urgent => immediate
2014-12-24 12:57 vmromanos Regression level => Production - Confirmed Stable
2014-12-24 12:57 vmromanos Regression date => 2014-06-11
2014-12-24 12:57 vmromanos Regression introduced in release => 3.0PR14Q3.4
2014-12-24 12:57 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/990a2a2410e9 [^]
2014-12-24 12:58 vmromanos Status new => scheduled
2014-12-24 12:58 vmromanos Assigned To Sandrahuguet => vmromanos
2014-12-24 12:58 vmromanos fix_in_branch => pi
2014-12-24 13:31 hgbot Checkin
2014-12-24 13:31 hgbot Note Added: 0072817
2014-12-24 13:31 hgbot Status scheduled => resolved
2014-12-24 13:31 hgbot Resolution open => fixed
2014-12-24 13:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/926cf5c76aaeef332d988368b2cabcafa5aabb9b [^]
2014-12-24 13:32 vmromanos Triggers an Emergency Pack No => Yes
2014-12-24 13:32 vmromanos Note Added: 0072818
2014-12-24 13:32 vmromanos fix_in_branch pi =>
2014-12-24 14:00 umartirena Review Assigned To => umartirena
2014-12-24 14:00 umartirena Note Added: 0072819
2014-12-24 14:00 umartirena Status resolved => closed
2014-12-24 14:00 umartirena Fixed in Version => pi
2014-12-30 09:57 shuehner Regression introduced in release 3.0PR14Q3.4 => 3.0PR14Q3
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073268
2015-03-24 17:41 aferraz Relationship added caused by 0029391


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker