Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028350
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2014-12-04 17:232014-12-15 00:23
ReporterjecharriView Statuspublic 
Assigned Tomalsasua 
PriorityimmediateResolutionfixedFixed in VersionRR15Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget VersionRR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomtaal
Regression levelProduction - QA Approved
Regression date
Regression introduced in releaseRR14Q3
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028350: Error when you login without incremental refresh configured

DescriptionError when you login without incremental refresh configured.

If you have an environment without incremental and full refresh configured, it can happen that second time that you login you receive an error in function newOrder because "OB.POS.modelterminal.get('terminal')" object is not properly loaded
Steps To Reproduce-Login to the environment
-Logout and login again

You will receive the error

I am going to send an email to our retail team to have a clone of the environment
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0027841 closedmarvintm terminal is loaded after that the called to method "OB.MobileApp.model.get('terminal').partnerAddress" is done 
related to defect 0028337 closedmalsasua when login is done in WEB POS and the first sales is done quickly, JS error is returned 
related to defect 0028393RR15Q3 closedmalsasua Product scree is not loaded when you login without incremental refresh configured 

-  Notes
(0072371)
malsasua (developer)
2014-12-09 18:47

fixed in changeset:

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: cd64c7f9a18d5c8803914208cf65ab00fdbf2682
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Tue Dec 09 18:45:13 2014 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/cd64c7f9a18d5c8803914208cf65ab00fdbf2682 [^] [^]

fixed issue 28337: terminal properties are not cleaned (set to null) when properties are loaded from backend in the login

previous to this commit, the properties are set to null and after that they are set to the correct value loaded from backend.
But there are some seconds that the properties are null.
Instead of set the property to null and after that set to the correct value, directly is done the set to the correct value

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0072478)
mtaal (manager)
2014-12-15 00:23

Checked and reviewed

- Issue History
Date Modified Username Field Change
2014-12-04 17:23 jecharri New Issue
2014-12-04 17:23 jecharri Assigned To => marvintm
2014-12-04 17:23 jecharri Regression level => Production - QA Approved
2014-12-04 17:23 jecharri Regression introduced in release => RR14Q3
2014-12-04 17:23 jecharri Triggers an Emergency Pack => No
2014-12-04 19:30 jecharri Relationship added duplicate of 0027841
2014-12-09 13:34 malsasua Relationship added related to 0028337
2014-12-09 18:47 malsasua Status new => scheduled
2014-12-09 18:47 malsasua Assigned To marvintm => malsasua
2014-12-09 18:47 malsasua fix_in_branch => pi
2014-12-09 18:47 malsasua Note Added: 0072371
2014-12-09 18:47 malsasua Status scheduled => resolved
2014-12-09 18:47 malsasua Fixed in Version => RR15Q1
2014-12-09 18:47 malsasua Resolution open => fixed
2014-12-10 13:15 malsasua Target Version RR15Q3 => RR15Q1
2014-12-10 13:15 malsasua fix_in_branch pi =>
2014-12-11 19:46 jecharri Issue cloned 0028393
2014-12-11 19:46 jecharri Relationship added related to 0028393
2014-12-15 00:23 mtaal Review Assigned To => mtaal
2014-12-15 00:23 mtaal Note Added: 0072478
2014-12-15 00:23 mtaal Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker