Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028214
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-11-18 17:012015-01-13 07:49
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revisioncf6e3f98cd6c
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-01-10
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c171ecac2673 [^]
Triggers an Emergency PackNo
Summary

0028214: The _selectedProperties parameter is not working on json rest webservices when not specifying a concrete record_id

DescriptionThe _selectedProperties parameter is not working on json rest webservices when not specifying a concrete record_id
Steps To ReproduceThat works:

https://livebuilds.openbravo.com/erp_pi_pgsql/org.openbravo.service.json.jsonrest/Country/100?_selectedProperties=id,name [^]


That does not work as expected:
https://livebuilds.openbravo.com/erp_pi_pgsql/org.openbravo.service.json.jsonrest/Country/?_selectedProperties=id,name [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0025461 closedalostale JSON WebServices don't support big volumes 
related to defect 0037424 closedalostale Export To Csv too slow with high volumes 

-  Notes
(0071795)
hgbot (developer)
2014-11-18 22:11

Repository: erp/devel/pi
Changeset: cf6e3f98cd6c3686895e65fca50dcb0dc03823a9
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Nov 18 22:10:10 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/cf6e3f98cd6c3686895e65fca50dcb0dc03823a9 [^]

Fixes issue 28214: _selectedProperties parameter work in JSON REST webservice

In a call to the Openbravo JSON REST webservice, the _selectedProperties parameter allows the user to specify the set of properties whose values should be returned by the webservice. This property was working properly when an ID is specified in the request, but not if it is not specified.

This stopped working because of this issue [1]. [1] implements a new method to handlle the case when the ID is not specified to improve the performance, but its missing the handling of _selectedProperties.

[1] https://code.openbravo.com/erp/devel/pi/rev/c171ecac2673 [^]

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0071888)
hgbot (developer)
2014-11-21 14:27

Repository: erp/devel/pi
Changeset: 4fb0bc73284650b33e3e02b4a49638cf6ca6d8c7
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Nov 21 14:25:25 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4fb0bc73284650b33e3e02b4a49638cf6ca6d8c7 [^]

related to bug 28214: added test case

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
A src-test/src/org/openbravo/test/webservice/JSONWebServices.java
---
(0071889)
alostale (developer)
2014-11-21 14:28

code reviewed
tested
added automated test case
(0073080)
hudsonbot (developer)
2014-12-30 23:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073123)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-18 17:01 egoitz New Issue
2014-11-18 17:01 egoitz Assigned To => AugustoMauch
2014-11-18 17:01 egoitz Modules => Core
2014-11-18 17:01 egoitz Regression level => Production - Confirmed Stable
2014-11-18 17:01 egoitz Regression introduced in release => 3.0PR14Q2
2014-11-18 17:01 egoitz Triggers an Emergency Pack => No
2014-11-18 21:53 AugustoMauch Regression date => 2014-01-10
2014-11-18 21:53 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/c171ecac2673 [^]
2014-11-18 21:54 AugustoMauch Issue Monitored: alostale
2014-11-18 21:54 AugustoMauch Review Assigned To => alostale
2014-11-18 22:11 hgbot Checkin
2014-11-18 22:11 hgbot Note Added: 0071795
2014-11-18 22:11 hgbot Status new => resolved
2014-11-18 22:11 hgbot Resolution open => fixed
2014-11-18 22:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cf6e3f98cd6c3686895e65fca50dcb0dc03823a9 [^]
2014-11-21 14:27 hgbot Checkin
2014-11-21 14:27 hgbot Note Added: 0071888
2014-11-21 14:28 alostale Note Added: 0071889
2014-11-21 14:28 alostale Status resolved => closed
2014-11-21 14:28 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:25 hudsonbot Checkin
2014-12-30 23:25 hudsonbot Note Added: 0073080
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073123
2015-01-13 07:49 alostale Relationship added caused by 0025461
2017-12-01 13:01 alostale Relationship added related to 0037424


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker