Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028197
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2014-11-18 05:522018-10-17 13:52
ReporterVictorVillarView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchpiFixed in SCM revision644c58ebe196
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028197: It is not possible to handle attributes (Lot) inserting orphan lines

DescriptionIt is not possible to handle attributes (Lot) inserting orphan lines
Steps To ReproduceAs group Admin role,
Go to Preferences window:
it is necessary to configure a preference named RM Allow Orphan Line.
Value Y.
Log out and Log in

Go to Return From Customer window,
 create a new register for Alimentos y Supermercados. Org: España Región Norte.
Click on Insert Orphan Line and select Zumo de Naranja Bio (Attribute set product definition: Lote)
  Return qty: 1
  Unit Price: 1
Click on OK.
Complete the document.

Go to Return Material Receipt,
 create a new register for Alimentos y Supermercados. Org: España Región Norte.
click on Pick&Edit Lines and select the previous line created in Return From Customer document. Select one storage bin.
Click on Done.

Try to complete the document. You can not do that because you have not defined an Attribute Set value.

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0028474 closedAtulOpenbravo API Change: Add Attribute Set Instance parameter in RM Insert Orphan Line process 
related to design defect 0039469 newTriage Finance Orphan lines do not currently support instance attributes 

-  Notes
(0072714)
AtulOpenbravo (developer)
2014-12-19 05:34

Test Plan
- Login as F&B International Group Admin Role.
- Go to Preferences window:
- Configure a preference named RM Allow Orphan Line and set Value = Y.
- Log out and Log in.

- Go to Return From Customer window.
- Create a new register for Alimentos y Supermercados. Org: España Región Norte.
- Click on Insert Orphan Line and select Zumo de Naranja Bio. (It has attribute set configuration).
- Now a field is provided to enter Attribute Set Value. Keep this field blank.
- Set Return qty: 1
- Set Unit Price: 1
- Click on OK, Error message will be displayed that Product has no attribute set.
- Again Click on Insert Orphan Line and select Zumo de Naranja Bio.
- Set Attribute Set Value. Do not keep it blank
- Set Return qty: 1
- Set Unit Price: 1
- Click on OK. Line is successfully inserted.
- Again Click on Insert Orphan Line and select product which as no attribute set configuration.
- Set Attribute Set Value as blank.
- Set Return Qty : 1
- Set Unit Price : 1
- Click on Ok. Line is successfully inserted.

- Go to Return Material Receipt.
- Create a new register for Alimentos y Supermercados. Org: España Región Norte.
- Click on Pick&Edit Lines and select the previous lines created in Return From Customer document. Select storage bin. Click on Done.

- Complete the document. You can do that because you have defined an Attribute Set value for the product which has attribute set configured.
(0073305)
hgbot (developer)
2015-01-05 15:55

Repository: erp/devel/pi
Changeset: 644c58ebe196b20699b9d23de708fe7eef375a63
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed Dec 31 19:14:19 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/644c58ebe196b20699b9d23de708fe7eef375a63 [^]

Fixes Issue 28197:RM Insert Orphan Line provides a field to provide attribute
set instance details for product if applicable.

New parameter is optional and process does not change if parameter is passed
in or not so API checks failure is false positive.

---
M src-db/database/sourcedata/AD_PROCESS_PARA.xml
M src/org/openbravo/erpCommon/ad_actionButton/RMInsertOrphanLine.java
---
(0073307)
Sandrahuguet (developer)
2015-01-05 16:02

Code review + testing OK
(0074105)
hudsonbot (developer)
2015-02-04 20:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-18 05:52 VictorVillar New Issue
2014-11-18 05:52 VictorVillar Assigned To => dmiguelez
2014-11-18 05:52 VictorVillar Modules => Core
2014-11-18 05:52 VictorVillar Triggers an Emergency Pack => No
2014-11-18 05:52 VictorVillar Issue Monitored: networkb
2014-11-24 07:27 VictorVillar Priority urgent => immediate
2014-12-01 15:54 egoitz Target Version 3.0PR15Q1 => 3.0PR15Q2
2014-12-15 13:47 VictorVillar Assigned To dmiguelez => AtulOpenbravo
2014-12-18 14:33 AtulOpenbravo Status new => scheduled
2014-12-18 14:33 AtulOpenbravo fix_in_branch => pi
2014-12-19 05:34 AtulOpenbravo Note Added: 0072714
2014-12-23 13:08 AtulOpenbravo Relationship added depends on 0028474
2015-01-05 15:55 hgbot Checkin
2015-01-05 15:55 hgbot Note Added: 0073305
2015-01-05 15:55 hgbot Status scheduled => resolved
2015-01-05 15:55 hgbot Resolution open => fixed
2015-01-05 15:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/644c58ebe196b20699b9d23de708fe7eef375a63 [^]
2015-01-05 16:02 Sandrahuguet Review Assigned To => Sandrahuguet
2015-01-05 16:03 Sandrahuguet Note Added: 0073307
2015-01-05 16:03 Sandrahuguet Status resolved => closed
2015-01-05 16:03 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-04 20:33 hudsonbot Checkin
2015-02-04 20:33 hudsonbot Note Added: 0074105
2018-10-17 13:38 ngarcia Relationship added related to 0039468
2018-10-17 13:51 ngarcia Relationship added related to 0039469
2018-10-17 13:52 ngarcia Relationship deleted related to 0039468


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker