Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028162
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2014-11-12 17:142016-04-08 11:00
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisiona3ff8b12624d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Topramakrishnan
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-02-20
Regression introduced in release3.0PR14Q2
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/0b033ca5bd1b08e81a30cfdbab2b459549d8c17c [^]
Triggers an Emergency PackNo
Summary

0028162: Cannot modify the reservation of a sales order line if it is partially reserved and released

DescriptionCannot modify the reservation of a sales order line if it is partially reserved and released
Steps To ReproduceAs group admin role:
   Add the Enable Stock Reservations preference
   Create a new product and add a sales price to it
   Create a Goods Receipt of 4 units of the product and complete it
   Create a Sales Order of 10 units of the product and book it
   Reserve the 4 units for that order
   Create a Goods Shipment from that order (4 units) and complete it
   Create a Goods Receipt of 6 units of the product and complete it
   Try to change the reserved quantity to the sales order line
   The following error message is shown:
      CannotDeleteReleasedReservation
   
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0023412 closedSandrahuguet Manage Stock Pick and Execute Window does not work with large amount of data 

-  Notes
(0071643)
AtulOpenbravo (developer)
2014-11-13 22:08

Test Plan
- Add the Enable Stock Reservations preference
- Create a new product and add a sales price to it.
- Create a Goods Receipt of 4 units of the product and complete it.
- Create a Sales Order of 10 units of the product and book it.
- Using manage reservation, reserve 4 units for that order.
- Create a Goods Shipment from that order (4 units) and complete it
- Create a Goods Receipt of 6 units of the product and complete it
- Using manage reservation, change the reserved quantity for the sales order line. It changes successfully.
(0071651)
hgbot (developer)
2014-11-14 10:59

Repository: erp/devel/pi
Changeset: a3ff8b12624d35c67e769aa1ba9056cf456941e9
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Fri Nov 14 15:28:11 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/a3ff8b12624d35c67e769aa1ba9056cf456941e9 [^]

Fixes Issue 28162:Cannot modify the reservation of a sales order line if it
is partially reserved and released

Before removing reservation stock line check is provided to check whether
released qty is zero or not.

---
M src/org/openbravo/common/actionhandler/ManageReservationActionHandler.java
---
(0071653)
AtulOpenbravo (developer)
2014-11-14 11:23

Reopen to fill up regression details
(0071654)
pramakrishnan (developer)
2014-11-14 11:31

Code Review + Testing - OK.
(0073057)
hudsonbot (developer)
2014-12-30 23:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0084444)
aferraz (developer)
2016-02-23 18:22

Test case added in testlink:
https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10000 [^]
(0085521)
hgbot (developer)
2016-04-08 11:00

Repository: tools/automation/int
Changeset: 4267b9c3da920d229a157170b7d7f1ee7f3d0518
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Feb 23 22:34:57 2016 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/4267b9c3da920d229a157170b7d7f1ee7f3d0518 [^]

Related to issue 28162: Add an automated test

---
M src-test/com/openbravo/test/integration/erp/gui/sales/transactions/salesorder/LinesTab.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/pickandexecute/PickAndExecuteWindow.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RES_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/sales/transactions/SalesOrder.java
A src-test/com/openbravo/test/integration/erp/data/sales/transactions/salesorder/ManageReservationData.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RESRegression28162.java
---

- Issue History
Date Modified Username Field Change
2014-11-12 17:14 ngarcia New Issue
2014-11-12 17:14 ngarcia Assigned To => dmiguelez
2014-11-12 17:14 ngarcia Modules => Core
2014-11-12 17:14 ngarcia Triggers an Emergency Pack => No
2014-11-12 17:14 ngarcia Assigned To dmiguelez => AtulOpenbravo
2014-11-12 17:21 ngarcia Regression level => Production - Confirmed Stable
2014-11-12 17:22 ngarcia Issue Monitored: networkb
2014-11-12 18:45 heccam Issue Monitored: heccam
2014-11-13 09:32 AtulOpenbravo Status new => scheduled
2014-11-13 09:32 AtulOpenbravo fix_in_branch => pi
2014-11-13 22:08 AtulOpenbravo Note Added: 0071643
2014-11-14 10:59 AtulOpenbravo Review Assigned To => pramakrishnan
2014-11-14 10:59 AtulOpenbravo fix_in_branch pi =>
2014-11-14 10:59 hgbot Checkin
2014-11-14 10:59 hgbot Note Added: 0071651
2014-11-14 10:59 hgbot Status scheduled => resolved
2014-11-14 10:59 hgbot Resolution open => fixed
2014-11-14 10:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a3ff8b12624d35c67e769aa1ba9056cf456941e9 [^]
2014-11-14 11:23 AtulOpenbravo Note Added: 0071653
2014-11-14 11:23 AtulOpenbravo Status resolved => new
2014-11-14 11:23 AtulOpenbravo Resolution fixed => open
2014-11-14 11:25 AtulOpenbravo Regression date => 2014-02-20
2014-11-14 11:25 AtulOpenbravo Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/0b033ca5bd1b08e81a30cfdbab2b459549d8c17c [^]
2014-11-14 11:25 AtulOpenbravo Status new => scheduled
2014-11-14 11:26 AtulOpenbravo Regression introduced in release => 3.0PR14Q2
2014-11-14 11:27 AtulOpenbravo Status scheduled => resolved
2014-11-14 11:27 AtulOpenbravo Fixed in Version => pi
2014-11-14 11:27 AtulOpenbravo Resolution open => fixed
2014-11-14 11:31 pramakrishnan Note Added: 0071654
2014-11-14 11:31 pramakrishnan Status resolved => closed
2014-11-14 12:56 ngarcia Relationship added caused by 0023412
2014-12-30 23:24 hudsonbot Checkin
2014-12-30 23:24 hudsonbot Note Added: 0073057
2016-02-23 18:22 aferraz Note Added: 0084444
2016-04-08 11:00 hgbot Checkin
2016-04-08 11:00 hgbot Note Added: 0085521


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker