Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028124
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-11-07 14:052014-12-30 23:26
ReportercaristuView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision6c40462ac6e5
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028124: The CSV Decimal Separator preference is not taken into account in Query/List widgets

DescriptionThe CSV Decimal Separator preference is not taken into account when exporting into CSV a Query/List widgets
Steps To Reproduce1) Configure the CSV Decimal Separator to use the comma (,) as decimal separator
2) Go to any Query/List widget in the workspace
3) Export the grid into csv. Notice that the amounts are using always the dot (.) as decimal separator
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0071869)
hgbot (developer)
2014-11-21 09:18

Repository: erp/devel/pi
Changeset: 6c40462ac6e5c980915b64bdd688be9183df87d4
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Nov 19 16:35:42 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6c40462ac6e5c980915b64bdd688be9183df87d4 [^]

Fixed issue 28124: The separator preference is not taken in CSV export.

When a csv was exported from a widget, the decimal separator preferences were not taken.
The problem was in "DataSourceServlet.java" class.
I've added a condition. Now when the CSV decimal separator preference is defined, uses it
insead of using the one defined in "Format.xml".

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/DataSourceServlet.java
---
(0071870)
alostale (developer)
2014-11-21 09:18

code reviewed

tested in widgets and standard grid
(0073119)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-07 14:05 caristu New Issue
2014-11-07 14:05 caristu Assigned To => AugustoMauch
2014-11-07 14:05 caristu Modules => Core
2014-11-07 14:05 caristu Triggers an Emergency Pack => No
2014-11-07 14:05 caristu Issue Monitored: networkb
2014-11-07 15:39 eugeni Issue Monitored: eugeni
2014-11-17 17:43 alostale Assigned To AugustoMauch => NaroaIriarte
2014-11-19 16:42 NaroaIriarte Review Assigned To => alostale
2014-11-21 09:18 hgbot Checkin
2014-11-21 09:18 hgbot Note Added: 0071869
2014-11-21 09:18 hgbot Status new => resolved
2014-11-21 09:18 hgbot Resolution open => fixed
2014-11-21 09:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6c40462ac6e5c980915b64bdd688be9183df87d4 [^]
2014-11-21 09:18 alostale Note Added: 0071870
2014-11-21 09:18 alostale Status resolved => closed
2014-11-21 09:18 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073119


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker