Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028085
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-11-04 21:172014-12-30 23:24
ReporteregoitzView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revisione735bef86355
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-01-07
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/46ec5ec2839da79ae27a5225c105c85ecde1cf6a [^]
Triggers an Emergency PackNo
Summary

0028085: On the organization window is not possible to use the organization type filter

DescriptionOn the organization window is not possible to use the organization type filter.
When you try to select an option on the filter you don't get any value.
A error is raised (see attachment)
Steps To Reproduce-Login and access on the organization window
-On grid view try to select a value on the organization type column to be used as filter.
*no options are shown
*check the openbravo.log at tomcat.
TagsNo tags attached.
Attached Fileslog file icon openbravo.log [^] (16,869 bytes) 2014-11-04 21:17

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00251823.0PR14Q2 closedalostale Query in org drop down in the list field is having bad performance 

-  Notes
(0071411)
AugustoMauch (developer)
2014-11-04 22:03

Changed to minor because even though it is not possible to filter that column using the filter drop down, it is possible to filter it by entering a string in the filter editor
(0071428)
hgbot (developer)
2014-11-05 13:50

Repository: erp/devel/pi
Changeset: e735bef863555ae90a0a52d569274901bebd72f4
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Nov 05 13:43:25 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e735bef863555ae90a0a52d569274901bebd72f4 [^]

fixed bug 28085: FK drop down filters don't work on Organization/Client windows

  The problem was due the generated query, it applied client/organization security
  assuming organization and client were in another entities.

  The fix cheks these special cases to do the security query based on that base
  entities.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0071429)
hgbot (developer)
2014-11-05 13:50

Repository: erp/devel/pi
Changeset: b112216b499bab95f13399e80facd94b277e367e
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Nov 05 13:49:09 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b112216b499bab95f13399e80facd94b277e367e [^]

related to bug 28085: added test case

  test case covering FK drop down datasource in Organization table

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
A src-test/src/org/openbravo/test/datasource/FKDropDownDatasource.java
---
(0071472)
AugustoMauch (developer)
2014-11-06 18:40

Code reviewed and verified in pi@e735bef86355
(0073018)
hudsonbot (developer)
2014-12-30 23:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073019)
hudsonbot (developer)
2014-12-30 23:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-04 21:17 egoitz New Issue
2014-11-04 21:17 egoitz Assigned To => AugustoMauch
2014-11-04 21:17 egoitz File Added: openbravo.log
2014-11-04 21:17 egoitz Modules => Core
2014-11-04 21:17 egoitz Regression level => Production - Confirmed Stable
2014-11-04 21:17 egoitz Regression introduced in release => 3.0PR14Q2.6
2014-11-04 21:17 egoitz Triggers an Emergency Pack => No
2014-11-04 22:03 AugustoMauch Note Added: 0071411
2014-11-04 22:03 AugustoMauch Severity major => minor
2014-11-05 10:15 alostale Relationship added caused by 0025182
2014-11-05 10:16 alostale Regression date => 2014-01-07
2014-11-05 10:16 alostale Regression introduced in release 3.0PR14Q2.6 => 3.0PR14Q2
2014-11-05 10:16 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/46ec5ec2839da79ae27a5225c105c85ecde1cf6a [^]
2014-11-05 13:40 alostale Review Assigned To => AugustoMauch
2014-11-05 13:40 alostale Assigned To AugustoMauch => alostale
2014-11-05 13:50 hgbot Checkin
2014-11-05 13:50 hgbot Note Added: 0071428
2014-11-05 13:50 hgbot Status new => resolved
2014-11-05 13:50 hgbot Resolution open => fixed
2014-11-05 13:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e735bef863555ae90a0a52d569274901bebd72f4 [^]
2014-11-05 13:50 hgbot Checkin
2014-11-05 13:50 hgbot Note Added: 0071429
2014-11-06 18:40 AugustoMauch Note Added: 0071472
2014-11-06 18:40 AugustoMauch Status resolved => closed
2014-11-06 18:40 AugustoMauch Fixed in Version => 3.0PR15Q1
2014-12-30 23:24 hudsonbot Checkin
2014-12-30 23:24 hudsonbot Note Added: 0073018
2014-12-30 23:24 hudsonbot Checkin
2014-12-30 23:24 hudsonbot Note Added: 0073019


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker