Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028045
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-10-31 15:592014-12-30 23:24
ReporterjecharriView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision39eafa25db30
ProjectionnoneETAnoneTarget Version3.0PR14Q3.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-06-02
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/5c5013dbfa41371101dfc00dc74a209fd7bd662c [^]
Triggers an Emergency PackYes
Summary

0028045: Selectors are not filtering properly when the popup is open

DescriptionSelectors are not filtering properly when the popup is open. The problem is that they are filtering starts with instead of contains
Steps To Reproduce-Go to live instance
-Create a "sales order" header
-Go to lines
-Create a record and go to product field
-Write "bida" -> selector will propose "Bebida Energética 0,5L"
-Press in magnifying glass and open the popup
-Write in the name "bida" -> verify that you don't receive any result
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0026748 closedAugustoMauch The Popup Text Match Style on the definition of the selector is not properly used 

-  Notes
(0071348)
alostale (developer)
2014-11-03 12:09

The selector is behaving as it is defined: pop up search style is "starts With".

The regression was introduced by 0026748, which made selectors to take into account this setting which was removed by 0018470.

This caused a behavioral change in Q3. Current fix sets back to "contains" all the selectors in Openbravo ERP + Retail in order to make them to behave as they did previously.

List of affected selectors:

Openbravo ERP
=============

Reservation
Invoice Line Selector
Product UOM Selector
Product
Invoice Selector
Product
StorageBin Selector without warehouse
Process Run
Tab Access Selector
Portal Role Selector
Business Partner not filtered by default by customer/vendor
Orderline selector
Product Complete
Table Tree Category
Payment Selector
Element Selector
Storage Bin Selector
Process Plan Version
Business Partner with contact and location
Physical Inventory line selector
Process Request
Project
Product Multiple
Transaction
Reservation Stock Selector
Region Selector
Product
Reservation Selector
Payment Schedule
MRP_ProductionRunLineSelector
Asset Selector
Business Partner with contact and location
Currency
Receipts
ProductSimple
Organization Selector not *
Currency Selector
Financial Account
Transactions link
Financial Account Selector
GL Item selector
Business Partner
Organization
Payment Method Selector
Payment Method
Payment Selector Transaction for Parameter Window
Doctype Selector
Activity selector
Campaign selector
Sales region selector
Project Selector
Product selector
APRM_ActionDocumentSelector
Multi Business Partner Selector
Selector Field Property Selector
Model Selector


Retail
======

Sale Product Complete
Customer with Price List
Store Organization
Product
(0071349)
hgbot (developer)
2014-11-03 12:54

Repository: erp/devel/pi
Changeset: 39eafa25db30fc6c46ae16319dfd8a2f0c92d876
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Nov 03 12:37:29 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/39eafa25db30fc6c46ae16319dfd8a2f0c92d876 [^]

fixed bug 28045: pop up in selectors filter by starts with instead of contains

  Setting all selectors in ERP to filter by contains instead of starts with in order
  to preserve the same behavior as in Q2, when this setting was not taken into account
  list of affected selectors:

        Reservation
        Invoice Line Selector
        Product UOM Selector
        Product
        Invoice Selector
        Product
        StorageBin Selector without warehouse
        Process Run
        Tab Access Selector
        Portal Role Selector
        Business Partner not filtered by default by customer/vendor
        Orderline selector
        Product Complete
        Table Tree Category
        Payment Selector
        Element Selector
        Storage Bin Selector
        Process Plan Version
        Business Partner with contact and location
        Physical Inventory line selector
        Process Request
        Project
        Product Multiple
        Transaction
        Reservation Stock Selector
        Region Selector
        Product
        Reservation Selector
        Payment Schedule
        MRP_ProductionRunLineSelector
        Asset Selector
        Business Partner with contact and location
        Currency
        Receipts
        ProductSimple
        Organization Selector not *
        Currency Selector
        Financial Account
        Transactions link
        Financial Account Selector
        GL Item selector
        Business Partner
        Organization
        Payment Method Selector
        Payment Method
        Payment Selector Transaction for Parameter Window
        Doctype Selector
        Activity selector
        Campaign selector
        Sales region selector
        Project Selector
        Product selector
        APRM_ActionDocumentSelector
        Multi Business Partner Selector
        Selector Field Property Selector
        Model Selector

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M modules/org.openbravo.userinterface.selector/src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0071350)
hgbot (developer)
2014-11-03 12:57

Repository: erp/pmods/org.openbravo.retail.config
Changeset: c886b96105fcd471de2e2a2e55adecfbd4d50f95
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Nov 03 12:53:24 2014 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.config/rev/c886b96105fcd471de2e2a2e55adecfbd4d50f95 [^]

related to bug 28045: pop up in selectors filters by starts

  Setting all selectors in ERP to filter by contains instead of starts with in order
  to preserve the same behavior as in Q2, when this setting was not taken into account
  list of affected selectors:

        Sale Product Complete
        Customer with Price List
        Store Organization
        Product

---
M src-db/database/sourcedata/AD_MENU.xml
M src-db/database/sourcedata/AD_TAB.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0071375)
AugustoMauch (developer)
2014-11-03 17:09

Code reviewed and verified in pi@39eafa25db30
(0073010)
hudsonbot (developer)
2014-12-30 23:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-31 15:59 jecharri New Issue
2014-10-31 15:59 jecharri Assigned To => AugustoMauch
2014-10-31 15:59 jecharri Web browser => Google Chrome
2014-10-31 15:59 jecharri Modules => Core
2014-10-31 15:59 jecharri Triggers an Emergency Pack => No
2014-10-31 16:00 jecharri Web browser Google Chrome => Google Chrome
2014-10-31 16:00 jecharri Regression level => Production - QA Approved
2014-10-31 16:00 jecharri Regression introduced in release => 3.0PR14Q3
2014-10-31 16:00 jecharri Triggers an Emergency Pack No => Yes
2014-10-31 16:46 johnfandl Issue Monitored: johnfandl
2014-11-03 10:31 alostale Relationship added caused by 0026748
2014-11-03 10:32 alostale Web browser Google Chrome => Google Chrome
2014-11-03 10:32 alostale Regression date => 2014-06-02
2014-11-03 10:32 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/5c5013dbfa41371101dfc00dc74a209fd7bd662c [^]
2014-11-03 11:12 alostale Assigned To AugustoMauch => alostale
2014-11-03 11:12 alostale Review Assigned To => AugustoMauch
2014-11-03 11:12 alostale Web browser Google Chrome => Google Chrome
2014-11-03 12:09 alostale Note Added: 0071348
2014-11-03 12:54 hgbot Checkin
2014-11-03 12:54 hgbot Note Added: 0071349
2014-11-03 12:54 hgbot Status new => resolved
2014-11-03 12:54 hgbot Resolution open => fixed
2014-11-03 12:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/39eafa25db30fc6c46ae16319dfd8a2f0c92d876 [^]
2014-11-03 12:57 hgbot Checkin
2014-11-03 12:57 hgbot Note Added: 0071350
2014-11-03 17:09 AugustoMauch Note Added: 0071375
2014-11-03 17:09 AugustoMauch Status resolved => closed
2014-11-03 17:09 AugustoMauch Fixed in Version => 3.0PR15Q1
2014-12-30 23:24 hudsonbot Checkin
2014-12-30 23:24 hudsonbot Note Added: 0073010


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker