Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027954
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Approval process - onlinemajoralways2014-10-23 07:212014-12-09 16:47
ReportersureshbabuView Statuspublic 
Assigned Tomario_castello 
PriorityhighResolutionfixedFixed in VersionRR15Q1
StatusclosedFix in branchpiFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - QA Approved
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027954: [RR14Q4]Approval required while deleting receipts during logout, wrong behavior when i enter invalid password

DescriptionWhile testing the scenario approval required while deleting receipts during logout, when i enter invalid password still system wrongly removes receipt and also wrongly logout of the system
Steps To ReproducePre-condition:

 Login to ERP system using below user credentials:

    "Username": Openbravo
    "Password": openbravo

Then change the role to “The White Valley Group Admin” role

Navigate to “Preference” window

Click Ctrl + D to add new record

Then enter the below details

    “Client”: The White Valley Group
    "Organization": Vall Blanca Store
    “Property List”: Checked
    “Property”: Web Pos Remove Receipts Approval
    “Value”:Y

Then In Visibility section, enter the below details

    “Visible at Client”: The White Valley Group
    "Visible at Organization": Vall Blanca Store
    “Visible at User”: Openbravo

Click Ctrl + S to save the changes

Then change the role to “System Administrator” role

Navigate to “Preference” window

Verify record is present for property “Web POS Remove Receipts Approval”

If the record is found, set the field "value" to

    “Value”:N

If the record is not found, then click Ctrl + D to add new record

Then enter the below details

    “Client”: System
    "Organization": *
    “Property List”: Checked
    “Property”: Web Pos Remove Receipts Approval
    “Value”:N

Then In Visibility section, enter the below details

    “Visible at Client”: <Blank>
    "Visible at Organization": <Blank>
    “Visible at User”: <Blank>

Click Ctrl + s to save the changes.

Steps:

  Login to POS terminal, go to the login URL: http://{server}/{context}/web/org.openbravo.retail.posterminal/?Test1 [^]

Enter login credentials:

    "Username": vallblanca
    "Password": openbravo

The POS window will appear.

Add product

    Product: Alpine skiing backpack 27 L; Quantity: 1 no
    Product: Adhesive Body warmers; Quantity: 1 no

And verify the below details

    Product: Alpine skiing backpack 27 L
    Qty: 1
    Price: 109.90
    Product: Adhesive body warmers
    Qty: 1
    Price: 3.60
    Total Gross Amount: 113.50

Tax Breakdown

    Tax percentage: Entregas IVA 21%
    Taxable Amount: 93.81
    Total Tax amount: 19.69

Then to logout from web POS click “Drop down” menu and select “Online” option

Verify below options appear in the “Online” popup

    Lock Screen
    End Session

To logout, click “End Session” option and verify

    “Approval Required” popup appears, along with “Openbravo” user appears in approval list

Enter as

    User id: “Openbravo”
    Password: Invalid password

Then click “Approve” button


Expected behavior: System should show warning message and remains in webpos screen (should not remove receipts and system should not logout).

Actual behavior: Once the user enters wrong password, and press approve button ... "Invalid username and password" error message appears but system wrongly logout.

Note: refer the screen shot for the error message.

TagsNo tags attached.
Attached Filespng file icon While testing the scenario approval required while deleting receipts during logout, when i enter invalid password still system wrongly removes receipt and also logout of the system.png [^] (129,856 bytes) 2014-10-23 07:21

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028278 closedmarvintm variable isLoggingIn never is set to false, then, during the login, some messages are not displayed and they should be displayed 
has duplicate defect 0028269 closedmario_castello System logs out if the password is entered wrong on an approval window 
related to defect 0027964 feedbackmalsasua [RR14Q4] System behaves wrongly, when the user enter inavlid password and press enter key in Password field 

-  Notes
(0072029)
plujan (manager)
2014-11-26 13:26

Please refer to the Testlink test case http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-7599 [^] and related test cases to get a broader look on the possible scenarios.
(0072174)
malsasua (developer)
2014-12-01 10:16
edited on: 2014-12-01 10:35

it is fixed by the changeset of issue 28278:
https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a2f8315bc9d86f4017c80c00a6595799ad521502 [^]

The problem was generated because the var isLoggingIn never was set to false, then in this line [1] the "if" is true and logout is done

[1] https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/file/6ea902cef0df/web/org.openbravo.mobile.core/source/data/ob-datasource.js#l76 [^]


- Issue History
Date Modified Username Field Change
2014-10-23 07:21 sureshbabu New Issue
2014-10-23 07:21 sureshbabu Assigned To => marvintm
2014-10-23 07:21 sureshbabu File Added: While testing the scenario approval required while deleting receipts during logout, when i enter invalid password still system wrongly removes receipt and also logout of the system.png
2014-10-23 07:21 sureshbabu Triggers an Emergency Pack => No
2014-11-20 18:12 malsasua Assigned To marvintm => mario_castello
2014-11-26 13:26 plujan Note Added: 0072029
2014-11-26 17:32 egoitz Relationship added related to 0028269
2014-11-28 01:09 mtaal Regression level => Production - QA Approved
2014-11-28 01:10 mtaal Relationship replaced has duplicate 0028269
2014-12-01 10:03 malsasua Relationship added related to 0028278
2014-12-01 10:15 malsasua Status new => scheduled
2014-12-01 10:15 malsasua fix_in_branch => pi
2014-12-01 10:16 malsasua Note Added: 0072174
2014-12-01 10:16 malsasua Status scheduled => resolved
2014-12-01 10:16 malsasua Fixed in Version => RR15Q1
2014-12-01 10:16 malsasua Resolution open => fixed
2014-12-01 10:35 malsasua Note Edited: 0072174 View Revisions
2014-12-09 16:47 marvintm Review Assigned To => marvintm
2014-12-09 16:47 marvintm Status resolved => closed
2014-12-15 17:56 malsasua Relationship added related to 0027964


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker