Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027882
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialhave not tried2014-10-16 09:002014-12-30 23:26
ReporteralostaleView Statuspublic 
Assigned ToNaroaIriarte 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision2c4a045dc11d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027882: Invalid request from "Welcome to Openbravo 3" widget

DescriptionIn activated production instances, "Welcome to Openbravo 3" widget does an invalid request to show purpose banner.
Steps To Reproduce-Activate an instance setting it as Production
-Log in the application
-Check the Welcome to Openbravo 3 widget in workspace:
  * It does not show a banner with instance purpose (it does for other purposes, see attached image)
  * Looking at the requests you can see a GET to /utility/ShowImageLogo?logo=banner-production -> 404 (not found)
Proposed Solution* Fix relative url (it should be one level less deep)
* Check with other purposes to ensure all of them are ok
TagsNo tags attached.
Attached Filespng file icon Selection_123.png [^] (28,458 bytes) 2014-10-16 09:01

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0071917)
hgbot (developer)
2014-11-24 09:42

Repository: erp/devel/pi
Changeset: 2c4a045dc11d500859c99f23d75126d1627d9720
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Fri Nov 21 10:53:05 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2c4a045dc11d500859c99f23d75126d1627d9720 [^]

Fixed issue 27882:Image in "Welcome to Openbravo3" widget is not shown.

When the Production instance is chosen you cannot see the "Production Banner Image" in the "Welcome to Openbravo 3" widget.
The problem was that the relative URL to get that image was wrong. The issue has been fixed by changing it in the ob-widget-styles.css.
The URL has been changed making it less deeper, from six levels to two levels deep.
This has been fixed as this way, instead of changing the URL as the other instance types url(images/purpose/banner-<instance type>.png), because in this way, the system administrator can
change the "Production Banner Image" himself.

---
M modules/org.openbravo.client.myob/web/org.openbravo.userinterface.smartclient/openbravo/skins/Default/org.openbravo.client.myob/ob-widget-styles.css
---
(0071920)
alostale (developer)
2014-11-24 09:45

code reviewed.

Tested:
-With "Production" instance purpose:
  -If there is no "Production Banner" image in System Info, a valid request is sent responding a blank image.
  -If there is "Production Banner" image in System Info, a valid request is sent responding that image.
-Other purposes show the correct current banners
(0073125)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-16 09:00 alostale New Issue
2014-10-16 09:00 alostale Assigned To => inigosanchez
2014-10-16 09:00 alostale Modules => Core
2014-10-16 09:00 alostale Triggers an Emergency Pack => No
2014-10-16 09:01 alostale File Added: Selection_123.png
2014-10-16 11:48 shuehner Issue Monitored: shuehner
2014-11-10 10:52 alostale Assigned To inigosanchez => NaroaIriarte
2014-11-18 15:01 NaroaIriarte Review Assigned To => alostale
2014-11-24 09:42 hgbot Checkin
2014-11-24 09:42 hgbot Note Added: 0071917
2014-11-24 09:42 hgbot Status new => resolved
2014-11-24 09:42 hgbot Resolution open => fixed
2014-11-24 09:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2c4a045dc11d500859c99f23d75126d1627d9720 [^]
2014-11-24 09:45 alostale Note Added: 0071920
2014-11-24 09:45 alostale Status resolved => closed
2014-11-24 09:45 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073125


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker