Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027869
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-10-15 09:162014-12-30 23:23
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revisionae40e9ae8736
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027869: Right click shows the wrong context menu having an external link menu opened

DescriptionThe browser's context menu is shown instead of the application context menu when we do a right click on any window having an external link menu opened at the same time.
Steps To ReproduceAs system administrator
1) Create a new menu entry:
   - Action: External link
   - Set a link: www.openbravo.com
As group admin role
2) Open the [Sales Order] window. Right-click on the header grid. The application context menu is opened.
3) Open the menu entry created in step 1). Leave it opened.
4) Go back to the [Sales Order] window. Right-click on the header grid. The browser menu context is shown instead (See attached)
5) Close the external link menu entry
6) Go back to the [Sales Order] window. Right-click on the header grid. Now the application context menu is shown correctly again.
TagsNo tags attached.
Attached Filesjpg file icon browserMenu.jpg [^] (76,458 bytes) 2014-10-15 09:16

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00279593.0PR15Q1 closedalostale Right click shows the wrong context menu under some circumstances using Google Chrome 

-  Notes
(0071010)
alostale (developer)
2014-10-17 08:27
edited on: 2014-10-17 08:52

Reproducible in linux in Chrome 38, not in Firefox 32

Can be reproduced if link is opened as a tab in workspace but not as a new browser tab

It occurs in the tabs opened previously to the external link while it is still open, tabs opened after external link work correctly.

(0071035)
hgbot (developer)
2014-10-17 14:29

Repository: erp/devel/pi
Changeset: ae40e9ae87364c6da49771aff451abcd4521d7ab
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Oct 17 14:19:51 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ae40e9ae87364c6da49771aff451abcd4521d7ab [^]

fixed bug 27869: wrong context menu having an external link menu opened in tab

  The issue is only reproducible in Chrome, even the external link tab is hidden
  because antoher tab is seen, click mouse event is sent to external link tab.

  Fix forces external link tab z-index to be 1 (instead of being managed by SC)
  so it is in the bottom not interfering with other tabs

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-external-page.js
---
(0071036)
alostale (developer)
2014-10-17 14:40

tested in Chrome 38, FF 32 and IE7
(0071163)
AugustoMauch (developer)
2014-10-24 10:59

Code reviewed and verified in pi@5bce36f9c047
(0072948)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-15 09:16 caristu New Issue
2014-10-15 09:16 caristu Assigned To => AugustoMauch
2014-10-15 09:16 caristu File Added: browserMenu.jpg
2014-10-15 09:16 caristu Modules => Core
2014-10-15 09:16 caristu Triggers an Emergency Pack => No
2014-10-15 09:16 caristu Issue Monitored: networkb
2014-10-15 09:27 caristu Summary Right click shows the wrong context menu when opening an external link menu => Right click shows the wrong context menu having an external link menu opened
2014-10-15 09:29 caristu Steps to Reproduce Updated View Revisions
2014-10-17 08:27 alostale Web browser => Google Chrome
2014-10-17 08:27 alostale Note Added: 0071010
2014-10-17 08:27 alostale Severity major => minor
2014-10-17 08:52 alostale Note Edited: 0071010 View Revisions
2014-10-17 09:07 jonalegriaesarte Web browser Google Chrome => Google Chrome
2014-10-17 14:00 alostale Assigned To AugustoMauch => alostale
2014-10-17 14:28 alostale Review Assigned To => AugustoMauch
2014-10-17 14:28 alostale Web browser Google Chrome => Google Chrome
2014-10-17 14:29 hgbot Checkin
2014-10-17 14:29 hgbot Note Added: 0071035
2014-10-17 14:29 hgbot Status new => resolved
2014-10-17 14:29 hgbot Resolution open => fixed
2014-10-17 14:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ae40e9ae87364c6da49771aff451abcd4521d7ab [^]
2014-10-17 14:40 alostale Note Added: 0071036
2014-10-23 12:23 caristu Relationship added related to 0027959
2014-10-24 10:59 AugustoMauch Note Added: 0071163
2014-10-24 10:59 AugustoMauch Status resolved => closed
2014-10-24 10:59 AugustoMauch Fixed in Version => 3.0PR15Q1
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072948


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker