Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027853
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2014-10-13 15:142014-12-30 23:23
ReporterpsanjuanView Statuspublic 
Assigned Toumartirena 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisioneb511c7f7b05
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027853: Manual Cost Correction Cost adjustments are not properly created.

Description"Manual Cost Correction" Cost adjustments are not properly created.
Steps To ReproduceCreate a new product named "Costing H1" in QA Testing client, Spain org.
Go to Price tab and enter a unit/list price of 105

Go to purchase order and create a new one dated on 28/10/2014 for 100 unit. Book the order.

Create a new order dated on 29/10/2014 for 100 unit, this time change the price to 105.50. Book the order.

Go to goods receipt window and create a new one dated on 30/10/2014. Create lines from two orders which means to receipt 200 units of the product. Complete the receipt. Navigate to Process Request window and launch costing background process.

Go back to goods receipt and post the receipt dated on 30/10/2014. Posting will show a value of 21050.

Go to product window, search the product and go to costing tab. Realize that there are two lines:
line 1 showing a cost of 105 and a total movement qty of 100
line 2 showing a cost of 105.25 (10500+10550/200) and a total movement qty of 200

Go to purchase invoice, create a new one dated on 1/11/2014. Create lines from the receipt. Complete and Post the invoice.

Go to Goods shipment window and create a new one for the product dated on 10/11/2014. Ship 150 units.

Navigate to Process Request window and launch costing background process.

Go back to goods shipment window and post shipment dated on 10/11/2014.. Posting will show a value of 15787.50

Go to product window, search the product and navigate to transactions tab. Search receipt dated on 30/10/2014 and valued at 10550 and press the button "Manual Cost Adjustment". Enter a total cost of 10600 and a date of 02/11/2014. Press OK.

Realize that total cost and unit cost of this transaction has changed to 10600.

Go to costing tab and realize that there is new cost of 105.33, but this is not correct as it should be: 10500+10600/200 = 105.50

Go to Cost Adjustment window and realize that a new "Manual Cost Correction" cost adjustment has been created, including below two lines:

line 1 adjust receipt dated on 29/10/2014. Adjustment amount is 50 (10600-10550), this is correct.

line 2 adjust shipment dated on 10/11/2014. Adjustment amount is 12. This is not correct as it should be 37.50 (150 units *105.50 new cost -15787.50)

Proposed SolutionGo to costing tab and realize that there is new cost of 105.33, but this is not correct as it should be: 10500+10600/200 = 105.50

Go to Cost Adjustment window and realize that a new "Manual Cost Correction" cost adjustment has been created, including below two lines:

line 1 adjust receipt dated on 29/10/2014. Adjustment amount is 50 (10600-10550), this is correct.

line 2 adjust shipment dated on 10/11/2014. Adjustment amount is 12. This is not correct as it should be 37.50 (150 units *105.50 new cost -15787.50)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0071089)
hgbot (developer)
2014-10-21 13:56

Repository: erp/devel/pi
Changeset: 2c476c2bc32821131d9a6f8878db795bee3ce330
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Tue Oct 21 13:55:05 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2c476c2bc32821131d9a6f8878db795bee3ce330 [^]

Fixes issue 27853: Manual Cost Correction Cost adjustments are not properly created

---
M src/org/openbravo/costing/AverageCostAdjustment.java
M src/org/openbravo/costing/CostAdjustmentUtils.java
M src/org/openbravo/costing/CostingBackground.java
---
(0071091)
psanjuan (manager)
2014-10-21 14:57

Verify.

See https://docs.google.com/a/openbravo.com/spreadsheets/d/1Ilm1oct0vH4iKFlI1I0VbmYM-r8fdo1moK02jd2Zigg/edit#gid=1025660841 [^]

product "Costing H1"
(0071137)
umartirena (developer)
2014-10-23 16:52

Reopened due to an extra record in Costing tab is created that is not necessary.
(0071138)
hgbot (developer)
2014-10-23 16:58

Repository: erp/devel/pi
Changeset: eb511c7f7b05c667f765bfa212515f327161f3aa
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Oct 23 16:57:58 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/eb511c7f7b05c667f765bfa212515f327161f3aa [^]

Related to Issue 27853: Not any more wrong records created in Costing tab

Changed the filter by Id in CostAdjustmentUtils.getStockOnTransactionDate(), CostAdjustmentUtils.getValuedStockOnTransactionDate() and AverageCostAdjustment.getRelatedTransactions().

---
M src/org/openbravo/costing/AverageCostAdjustment.java
M src/org/openbravo/costing/CostAdjustmentUtils.java
---
(0071226)
psanjuan (manager)
2014-10-28 15:06

Verified that no extra record is created in Costing tab but below two lines:
Line 1 - Cost 105 total movement quantity 100
Line 2 - Cost 105.5 total movement quantity 200
(0072961)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072977)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-13 15:14 psanjuan New Issue
2014-10-13 15:14 psanjuan Assigned To => dmiguelez
2014-10-13 15:14 psanjuan Modules => Core
2014-10-13 15:14 psanjuan Triggers an Emergency Pack => No
2014-10-16 09:55 psanjuan Assigned To dmiguelez => umartirena
2014-10-16 09:55 psanjuan Description Updated View Revisions
2014-10-16 09:55 psanjuan Steps to Reproduce Updated View Revisions
2014-10-16 09:55 psanjuan Proposed Solution updated
2014-10-21 13:56 hgbot Checkin
2014-10-21 13:56 hgbot Note Added: 0071089
2014-10-21 13:56 hgbot Status new => resolved
2014-10-21 13:56 hgbot Resolution open => fixed
2014-10-21 13:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2c476c2bc32821131d9a6f8878db795bee3ce330 [^]
2014-10-21 14:57 psanjuan Note Added: 0071091
2014-10-21 14:57 psanjuan Status resolved => closed
2014-10-23 16:52 umartirena Note Added: 0071137
2014-10-23 16:52 umartirena Status closed => new
2014-10-23 16:52 umartirena Resolution fixed => open
2014-10-23 16:58 hgbot Checkin
2014-10-23 16:58 hgbot Note Added: 0071138
2014-10-28 13:43 umartirena Status new => scheduled
2014-10-28 13:44 umartirena Status scheduled => resolved
2014-10-28 13:44 umartirena Fixed in Version => pi
2014-10-28 13:44 umartirena Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/2c476c2bc32821131d9a6f8878db795bee3ce330 [^] => https://code.openbravo.com/erp/devel/pi/rev/eb511c7f7b05 [^]
2014-10-28 13:44 umartirena Resolution open => fixed
2014-10-28 15:01 psanjuan Steps to Reproduce Updated View Revisions
2014-10-28 15:02 psanjuan Steps to Reproduce Updated View Revisions
2014-10-28 15:06 psanjuan Note Added: 0071226
2014-10-28 15:06 psanjuan Status resolved => closed
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072961
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072977


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker