Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027829
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-10-10 12:002014-12-30 23:26
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision30e8d84ac147
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027829: Grids in parameter windows based on HQL query tables don't work properly depending on the column order

DescriptionThe new parameter windows can display grids based on HQL Query tables.

In order this grids to work well the order of the columns in the hql query, sequence number of the table columns in AD and sequence number of the window fields in AD must be the same. Otherwise, in the first field it shows the first column of the query, even if it does not belong to the column in AD related to it.
Steps To Reproduce1) Go to the [Tables and Columns] window and create a new column for the aprm_orderinvoice table. Put 1 as sequence number.
2) Go to the [Windows, Tabs and fields], navigate to the "Order Invoice P&E" and create a new field for the column created in step 1)
3) Modify the getSelectClause() method in the AddPaymentOrderInvoicesTransformer class to select a value for the column created in step 1). Put the new selected column at the end of the query
4) Execute ant smartbuild and restart tomcat
5) Go to the [Sales Invoice] window and click on the "Add Payment" button. Notice that the values are not being displayed on the correct field.
6) Modify the query and put the new column at the first position. Now everything works fine because the order of the column in the hql query, sequence number of the table column in AD and sequence number of the window field in AD is the same
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0072032)
hgbot (developer)
2014-11-26 13:51

Repository: erp/devel/pi
Changeset: 30e8d84ac147104b91533bc7a68235dc69ba06f8
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Nov 26 13:47:58 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/30e8d84ac147104b91533bc7a68235dc69ba06f8 [^]

Fixes issue 27829: Column order definition in HQL tables does not matter

There was already a mechanism in place to support that the order of the columns in the HQL query is different from the order of the columns in the application dictionary. The problem was that this mechanism was not working properly when the column aliases had uppercase characters, due to a missimg .toLowercase statement in the Entity.getPropertyByColumnName method. Due to this bug the HQLDataSourceService was not able to find the properties of the entity based on the column alias, and was instead using the index of the column to pick the value from the result array, making the column order relevant.

---
M src/org/openbravo/base/model/Entity.java
---
(0072190)
alostale (developer)
2014-12-01 12:31

Code reviewed.

Tested by changing column position and using lower/upper cases
(0073148)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-10 12:00 caristu New Issue
2014-10-10 12:00 caristu Assigned To => AugustoMauch
2014-10-10 12:00 caristu Modules => Core
2014-10-10 12:00 caristu Triggers an Emergency Pack => No
2014-10-10 12:17 caristu Issue Monitored: networkb
2014-10-10 12:18 caristu version => pi
2014-11-10 10:52 alostale Assigned To AugustoMauch => NaroaIriarte
2014-11-10 10:52 alostale Assigned To NaroaIriarte => AugustoMauch
2014-11-26 13:50 AugustoMauch Issue Monitored: alostale
2014-11-26 13:51 AugustoMauch Review Assigned To => alostale
2014-11-26 13:51 hgbot Checkin
2014-11-26 13:51 hgbot Note Added: 0072032
2014-11-26 13:51 hgbot Status new => resolved
2014-11-26 13:51 hgbot Resolution open => fixed
2014-11-26 13:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/30e8d84ac147104b91533bc7a68235dc69ba06f8 [^]
2014-12-01 12:31 alostale Note Added: 0072190
2014-12-01 12:31 alostale Status resolved => closed
2014-12-01 12:31 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073148


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker