Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027769
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-10-06 11:532014-12-30 23:22
ReportermtaalView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision7198f6b050d3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2014-07-14
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^]
Triggers an Emergency PackNo
Summary

0027769: Record id shown in grid filtering, when adding a new column to the grid

DescriptionWhen filtering on a Foreign Key and then adding a column to the grid, the result is that the FK filter changes and shows the ID of the record.

See here:
http://screencast.com/t/p2Axbnt6TW [^]

Note the jing movie shows the case that there are multiple records with the same identifier, but the issue can also be reproduced by filtering on a record with a unique identifier.
Steps To Reproduce.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0025211 closedAugustoMauch Filter by selected value in FK uses identifier instead of ID 
related to defect 00302743.0PR15Q4 closedcaristu In saved views with multiple criteria in one field, the uuid value is shown in the column header when filtering sometimes 

-  Notes
(0070759)
alostale (developer)
2014-10-07 08:52

This can be reproduced also when hiding a column from grid.
(0070766)
hgbot (developer)
2014-10-07 13:18

Repository: erp/devel/pi
Changeset: c8400accd26c4125ebe15dfdfcc26705afa9bf74
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 07 13:16:06 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c8400accd26c4125ebe15dfdfcc26705afa9bf74 [^]

Fixes issue 27769: Record id not shown in the filter when a new field is added

When a foreign key field is being filtered using its id (i.e. by selecting a record from its drop down), its filterType property is set to 'id'. This property is then used in several places like in the getCriterion and getCriterion. The problem was that when adding/removing a field from the grid, the filter fields are rebuilt from scratch and the filterType property was being reset to its default value ('identifier'). To fix this, the list of foreign key fields being filtered by their id is stored before resetting the filter fields, and consulted when initializing the foreign key fields.

Also the foreign key cache needs to be persisted in order to be able to obtain the record's identifier given its id (in the criteria only the id is stored).

The getFKFilterAuxiliaryCache function has been moved from OBViewGrid to OBGrid so that it can also be used in Pick&Execute grids. This has no risk, as it did not use any code specific from OBViewGrid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0070774)
alostale (developer)
2014-10-07 14:34

Reopening, failed test cases 5 and 6 (see below)

Test cases:

All of them executed in sales order window, in all the cases check BP is filtered correctly and "==Alimentos y Supermercados" appears in the filter text box.

1. Add new grid column --> OK
  1.1 Clear filters
  1.2 Filter BP by Alimentos y Supermercados
  1.3 Add Warehouse column

2. Remove grid column --> OK
  2.1 Clear filters
  2.2 Filter BP by Alimentos y Supermercados
  2.3 Remove Warehouse column

3. Saved view --> OK
  3.1 Save view
  3.2 Close Sales Order window
  3.3 Reopen Sales Order window
  3.4 Applied saved view
  
4. Saved default view --> OK
  4.1 Select saved view as default
  4.2 Close Sales Order window
  4.3 Reopen Sales Order window
  
5. Direct link from Quick Launch --> FAIL (was working in live)
  5.1 Get direct link having the filter applied
  5.2 Copy direct link in Quick Launch
       --> filter is correctly applied but ID is seen in filter text box

6. Direct link from URL --> FAIL (was working in live)
  6.1 Get direct link having the filter applied
  6.2 Copy direct link in URL
       --> filter is correctly applied but ID is seen in filter text box
(0070775)
hgbot (developer)
2014-10-07 16:05

Repository: erp/devel/pi
Changeset: 7198f6b050d38d2e02db062f9f192e80344bf29e
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 07 16:04:45 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7198f6b050d38d2e02db062f9f192e80344bf29e [^]

Fixes issue 27769: Record id not shown when opening link from URL

In the OBGrid.setFields function, the originally named fkCache was meant to store the information needed to restore the state of the foreign key columns after resetting the fields. The scope of that auxiliary cache was setField function, that is why it is deleted from the object before leaving the function.

The problem was that 'fkCache' was already being used to name another property. This property stores the id-identifier pairings of the criterias saved in direct links. As that property was being removed when the grid fields were set, if a tab was opened using a direct link the criterias on the foreign key columns showed their ids.

This problem has been fixed by renaming the temporal property used in the setFields function.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0070792)
alostale (developer)
2014-10-08 08:35

Code reviewed

Tested with the cases described in note above.

Added those test cases to test link: http://tools.openbravo.com:8891/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-7869 [^]
(0072909)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072912)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-06 11:53 mtaal New Issue
2014-10-06 11:53 mtaal Assigned To => AugustoMauch
2014-10-06 11:53 mtaal Modules => Core
2014-10-06 11:53 mtaal Triggers an Emergency Pack => No
2014-10-06 11:55 mtaal Target Version 3.0PR14Q4 =>
2014-10-07 08:40 alostale Regression level => Packaging and release
2014-10-07 08:40 alostale Regression date => 2014-07-14
2014-10-07 08:40 alostale Regression introduced in release => main
2014-10-07 08:40 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^] http://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^]
2014-10-07 08:40 alostale Priority normal => immediate
2014-10-07 08:40 alostale Severity major => minor
2014-10-07 08:40 alostale Regression introduced by commit http://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^] http://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^] => http://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^]
2014-10-07 08:40 alostale Relationship added caused by 0025211
2014-10-07 08:52 alostale Note Added: 0070759
2014-10-07 08:53 alostale version 3.0PR14Q2.5 => main
2014-10-07 13:16 AugustoMauch Issue Monitored: alostale
2014-10-07 13:16 AugustoMauch Review Assigned To => alostale
2014-10-07 13:18 hgbot Checkin
2014-10-07 13:18 hgbot Note Added: 0070766
2014-10-07 13:18 hgbot Status new => resolved
2014-10-07 13:18 hgbot Resolution open => fixed
2014-10-07 13:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c8400accd26c4125ebe15dfdfcc26705afa9bf74 [^]
2014-10-07 14:34 alostale Note Added: 0070774
2014-10-07 14:34 alostale Status resolved => new
2014-10-07 14:34 alostale Resolution fixed => open
2014-10-07 16:05 hgbot Checkin
2014-10-07 16:05 hgbot Note Added: 0070775
2014-10-07 16:05 hgbot Status new => resolved
2014-10-07 16:05 hgbot Resolution open => fixed
2014-10-07 16:05 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/c8400accd26c4125ebe15dfdfcc26705afa9bf74 [^] => http://code.openbravo.com/erp/devel/pi/rev/7198f6b050d38d2e02db062f9f192e80344bf29e [^]
2014-10-08 08:35 alostale Note Added: 0070792
2014-10-08 08:35 alostale Status resolved => closed
2014-10-08 08:35 alostale Fixed in Version => 3.0PR14Q4
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072909
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072912
2015-06-29 13:08 egoitz Relationship added related to 0030274


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker