Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027743
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-10-02 16:052014-12-30 23:22
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision408e2537962c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toinigosanchez
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2014-08-11
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/0276fa6a664f5b9b0c9e690d1a45d55da86f792b [^]
Triggers an Emergency PackNo
Summary

0027743: ant target run.api.test.javascript is broken after latest junit changes

DescriptionRunning that target does not find its .class anymore.

Looks like that internal target from src/build.xml was missing to be moved to src-test in that project as the others were.
Steps To Reproduceant run.api.test.javascript -Dapi.test.javascript.details=/tmp -DjsPath=web/ -Dexport=yes
TagsNo tags attached.
Attached Files? file icon 27743.export [^] (2,340 bytes) 2014-10-03 08:14

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0027290 closedinigosanchez Upgrade all test cases of JUnit (Version 4.11) 

-  Notes
(0070674)
alostale (developer)
2014-10-03 07:54
edited on: 2014-10-03 07:54

Tested by executing the task explained in the steps to reproduce. It generates *.details files in /tmp with info about global js functions + variables.

(0070675)
alostale (developer)
2014-10-03 08:14

attached export as pi is frozen
(0070701)
hgbot (developer)
2014-10-03 15:24

Repository: erp/devel/pi
Changeset: 408e2537962c05b167370a0eb7b5fbc44f0db85e
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Oct 03 07:51:10 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/408e2537962c05b167370a0eb7b5fbc44f0db85e [^]

fixed bug 27743: ant target run.api.test.javascript is broken

  JavaScriptAntTest ant task was moved to src-test but the ant task in build.xml
  invoking it was not.

  Build.xml files have been changed to reflect new location.

---
M build.xml
M src-test/build.xml
M src/build.xml
---
(0070722)
inigosanchez (developer)
2014-10-06 08:52

Code reviewed and tested in pi@408e2537962c

Test cases:
-Tested by executing the task explained in the steps to reproduce: VERIFIED
(0072890)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-02 16:05 shuehner New Issue
2014-10-02 16:05 shuehner Assigned To => AugustoMauch
2014-10-02 16:05 shuehner Modules => Core
2014-10-02 16:05 shuehner Regression level => Packaging and release
2014-10-02 16:05 shuehner Triggers an Emergency Pack => No
2014-10-03 07:29 alostale Relationship added caused by 0027290
2014-10-03 07:30 alostale Regression date => 2014-08-11
2014-10-03 07:30 alostale Regression introduced in release => main
2014-10-03 07:30 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/0276fa6a664f5b9b0c9e690d1a45d55da86f792b [^]
2014-10-03 07:30 alostale Assigned To AugustoMauch => alostale
2014-10-03 07:49 alostale Steps to Reproduce Updated View Revisions
2014-10-03 07:54 alostale Note Added: 0070674
2014-10-03 07:54 alostale Note Edited: 0070674 View Revisions
2014-10-03 08:14 alostale File Added: 27743.export
2014-10-03 08:14 alostale Note Added: 0070675
2014-10-03 10:22 inigosanchez Status new => acknowledged
2014-10-03 10:22 inigosanchez Status acknowledged => scheduled
2014-10-03 10:22 inigosanchez fix_in_branch => pi
2014-10-03 15:24 hgbot Checkin
2014-10-03 15:24 hgbot Note Added: 0070701
2014-10-03 15:24 hgbot Status scheduled => resolved
2014-10-03 15:24 hgbot Resolution open => fixed
2014-10-03 15:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/408e2537962c05b167370a0eb7b5fbc44f0db85e [^]
2014-10-06 08:28 alostale Review Assigned To => inigosanchez
2014-10-06 08:52 inigosanchez Note Added: 0070722
2014-10-06 08:52 inigosanchez Status resolved => closed
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072890


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker