Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027728
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-10-01 18:512014-12-30 23:24
ReportercaristuView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision3161d514a07c
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027728: Query/List Widgets should not display links for Portal Roles

DescriptionQuery/List Widgets should not display links for Portal Roles, as Portal Roles can't navigate to the windows of the ERP.
Steps To Reproduce1) Create a new Portal Role
2) Add the "Pending Goods Receipt" widget to the workspace of the Portal Role
3) Notice that the widget appears with link in the Documentno column
   Currently the behavior is correct as the Portal Role can't navigate when clicking on the links.

  But it would be a more intuitive appearance for the user if these links wouldn't be rendered for the Portal Roles.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0071460)
hgbot (developer)
2014-11-06 13:17

Repository: erp/devel/pi
Changeset: 3161d514a07cd0ca5d5f1e116bfc4c62e8b5278c
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Nov 06 13:11:15 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3161d514a07cd0ca5d5f1e116bfc4c62e8b5278c [^]

fixed bug 27728: Query/List Widgets should not display links for Portal Roles.

The problem was that query/List Widgets display links for Portal Roles and
Portal Roles can't navigate to the windows of the ERP.

To solve this problem, it checks if it is Portal Role and in this case the link
is not displayed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.querylist/web/org.openbravo.client.querylist/js/ob-querylist-widget.js
---
(0071510)
alostale (developer)
2014-11-10 08:55

code reviewed

tested with standard and portal roles
(0073021)
hudsonbot (developer)
2014-12-30 23:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-01 18:51 caristu New Issue
2014-10-01 18:51 caristu Assigned To => AugustoMauch
2014-10-01 18:51 caristu Modules => Core
2014-10-01 18:51 caristu Triggers an Emergency Pack => No
2014-10-01 18:51 caristu Issue Monitored: networkb
2014-10-01 19:11 caristu Type defect => design defect
2014-10-02 08:42 caristu Target Version 3.0PR15Q1 =>
2014-10-02 10:46 caristu Type design defect => defect
2014-10-02 10:46 caristu Target Version => 3.0PR15Q1
2014-10-08 16:02 alostale Assigned To AugustoMauch => inigosanchez
2014-11-06 13:15 inigosanchez Issue Monitored: alostale
2014-11-06 13:16 inigosanchez Review Assigned To => alostale
2014-11-06 13:17 hgbot Checkin
2014-11-06 13:17 hgbot Note Added: 0071460
2014-11-06 13:17 hgbot Status new => resolved
2014-11-06 13:17 hgbot Resolution open => fixed
2014-11-06 13:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3161d514a07cd0ca5d5f1e116bfc4c62e8b5278c [^]
2014-11-10 08:55 alostale Note Added: 0071510
2014-11-10 08:55 alostale Status resolved => closed
2014-11-10 08:55 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:24 hudsonbot Checkin
2014-12-30 23:24 hudsonbot Note Added: 0073021


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker