Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027706
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-09-29 13:022014-09-30 22:33
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchpiFixed in SCM revisionedf09f403355
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-07-14
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^]
Triggers an Emergency PackNo
Summary

0027706: Wrong filtering when there are records with the same identifier

DescriptionWrong filtering when there are records with the same identifier. The problem is caused because the criteria is using the same ID for both records, instead of using the corresponding identifier for each one:

{"operator":"or","criteria":[{"fieldName":"businessPartner","operator":"equals","value":"35BBCB75B5D64F87B3BA5C5E7984E733"},{"fieldName":"businessPartner","operator":"equals","value":"35BBCB75B5D64F87B3BA5C5E7984E733"}],"fieldName":"businessPartner","_constructor":"AdvancedCriteria"}
Steps To Reproduce1) Create a new business partner with a name exactly as one of the already existing business partners, for example: Alimentos y Supermercados, S.A
2) Go to the [Sales Invoice] window, and create a new Sales Invoice for the new business partner. Complete it.
3) Clear all the filters. Using the drop-down list, select the two entries for "Alimentos y Supermercados, S.A.". Notice that is only showing records for one of them.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0025211 closedAugustoMauch Filter by selected value in FK uses identifier instead of ID 
related to defect 0027768 closedAugustoMauch Records with multiple identifiers result in multiple parts in the filter field in grid filtering 
related to defect 0028388 closedalostale Unexpected behavior after reopen "Transaction Document" dropdown selector with selected filter. 

-  Notes
(0070506)
hgbot (developer)
2014-09-29 17:48

Repository: erp/devel/pi
Changeset: edf09f403355011408c33f2136e33af137c18923
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Sep 29 17:41:21 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/edf09f403355011408c33f2136e33af137c18923 [^]

Fixes issue 27706: fk filters work having several records with same identifier

The problem was that the new way if filtering foreign keys by using their ids instead of their identifiers did not support having several records with the same identifier. Note that this is a corner case, as it should not happen that two records in the same table have the same identifier.

To fix this, the getRecordIdFromIdentifier function has been reworked to getRecordIdsFromIdentifier, because a given identifier can hit several records, each one with its own id. Now, if for instance the user clicks on the identifier x, and there are several records with the x identifier, all those records will be checked in the picklist.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0070508)
AugustoMauch (developer)
2014-09-29 17:49

Reopened to enter regression fields
(0070533)
shankarb (developer)
2014-09-30 08:05

Code reviewed and verified in pi changeset 6c864add1905
(0070586)
hudsonbot (developer)
2014-09-30 22:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2cae02185081 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-09-29 13:02 caristu New Issue
2014-09-29 13:02 caristu Assigned To => AugustoMauch
2014-09-29 13:02 caristu Modules => Core
2014-09-29 13:02 caristu Regression level => Pre packaging ( pi )
2014-09-29 13:02 caristu Regression introduced in release => pi
2014-09-29 13:02 caristu Triggers an Emergency Pack => No
2014-09-29 13:02 caristu Issue Monitored: networkb
2014-09-29 13:07 caristu Steps to Reproduce Updated View Revisions
2014-09-29 13:15 caristu Description Updated View Revisions
2014-09-29 13:15 caristu Steps to Reproduce Updated View Revisions
2014-09-29 17:42 AugustoMauch Issue Monitored: shankarb
2014-09-29 17:42 AugustoMauch Review Assigned To => shankarb
2014-09-29 17:48 hgbot Checkin
2014-09-29 17:48 hgbot Note Added: 0070506
2014-09-29 17:48 hgbot Status new => resolved
2014-09-29 17:48 hgbot Resolution open => fixed
2014-09-29 17:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/edf09f403355011408c33f2136e33af137c18923 [^]
2014-09-29 17:49 AugustoMauch Note Added: 0070508
2014-09-29 17:49 AugustoMauch Status resolved => new
2014-09-29 17:49 AugustoMauch Resolution fixed => open
2014-09-29 17:53 AugustoMauch Relationship added caused by 0025211
2014-09-29 17:53 AugustoMauch Regression date => 2014-07-14
2014-09-29 17:53 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^]
2014-09-29 17:54 AugustoMauch Status new => scheduled
2014-09-29 17:54 AugustoMauch fix_in_branch => pi
2014-09-29 17:54 AugustoMauch Status scheduled => resolved
2014-09-29 17:54 AugustoMauch Resolution open => fixed
2014-09-30 08:05 shankarb Note Added: 0070533
2014-09-30 08:05 shankarb Status resolved => closed
2014-09-30 08:05 shankarb Fixed in Version => 3.0PR14Q4
2014-09-30 22:33 hudsonbot Checkin
2014-09-30 22:33 hudsonbot Note Added: 0070586
2014-10-06 11:50 mtaal Relationship added related to 0027768
2014-12-16 13:58 alostale Relationship added related to 0028388


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker