Anonymous | Login
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Offline Modemajorhave not tried2014-09-25 16:102014-10-10 10:55
ReporterplujanView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in VersionRR15Q1
StatusclosedFix in branchFixed in SCM revisionebfdefb948d2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo

0027688: Offline mode does not detect signal is back if no session was created in the Backend

DescriptionWhile working in Offline mode, application behaviour is not the same if the login was made online or offline. If offline at login time, the session is not created in the Backend, so whenever online ability is detected it should take the user to login page. This does not happen though.
Steps To Reproduce1. Test the online login first. With a proper Internet connectivity, login in the frontend.
2. Disconnect the computer from the Internet
3. Create an order. Check that since it is offline, there will be no "Order XXX has ben closed" success message. Check that the order has not being created in the backend neither.
4. Reconnect the Internet
5. Create a second order. Now it should detect the online ability and show a message "All pending orders have been processed". Check that this order and the previous one were synchronised to the server.
6. Logout
7. Disconnect the Internet for checking the login from offline mode.
8. Logging in and creating orders should be not different from the first steps.
9. Reconnect the Internet.
10. Create another order. Expected behaviour is to get the online mode detected but since there was not a previous session created, a message asking by a new login should be shown. However, this does not happen and the frontend keeps working on offline mode.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
marvintm (developer)
2014-10-07 13:19

Apart from the case described, there is also a minor issue related to this problem. If you log in online, and then you lose the session (for example, due to a server restart), the system will not notice the next request that the server has come back but you need to log in again.

Instead, it will take up to one minute to notice, and then the popup prompting to log in again will be shown.

The change we are going to do will solve both issues: in case you logged online, the system will notice immediately after a request that the user needs to log in again. In case you logged offline, it will also notice immediately after any operation which attempts to do a request to the server that a login is required.
hgbot (developer)
2014-10-07 17:13

Repository: erp/pmods/
Changeset: ebfdefb948d232898806827fd601ffef2aa02c77
Author: Antonio Moreno <antonio.moreno <at>>
Date: Tue Oct 07 17:13:02 2014 +0200
URL: [^]

Fixed issue 27688. Now triggerOffline will immediately check connectivity status.

M web/
migueldejuana (developer)
2014-10-10 10:55

Tested and reviewed in 9f470354180c

- Issue History
Date Modified Username Field Change
2014-09-25 16:10 plujan New Issue
2014-09-25 16:10 plujan Assigned To => marvintm
2014-09-25 16:10 plujan Triggers an Emergency Pack => No
2014-10-07 13:19 marvintm Note Added: 0070767
2014-10-07 17:13 hgbot Checkin
2014-10-07 17:13 hgbot Note Added: 0070779
2014-10-07 17:13 hgbot Status new => resolved
2014-10-07 17:13 hgbot Resolution open => fixed
2014-10-07 17:13 hgbot Fixed in SCM revision => [^]
2014-10-10 10:55 migueldejuana Review Assigned To => migueldejuana
2014-10-10 10:55 migueldejuana Note Added: 0070862
2014-10-10 10:55 migueldejuana Status resolved => closed
2014-10-10 10:55 migueldejuana Fixed in Version => RR15Q1

Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker