Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027679
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-09-25 10:352014-09-26 19:08
ReporteralostaleView Statuspublic 
Assigned Toshankarb 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchpiFixed in SCM revision653cc6909012
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-02-26
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
Triggers an Emergency PackNo
Summary

0027679: can't use FK drop down if grid is already filtered by a relative date

DescriptionFilter drop down for FK columns doesn't show any value when the grid is already filtered by a relative date.

This is the backend error:
7bb7455f 856619 [http-8080-3] ERROR org.openbravo.service.json.DefaultJsonDataService - Invalid filter value {"_constructor":"RelativeDate","value":"$today","rangePosition":"end"}.
org.openbravo.base.exception.OBException: Invalid filter value {"_constructor":"RelativeDate","value":"$today","rangePosition":"end"}.

The problem is in the request that is sent in this case, the criteria uses the RelativeDate which is not implemented in Backed.

Previous to 3.0PR14Q2 the criteria parameter converted relative date into absolute date, so it looked like:
criteria:{"fieldName":"orderDate","operator":"lessOrEqual","value":"2014-09-25T21:59:59","_constructor":"AdvancedCriteria"}
Steps To Reproduce-Open Sales Order window
-Filter Order Date field selecting To Today in the filter popup
-Try to open Business Partner drop down list to filter by this field -> No items to show is displayed

Proposed SolutionChange client to work as it did previous to Q2 converting relative into absolute dates
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 
causes defect 0029010 closedAugustoMauch the grid is filtering by relative date not the absolute 

-  Notes
(0070418)
hgbot (developer)
2014-09-26 07:39

Repository: erp/devel/pi
Changeset: 653cc69090124def179091b96d9d2d820cc47d2b
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Sep 25 17:06:26 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/653cc69090124def179091b96d9d2d820cc47d2b [^]

Fixes Issue 27679: can't use FK drop down if grid is already filtered by a relative date

Convert relative dates in criteria to absolute dates.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0070429)
alostale (developer)
2014-09-26 09:49

code reviewed

tested:
- following issue's steps to reproduce
- saving a view with this filter work fine
(0070454)
hudsonbot (developer)
2014-09-26 19:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/37b816a315f2 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-09-25 10:35 alostale New Issue
2014-09-25 10:35 alostale Assigned To => AugustoMauch
2014-09-25 10:35 alostale Modules => Core
2014-09-25 10:35 alostale Regression level => Production - Confirmed Stable
2014-09-25 10:35 alostale Triggers an Emergency Pack => No
2014-09-25 10:37 alostale Regression introduced in release => 3.0PR14Q2
2014-09-25 10:47 alostale Assigned To AugustoMauch => shankarb
2014-09-25 13:35 shankarb Regression date => 2014-02-26
2014-09-25 13:35 shankarb Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
2014-09-25 13:38 shankarb Review Assigned To => alostale
2014-09-25 13:38 shankarb Issue Monitored: alostale
2014-09-26 07:39 hgbot Checkin
2014-09-26 07:39 hgbot Note Added: 0070418
2014-09-26 07:39 hgbot Status new => resolved
2014-09-26 07:39 hgbot Resolution open => fixed
2014-09-26 07:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/653cc69090124def179091b96d9d2d820cc47d2b [^]
2014-09-26 09:05 alostale Status resolved => new
2014-09-26 09:05 alostale Resolution fixed => open
2014-09-26 09:05 alostale Relationship added caused by 0025574
2014-09-26 09:05 alostale Status new => scheduled
2014-09-26 09:05 alostale fix_in_branch => pi
2014-09-26 09:06 alostale Status scheduled => resolved
2014-09-26 09:06 alostale Resolution open => fixed
2014-09-26 09:49 alostale Note Added: 0070429
2014-09-26 09:49 alostale Status resolved => closed
2014-09-26 09:49 alostale Fixed in Version => 3.0PR14Q4
2014-09-26 19:08 hudsonbot Checkin
2014-09-26 19:08 hudsonbot Note Added: 0070454
2015-02-25 08:38 alostale Relationship added causes 0029010


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker