Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027674
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformmajoralways2014-09-24 19:182014-11-24 08:57
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchpiFixed in SCM revision3221fd5a8661
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027674: Selected record is lost when the amount of records shown is high

DescriptionThe selected record is lost when the amount of records shown by a view in a tab is high
Steps To Reproduce1) Use an environment which has more that 1000 sales invoices
2) Access to the [Sales Invoice]
3) Remove filters and sort by creation date
4) Create a new record in form view. Click on the "Create Lines From" button to create the invoice fields. Everything works fine
5) Click on the create new record in form button again. From this moment one of this behaviors could happen:
  a) The selected record is lost. Is not possible to click on the "Create Lines From" button
  b) The selected record is not lost yet. Click on the "Create Lines From" button. After clicking on the "OK" button in the popup, the selected record will be lost
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00271693.0PR14Q4 closedshankarb Unexpected behavior in saved views that includes a filter 
depends on design defect 0025811 closedAugustoMauch unnecessary request on grid refresh 

-  Notes
(0070941)
alostale (developer)
2014-10-15 08:56

The problem is caused by the multiple requests doing for record refresh triggered by button execution. See issue 0025811.

When it apparently works fine, it executes:
* 4 Requests to Invoice datasource
* 3 Requests to FIC
* 1 Request to InvoiceLine datasource

When it fails:
* 6 Requests to Invoice datasource
* 3 Requests to FIC
* 1 Request to InvoiceLine datasource
(0071912)
alostale (developer)
2014-11-24 08:56

Fixed by changeset for 0025811
(0071913)
alostale (developer)
2014-11-24 08:57

Tested after 0025811 is fixed. Now it works properly following steps to reproduce.

- Issue History
Date Modified Username Field Change
2014-09-24 19:18 caristu New Issue
2014-09-24 19:18 caristu Assigned To => AugustoMauch
2014-09-24 19:18 caristu Modules => Core
2014-09-24 19:18 caristu Triggers an Emergency Pack => No
2014-09-24 19:19 caristu Target Version => 3.0PR14Q4
2014-09-24 19:19 caristu Issue Monitored: networkb
2014-09-24 19:26 caristu Summary Selected record is lost when the amount of records shown by a view in a tab is high => Selected record is lost when the amount of records shown by a saved view in a tab is high
2014-09-24 19:30 caristu Relationship added related to 0027169
2014-09-24 19:43 heccam Issue Monitored: heccam
2014-09-29 08:31 alostale Target Version 3.0PR14Q4 => 3.0PR15Q1
2014-10-15 08:53 alostale Relationship added depends on 0025811
2014-10-15 08:56 alostale Note Added: 0070941
2014-10-16 09:10 alostale Summary Selected record is lost when the amount of records shown by a saved view in a tab is high => Selected record is lost when the amount of records shown is high
2014-10-16 09:10 alostale Steps to Reproduce Updated View Revisions
2014-11-17 13:41 jonalegriaesarte Type defect => design defect
2014-11-17 13:41 jonalegriaesarte Target Version 3.0PR15Q1 =>
2014-11-24 08:55 alostale Status new => scheduled
2014-11-24 08:55 alostale fix_in_branch => pi
2014-11-24 08:56 alostale Note Added: 0071912
2014-11-24 08:56 alostale Status scheduled => resolved
2014-11-24 08:56 alostale Fixed in Version => 3.0PR15Q1
2014-11-24 08:56 alostale Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3221fd5a8661d7f9dfbfd6d4255bace9834e6535 [^]
2014-11-24 08:56 alostale Resolution open => fixed
2014-11-24 08:57 alostale Review Assigned To => alostale
2014-11-24 08:57 alostale Note Added: 0071913
2014-11-24 08:57 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker