Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027570
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2014-09-10 08:572015-02-04 20:34
ReporterVictorVillarView Statuspublic 
Assigned Tofsoto82 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision5ef45cfcb9a5
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027570: The Business Partner should be filled in the Payment Out Lines

DescriptionThe Business Partner should be filled in the Payment Out Lines
Steps To ReproduceAs group Admin role,
Go to Payment Out window,
  Organization: España Región Norte
  Payment method: transferencia
 Click on Add Details button
Select a Purchase Invoice (example: 10000549, Business Partner: Bebidas Alegres)
Click on Done.

Realise that the Business Partner in the Payment Out Line is blank, but it should be the value of the Business Partner of the invoice, due to is a mandatory Accounting Dimension in the Purchase Invoice document.

The same should appear for other vendors included in the same Payment Out
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033629 closedalostale slow order/invoice grid population in Add Payment 

-  Notes
(0070887)
fsoto82 (developer)
2014-10-11 19:53

As group Admin role,
Go to Payment Out window,
  Organization: España Región Norte
  Payment method: transferencia
 Click on Add Details button
Select a Purchase Invoice (example: 10000549, Business Partner: Bebidas Alegres)
Click on Done.

Verify that every Payment Out Line have their corresponding Business Partner.
(0072797)
hgbot (developer)
2014-12-23 13:05

Repository: erp/devel/pi
Changeset: f5b23fe2295b581ffc074321bfc4eb2bd504626a
Author: Fernando Soto <fernando.soto <at> peoplewalking.com>
Date: Tue Oct 28 21:23:23 2014 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/f5b23fe2295b581ffc074321bfc4eb2bd504626a [^]

Fixed bug 27570: The Business Partner should be filled in the Payment Out Lines

Modified APRM_GEN_PAYMENTSCHEDULE_INV and APRM_GEN_PAYMENTSCHEDULE_ORD to set the business partner to the payment_schedule_detail.
Also added a Modulescript to correct previously entered data.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_ORD.xml
A src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateBpPaymentLine.class
A src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateBpPaymentLineData.class
A src-util/modulescript/src/org/openbravo/modulescript/UpdateBpPaymentLine.java
A src-util/modulescript/src/org/openbravo/modulescript/UpdateBpPaymentLine_data.xsql
---
(0072798)
pramakrishnan (developer)
2014-12-23 13:17

Code review + testing - OK.
(0073263)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073907)
Sandrahuguet (developer)
2015-01-29 15:53

reopened because the modulescript is not correct
(0073912)
hgbot (developer)
2015-01-29 17:52

Repository: erp/devel/pi
Changeset: 5ef45cfcb9a534d138915356f7a3b8f4b133cbf2
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Jan 29 17:22:12 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5ef45cfcb9a534d138915356f7a3b8f4b133cbf2 [^]

Fixed bug 27570 updateBpPaymentLineInvoice is not correct for all scenarios

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateBpPaymentLineData.class
M src-util/modulescript/src/org/openbravo/modulescript/UpdateBpPaymentLine_data.xsql
---
(0073913)
vmromanos (developer)
2015-01-29 17:54

Code review + testing OK

Missing scenario where a PSD is created from an invoice which has been created from an order is now working fine.
(0074197)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-09-10 08:57 VictorVillar New Issue
2014-09-10 08:57 VictorVillar Assigned To => dmiguelez
2014-09-10 08:57 VictorVillar Modules => Core
2014-09-10 08:57 VictorVillar Triggers an Emergency Pack => No
2014-09-10 08:57 VictorVillar Issue Monitored: networkb
2014-09-22 16:36 jonalegriaesarte Target Version 3.0PR14Q4 => 3.0PR15Q1
2014-09-25 17:10 extra Issue Monitored: extra
2014-10-11 19:51 fsoto82 Status new => scheduled
2014-10-11 19:51 fsoto82 Assigned To dmiguelez => fsoto82
2014-10-11 19:51 fsoto82 fix_in_branch => pi
2014-10-11 19:53 fsoto82 Note Added: 0070887
2014-12-23 13:05 hgbot Checkin
2014-12-23 13:05 hgbot Note Added: 0072797
2014-12-23 13:05 hgbot Status scheduled => resolved
2014-12-23 13:05 hgbot Resolution open => fixed
2014-12-23 13:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f5b23fe2295b581ffc074321bfc4eb2bd504626a [^]
2014-12-23 13:17 pramakrishnan Review Assigned To => pramakrishnan
2014-12-23 13:17 pramakrishnan Note Added: 0072798
2014-12-23 13:17 pramakrishnan Status resolved => closed
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073263
2015-01-29 15:52 Sandrahuguet Status closed => new
2015-01-29 15:53 Sandrahuguet Resolution fixed => open
2015-01-29 15:53 Sandrahuguet Note Added: 0073907
2015-01-29 17:52 hgbot Checkin
2015-01-29 17:52 hgbot Note Added: 0073912
2015-01-29 17:52 hgbot Status new => resolved
2015-01-29 17:52 hgbot Resolution open => fixed
2015-01-29 17:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/f5b23fe2295b581ffc074321bfc4eb2bd504626a [^] => http://code.openbravo.com/erp/devel/pi/rev/5ef45cfcb9a534d138915356f7a3b8f4b133cbf2 [^]
2015-01-29 17:54 vmromanos Review Assigned To pramakrishnan => vmromanos
2015-01-29 17:54 vmromanos Note Added: 0073913
2015-01-29 17:54 vmromanos Status resolved => closed
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074197
2016-08-05 11:11 vmromanos Relationship added blocks 0033629


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker