Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027560
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialhave not tried2014-09-09 08:552014-09-22 10:29
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revisionec2461a9b752
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027560: instance mismatch using trial license to refresh an expired instance with no sys identifier

DescriptionWhen fresh professional instance with an expired license and no system identifier (ie. Retail virtual appliance) is activated with a Trial license, it becomes unusable after Tomcat is restarted.

"This professional license is issued for a different Openbravo instance. Therefore, this instance cannot be activated." alert is shown in login and only System Admin can enter the application.
Steps To Reproduce-Download retail appliance: http://releaser1.openbravo.com/releases/3.0RR14Q3/appliances/openbravo-3.0RR14Q3-vmware-i386.zip [^]
-Log in as Openbravo (license is expired so it will log as System Admin)
-DO NOT activate Heartbeat
-Get a Trial License
-Open Instance Activation window and activate with that license
-Restart Tomcat
-Subsequent logins show "This professional license is issued for a different Openbravo instance. Therefore, this instance cannot be activated." message
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0070040)
hgbot (developer)
2014-09-09 09:12

Repository: erp/devel/pi
Changeset: ec2461a9b7529705c4149c809af19e05122ea2d7
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Sep 09 09:10:32 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ec2461a9b7529705c4149c809af19e05122ea2d7 [^]

fixes 27560: can't use expired instance refresed with trial without sys id

  An instance without sys id that was previously activated with an expired license
  and is activated with a trial can't be used anymore. This was caused because:
    -Expired licenses a tried to be renewed behind the scenes to do so, sys id is
     required but as there is none a new one is created but not persisted in DB
    -When requesting trial activation that previously generated sys id is used and
     the licence is associated to it
    -Finally data is refreshed from db, and as the sys id was not persisted a new one
     is created and saved. Causing the mismatch with the id linked to the license

---
M src/org/openbravo/erpCommon/utility/SystemInfo.java
---
(0070226)
shankarb (developer)
2014-09-22 10:29

Code reviewed and verified in pi changeset 99b060690c1f.

- Issue History
Date Modified Username Field Change
2014-09-09 08:55 alostale New Issue
2014-09-09 08:55 alostale Assigned To => alostale
2014-09-09 08:55 alostale Modules => Core
2014-09-09 08:55 alostale Triggers an Emergency Pack => No
2014-09-09 08:57 alostale Review Assigned To => shankarb
2014-09-09 09:12 hgbot Checkin
2014-09-09 09:12 hgbot Note Added: 0070040
2014-09-09 09:12 hgbot Status new => resolved
2014-09-09 09:12 hgbot Resolution open => fixed
2014-09-09 09:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ec2461a9b7529705c4149c809af19e05122ea2d7 [^]
2014-09-22 10:29 shankarb Note Added: 0070226
2014-09-22 10:29 shankarb Status resolved => closed
2014-09-22 10:29 shankarb Fixed in Version => 3.0PR14Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker