Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027322
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-08-13 13:272014-09-25 11:30
ReporterumartirenaView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revisionfa9897fd81dc
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027322: Selectors don't work properly in Parameter Windows if are opened directly from a menu entry

DescriptionSelectors don't work properly in Parameter Windows if are opened directly from a menu entry. The result of the selector is not being filtered properly by organization. This happens because there is not a context parameter called "_org", and in the back end it is expected in that way. Normally this parameter would be retrieved from the row selected in the parent grid when this process is opened in a pop up. But this is not the case.
Steps To ReproduceCreate a process definition with an Organization parameter and a Business Partner parameter.
Create a menu entry that opens this process definition directly.
Realize that the Business Partner selector does not filter by the org of the other parameter(name ad_org_id), neither the logging organization.
Proposed SolutionFind any parameter named "_org", and if it is not found, try to use another one called ad_org_id, or something similar.
TagsNo tags attached.
Attached Files? file icon issue27322.export [^] (1,834 bytes) 2014-09-01 12:49

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0027518 neweduardo_Argal Modules It would be fine if business partner selector could be filtered by the ones that belong to the natural tree of the defined org 

-  Notes
(0069900)
hgbot (developer)
2014-09-01 16:56

Repository: erp/devel/pi
Changeset: 33f4f0a2e46de4c2f6accd0a60cfa303d58466a4
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Sep 01 12:48:37 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/33f4f0a2e46de4c2f6accd0a60cfa303d58466a4 [^]

Fixes issue 27322: Param windows opened from the menu fill in _org parameter

The problem was that the organization used to set the _org parameter was the one of the record selected in the view from where the process window has been opened. If the window is opened from the menu then the _org parameter was not being set, and some validations were not working.

Now, if the parameter window has an ad_org_id parameter and is not empty, its value will be used to set _org. Otherwise the current user organization will be used.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0069901)
AugustoMauch (developer)
2014-09-01 16:57

To test it:
- Install this module: https://code.openbravo.com/erp/mods/org.openbravo.finance.addpaymentcreditpaymentsgrid/ [^]
- Open the Add Payment process from the menu
- Check that the _org parameter is sent in the request done to populate the selectors
(0069920)
hudsonbot (developer)
2014-09-02 19:52

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6b48609f5665 [^]
Maturity status: Test
(0069927)
shankarb (developer)
2014-09-03 07:11

Code reviewed and verified in pi changeset 33f4f0a2e46d
(0070276)
hgbot (developer)
2014-09-23 10:36

Repository: erp/devel/pi
Changeset: fa9897fd81dcd0a07d1cac5b6e16f3fb8d809e6d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Sep 01 12:48:37 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fa9897fd81dcd0a07d1cac5b6e16f3fb8d809e6d [^]

Fixes issue 27322: Param windows opened from the menu fill in _org parameter

If the parameter window has an ad_org_id parameter and is not empty, its value will be used to set _org. Otherwise the current user organization will be used.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0070295)
shankarb (developer)
2014-09-24 08:04

Same fix applied again in reconciliation refactor project merge.
(0070357)
hudsonbot (developer)
2014-09-25 11:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63604e8e17b7 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-08-13 13:27 umartirena New Issue
2014-08-13 13:27 umartirena Assigned To => AugustoMauch
2014-08-13 13:27 umartirena Modules => Core
2014-08-13 13:27 umartirena Triggers an Emergency Pack => No
2014-08-13 13:28 umartirena Target Version => 3.0PR14Q4
2014-08-13 13:41 AugustoMauch Type feature request => defect
2014-09-01 12:49 AugustoMauch File Added: issue27322.export
2014-09-01 16:40 ngarcia Issue Monitored: ngarcia
2014-09-01 16:53 AugustoMauch Issue Monitored: shankarb
2014-09-01 16:54 AugustoMauch Review Assigned To => shankarb
2014-09-01 16:56 hgbot Checkin
2014-09-01 16:56 hgbot Note Added: 0069900
2014-09-01 16:56 hgbot Status new => resolved
2014-09-01 16:56 hgbot Resolution open => fixed
2014-09-01 16:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/33f4f0a2e46de4c2f6accd0a60cfa303d58466a4 [^]
2014-09-01 16:57 AugustoMauch Note Added: 0069901
2014-09-01 17:16 ngarcia Relationship added related to 0027518
2014-09-02 19:52 hudsonbot Checkin
2014-09-02 19:52 hudsonbot Note Added: 0069920
2014-09-03 07:11 shankarb Note Added: 0069927
2014-09-03 07:11 shankarb Status resolved => closed
2014-09-03 07:11 shankarb Fixed in Version => 3.0PR14Q4
2014-09-23 10:36 hgbot Checkin
2014-09-23 10:36 hgbot Note Added: 0070276
2014-09-23 10:36 hgbot Status closed => resolved
2014-09-23 10:36 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/33f4f0a2e46de4c2f6accd0a60cfa303d58466a4 [^] => http://code.openbravo.com/erp/devel/pi/rev/fa9897fd81dcd0a07d1cac5b6e16f3fb8d809e6d [^]
2014-09-24 08:04 shankarb Note Added: 0070295
2014-09-24 08:04 shankarb Status resolved => closed
2014-09-25 11:30 hudsonbot Checkin
2014-09-25 11:30 hudsonbot Note Added: 0070357


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker