Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027303
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-08-11 09:392014-12-15 17:34
ReporteralostaleView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision5051c9b57bb4
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-07-14
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/c028f776d1e6a92bd3005af03146522ec5a90a8b [^]
Triggers an Emergency PackNo
Summary

0027303: direct link filtered by FK column doesn't work

DescriptionWhen a grid is filtered by a FK record selected from drop down list and a direct link is obtained, it doesn't work properly: it tries to apply ID to text identifier.
Steps To Reproduce-Go to Sales Order
-Open BP drop down list and select Alimentos y Supermercados
-Click "Get Direct Link" icon in toolbar and copy it
-Set that link in URL -> Sales Order window is opened but BP is not filtered by Alimentos y Supermercados but by its internal ID, causing no records being shown
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0025211 closedAugustoMauch Filter by selected value in FK uses identifier instead of ID 
related to defect 0027333 closedAugustoMauch direct link filtered by FK column doesn't work in Quick Launch 
related to defect 0027334 closedAugustoMauch direct link obtained after removing default filter still applies them 
related to defect 0024577 closedAugustoMauch "Direct link url which contains explicit criteria" does not work in case of "implicit filter" or "default view" on the window 

-  Notes
(0069295)
hgbot (developer)
2014-08-11 14:03

Repository: erp/devel/pi
Changeset: 5051c9b57bb4f84252323ddfb82512dc2dd58c51
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Aug 11 14:02:52 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5051c9b57bb4f84252323ddfb82512dc2dd58c51 [^]

Fixes issue 27303: direct link filtered by FK column doesn't work

The problem was that the identifier of the foreign key being filtered now is not stored in the criteria itself, because it is filtered using the id. To fix this, the chache with
the map of fk-id, fk-identifiers of the filtered foreign keys is stored in the url, and then applied when the grid filter editor is available.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
---
(0069325)
hudsonbot (developer)
2014-08-12 20:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f93c6f350902 [^]
Maturity status: Test
(0069363)
alostale (developer)
2014-08-14 08:26

Code reviewed and tested

It also fixes 0027333
(0072482)
johnfandl (reporter)
2014-12-15 02:35

Is this supposed to be fixed in PI? Because I still see the same problem testing here:

* https://livebuilds.openbravo.com/erp_pi_pgsql/ [^]
(0072484)
alostale (developer)
2014-12-15 08:18

Hi John,

I've just tested it in livebuilds pi following the steps described in this issue and it works fine for me.

If you still see the problem, can you detail the steps you follow to reproduce?

Thanks
(0072520)
johnfandl (reporter)
2014-12-15 17:34

-Go to Sales Order
-Open BP drop down list and select Alimentos y Supermercados
-Click "Get Direct Link" icon in toolbar and copy it
-Set that link in Quick Launch-> Sales Order window is opened but BP is not filtered by Alimentos y Supermercados

So, same as your steps except using quicklaunch not separate browser tab (separate browser tab makes no sense from user perspective)

- Issue History
Date Modified Username Field Change
2014-08-11 09:39 alostale New Issue
2014-08-11 09:39 alostale Assigned To => AugustoMauch
2014-08-11 09:39 alostale Modules => Core
2014-08-11 09:39 alostale Triggers an Emergency Pack => No
2014-08-11 09:39 alostale Relationship added caused by 0025211
2014-08-11 09:40 alostale Regression level => Pre packaging ( pi )
2014-08-11 09:40 alostale Regression date => 2014-07-14
2014-08-11 09:40 alostale Regression introduced in release => main
2014-08-11 09:40 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/c028f776d1e6a92bd3005af03146522ec5a90a8b [^]
2014-08-11 13:58 AugustoMauch Issue Monitored: alostale
2014-08-11 13:59 AugustoMauch Review Assigned To => alostale
2014-08-11 14:03 hgbot Checkin
2014-08-11 14:03 hgbot Note Added: 0069295
2014-08-11 14:03 hgbot Status new => resolved
2014-08-11 14:03 hgbot Resolution open => fixed
2014-08-11 14:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5051c9b57bb4f84252323ddfb82512dc2dd58c51 [^]
2014-08-12 20:57 hudsonbot Checkin
2014-08-12 20:57 hudsonbot Note Added: 0069325
2014-08-14 08:25 alostale Relationship added related to 0027333
2014-08-14 08:26 alostale Note Added: 0069363
2014-08-14 08:26 alostale Status resolved => closed
2014-08-14 08:26 alostale Fixed in Version => 3.0PR14Q4
2014-08-14 08:32 alostale Relationship added related to 0027334
2014-12-15 02:34 johnfandl Issue Monitored: johnfandl
2014-12-15 02:35 johnfandl Note Added: 0072482
2014-12-15 08:18 alostale Note Added: 0072484
2014-12-15 17:34 johnfandl Note Added: 0072520
2014-12-29 13:01 AugustoMauch Relationship added related to 0024577


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker